LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-19-2008, 12:59 AM   #16
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15

When I did ssh from board to computer with -X, x server is running on board because I can see computer's applications on my board's LCD display..

As I know X server is properly installed..
Still, do you know which are the libraries and resources are necessory..??

when I did ssh from computer to board first time,~/.Xauthority file has been generated..
Now I am having ~/.Xauthority file on both board and computer..

Is there any relationship between x server and port 60xx..??
port 6000 is listening to something on my board but in computer, it is not there..

What should be the value of DISPLAY..??how to set it parmanently??
I am having only one display for the board..

Any suggessions??

Thank you..

Last edited by vasudharao; 03-19-2008 at 01:11 AM.
 
Old 03-19-2008, 01:32 AM   #17
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Port 6000 is for using remote X11 sessions without ssh. For example if you used xhost or xauth for authentication you could start x on the board but use one of your computer screens for the display and input.

If you used xdmcp (uses port 177) you could log in to the board from your computer. The first session you open will use port 6000. If you log on from a second computer, that session will use port 6001.


If you allowed xdmcp you could log in to your board from your desktop.
I use SuSE 10.3. On the login screen in the lower left hand corner I can log into my desktop remotely from my laptop.
It is like being at my desktop for the entire session except for sound. To run amarok, then I need to ssh -X to my laptop's IP and start amarok running on my laptop. ( A bit surreal )

To enable xdmcp, I needed to allow it in YasT2 -> Security & Users -> Local Security by checking "Allow Remote Graphical Login". Then I edited /opt/kde3/share/config/kdm/kdmrc changing
Code:
[Xdmcp]
# Whether KDM should listen to incoming XDMCP requests.
# Default is false
#Enable=false
# The UDP port on which KDM should listen for XDMCP requests. Do not change.
# Default is 177
#Port=177
...

[Xdmcp]
# Whether KDM should listen to incoming XDMCP requests.
# Default is false
Enable=true
# The UDP port on which KDM should listen for XDMCP requests. Do not change.
# Default is 177
#Port=177
I'm behind a NAT router and I am the only user on the LAN at home, so I don't think using xdcmp is too dangerous.
I have port 6000 open for now as well. At least until I'm done playing around with xdmcp.
 
Old 03-19-2008, 02:00 AM   #18
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15
Ok then I can forget about port 6000 rt? because I want x server with ssh only..

The thing is there is no files or directoris with name "xdmcp" in my board....I dont know anything abt this..

But in computer one file is present..i.e.,/usr/lib/pkgconfig/xdmcp.pc

should I install it..is it necossory for xserver to work on board..??

Should I use xhost +..??

Thank you..

Last edited by vasudharao; 03-19-2008 at 02:19 AM.
 
Old 03-19-2008, 06:27 AM   #19
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15
When I do ssh from computer to board and after ssh into board when give "xterm",instead of opening window on computer's screen it will open on board's LCD screen..

Is this because of port 6000 listening on board..??

should I install xdmcp to the board..??
What is the step I can take next..??

Last edited by vasudharao; 03-19-2008 at 06:30 AM.
 
Old 03-20-2008, 05:41 AM   #20
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Could you supply a link to the documentation for this device?
Does the Linux OS come with the unit or did you install it yourself?
 
Old 03-24-2008, 02:29 AM   #21
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15
sorry..I dont have such documents for the device..I searched in google also..
OS is installed by myself..

Thank you..
 
Old 03-24-2008, 02:38 AM   #22
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
I think that the problem may be that X11 wasn't installed properly. The error messages about not finding xauth seem to indicate that. Ssh uses xauth in the background to allow X forwarding permissions.
 
Old 03-24-2008, 05:08 AM   #23
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15
Right now I am not getting any error messages as such..

I have added only /usr/X11R6/bin/xauth from other similar type of board to my board..

Here is the output when I did ssh from host to my board after adding the above..

Code:
[vasudha@localhost ~]$ ssh -X -vvv root@192.168.1.57
OpenSSH_4.3p2, OpenSSL 0.9.8b 04 May 2006
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.1.57 [192.168.1.57] port 22.
debug1: Connection established.
debug3: Not a RSA1 key file /home/vasudha/.ssh/id_rsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /home/vasudha/.ssh/id_rsa type 1
debug3: Not a RSA1 key file /home/vasudha/.ssh/id_dsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /home/vasudha/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.7.1p2
debug1: match: OpenSSH_3.7.1p2 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib
debug2: kex_parse_kexinit: none,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_init: found hmac-md5
debug1: kex: server->client aes128-cbc hmac-md5 none
debug2: mac_init: found hmac-md5
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 128/256
debug2: bits set: 531/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug3: check_host_in_hostfile: filename /home/vasudha/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 4
debug1: Host '192.168.1.57' is known and matches the RSA host key.
debug1: Found key in /home/vasudha/.ssh/known_hosts:4
debug2: bits set: 534/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/vasudha/.ssh/id_rsa (0x8a193a8)
debug2: key: /home/vasudha/.ssh/id_dsa (0x8a19358)
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /home/vasudha/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug1: Offering public key: /home/vasudha/.ssh/id_dsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
root@192.168.1.57's password: 
debug3: packet_send2: adding 64 (len 53 padlen 11 extra_pad 64)
debug2: we sent a password packet, wait for reply
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Entering interactive session.
debug2: callback start
debug2: x11_get_proto: /usr/bin/xauth  list :0.0 2>/dev/null
debug1: Requesting X11 forwarding with authentication spoofing.
debug2: channel 0: request x11-req confirm 0
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 0
debug3: tty_make_modes: ospeed 38400
debug3: tty_make_modes: ispeed 38400
debug3: tty_make_modes: 1 3
debug3: tty_make_modes: 2 28
debug3: tty_make_modes: 3 127
debug3: tty_make_modes: 4 21
debug3: tty_make_modes: 5 4
debug3: tty_make_modes: 6 255
debug3: tty_make_modes: 7 255
debug3: tty_make_modes: 8 17
debug3: tty_make_modes: 9 19
debug3: tty_make_modes: 10 26
debug3: tty_make_modes: 12 18
debug3: tty_make_modes: 13 23
debug3: tty_make_modes: 14 22
debug3: tty_make_modes: 18 15
debug3: tty_make_modes: 30 0
debug3: tty_make_modes: 31 0
debug3: tty_make_modes: 32 0
debug3: tty_make_modes: 33 0
debug3: tty_make_modes: 34 0
debug3: tty_make_modes: 35 0
debug3: tty_make_modes: 36 1
debug3: tty_make_modes: 37 0
debug3: tty_make_modes: 38 1
debug3: tty_make_modes: 39 1
debug3: tty_make_modes: 40 0
debug3: tty_make_modes: 41 1
debug3: tty_make_modes: 50 1
debug3: tty_make_modes: 51 1
debug3: tty_make_modes: 52 0
debug3: tty_make_modes: 53 1
debug3: tty_make_modes: 54 1
debug3: tty_make_modes: 55 1
debug3: tty_make_modes: 56 0
debug3: tty_make_modes: 57 0
debug3: tty_make_modes: 58 0
debug3: tty_make_modes: 59 1
debug3: tty_make_modes: 60 1
debug3: tty_make_modes: 61 1
debug3: tty_make_modes: 62 0
debug3: tty_make_modes: 70 1
debug3: tty_make_modes: 71 0
debug3: tty_make_modes: 72 1
debug3: tty_make_modes: 73 0
debug3: tty_make_modes: 74 0
debug3: tty_make_modes: 75 0
debug3: tty_make_modes: 90 1
debug3: tty_make_modes: 91 1
debug3: tty_make_modes: 92 0
debug3: tty_make_modes: 93 0
debug2: channel 0: request shell confirm 0
debug2: fd 3 setting TCP_NODELAY
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel 0: rcvd adjust 131072
/usr/X11R6/bin/xauth:  creating new authority file /root/.Xauthority

Last edited by vasudharao; 03-24-2008 at 05:10 AM.
 
Old 03-24-2008, 05:23 AM   #24
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Is it working now? Launch a program from the shell. Does the window come up?
 
Old 03-24-2008, 05:29 AM   #25
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15
After I did ssh from host to board, in shell I ran one application..Instead of showing window in host's screen,window comes up in my board's LCD display..

What may be the problem..??

Last edited by vasudharao; 03-24-2008 at 05:30 AM.
 
Old 03-24-2008, 06:10 AM   #26
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15
And also at the same time,on the board ,it looks like application hangs forever....no warning..no error messages..
 
Old 03-24-2008, 07:05 AM   #27
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
After ssh'ing into the board what does "echo $DISPLAY" say?
 
Old 03-24-2008, 07:44 AM   #28
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15
after ssh'ng to board,I got,
[root@INN /root]$echo $DISPLAY
:0.0

Last edited by vasudharao; 03-24-2008 at 07:45 AM.
 
Old 03-24-2008, 07:51 AM   #29
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
It should be something like ":10.0". Do you have your own account on the board. I've never ssh'ed into a root account. I don't know if something may prohibit forwarding X if it is root.
 
Old 03-24-2008, 08:08 AM   #30
vasudharao
LQ Newbie
 
Registered: Feb 2008
Posts: 26

Original Poster
Rep: Reputation: 15
* How to set the value of DISPLAY variable parmanently..??
* I dont have any account on the board..I will create it now..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH X forwarding krusty_lab AIX 10 01-02-2008 10:36 AM
SSH and X forwarding? SlowCoder Linux - Newbie 8 05-28-2006 11:24 PM
SSH X forwarding djgerbavore Linux - Networking 1 11-17-2005 10:40 AM
X forwarding via SSH bd1308 Linux - Software 4 08-30-2005 08:13 PM
ssh and X-forwarding Björneborg Linux - Networking 2 02-19-2004 11:50 AM


All times are GMT -5. The time now is 11:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration