LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-02-2004, 03:22 AM   #1
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
wvdial puzzle..... Can't find phone number!


Hi there

I've tried everything to get Linux to work with my modem (including swapping modems) and am nearly there.

My modem is in and recognised (I think) but still won't work. It looks like an easy fix, but I need some help - please.

I run wvdial and get the following message:


[root@localhost root]# wvdial
--> WvDial: Internet dialer version 1.53
--> Warning: section [Dialer Defaults] does not exist in wvdial.conf.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Configuration does not specify a valid phone number.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.
[root@localhost root]# wvdial


It appears that the modem is working, but that my details like phone number aren't there... but they are! I went to a helpful website that said my details would be in /etc/wvdial.conf so I had a look and yes - there they are.. look.



[Modem0]
Modem = /dev/ttySHSF0
Baud = 57600
SetVolume = 3
Dial Command = ATDT
Init1 = ATZ
FlowControl = CRTSCTS
[Dialer Evemail]
Area Code = 1280
Username = t********@evemail.net
Password = d*******6
Phone = 080******2
Dial Prefix = 1470
Stupid Mode = 1
Inherits = Modem0

which DOES have the phone no and stuff in (asterisks inserted here by me)


So whats going on please? Any ideas?

Thanks in advance.

 
Old 05-02-2004, 03:43 AM   #2
sweet*amber
Member
 
Registered: Apr 2004
Location: Philippines
Distribution: Red Hat 9.0 - Suse 8.0 - Slackware 7.0 - Fedora Core 2 test 3
Posts: 133

Rep: Reputation: 15
hey, i think i can help yah. btw do you have to connect using network something?
1. log in as root
2. open a konsole
3. type /usr/bin/wvdiaconf wvdial.conf
4. type updatedb
5. type kedit /root/wvdial.conf
6. type kedit /etc/wvdial.conf
6. copy [dialer defaults] everything that is written in that .conf, i kinda forgot where the [dialer default] is located whether in /root or /etc just copy everything and paste it in the other .conf
7. paste in the other wvdial.conf
8. copy the init strings its like AT& something like that
9. paste in the init strings in every init1= ................ blah
10. save

btw i connect via network device control

Last edited by sweet*amber; 05-02-2004 at 03:52 AM.
 
Old 05-02-2004, 04:57 AM   #3
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Thanks for that - I'll give it a try.

I'm trying wvdial as no matter what I try I can't get the Network device control to work with my modem.
 
Old 05-02-2004, 09:48 AM   #4
sweet*amber
Member
 
Registered: Apr 2004
Location: Philippines
Distribution: Red Hat 9.0 - Suse 8.0 - Slackware 7.0 - Fedora Core 2 test 3
Posts: 133

Rep: Reputation: 15
this will work. i have the same problem with yours, why don't you reset everything and start again
network congifuration -> network device control and edit your wvdial.conf

i'm also a newbie, but since i was able to make it, so why not share, this might work
 
Old 05-02-2004, 10:42 AM   #5
sweet*amber
Member
 
Registered: Apr 2004
Location: Philippines
Distribution: Red Hat 9.0 - Suse 8.0 - Slackware 7.0 - Fedora Core 2 test 3
Posts: 133

Rep: Reputation: 15
PS: you substitute the phone number, username, password in every <_____> and get your network device control kicking!
 
Old 05-04-2004, 02:43 PM   #6
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Hi there...

Well I tried, but no luck. Excuse me if I have been really silly, but if you type kedit as you said, you get an error - bad command or something like that. I tried to copy it all to floppy but for some reason windows can't read the text file!

Anyway, in both /root and in /etc are two files wvdialconf and wvdial.conf

I'm not sure what the difference the 'dot' makes, but nonetheles there are two files in each.
Both of these files have the correct dialing info in them.

I type wvdial and still get the same message as I gave at the top of this thread.

what is the /usr/bin/wvdial wvdial.conf bit you said to do about? (I did type what you said though)

I had a look inside /usr/bin and again found two files wvdial and wvdial.conf but neither would open in gedit as they were 'probably binary files'

I'll boot up again in Linux in a while and try again to save my terminal typings and stuff, but any help you can give me is SO gratefully received!

Thanks
Adrian
 
Old 05-04-2004, 02:50 PM   #7
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by sweet*amber
PS: you substitute the phone number, username, password in every <_____> and get your network device control kicking!
Oh, one thing I just noticed... I removed the brackets < and > as well as the line when typing in the details.. I suppose that was correct.


Anyway, I got my disc read by textpad and this is what happened.....



[root@localhost root]# /usr/bin/wvdialconf wvdial.conf
Scanning your serial ports for a modem.

Port Scan<*1>: Scanning ttySHSF0 first, /dev/modem is a link to it.
ttySHSF0<*1>: ATQ0 V1 E1 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 Z -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttySHSF0<*1>: Modem Identifier: ATI -- 56000
ttySHSF0<*1>: Speed 4800: AT -- OK
ttySHSF0<*1>: Speed 9600: AT -- OK
ttySHSF0<*1>: Speed 19200: AT -- OK
ttySHSF0<*1>: Speed 38400: AT -- OK
ttySHSF0<*1>: Speed 57600: AT -- OK
ttySHSF0<*1>: Speed 115200: AT -- OK
ttySHSF0<*1>: Max speed is 115200; that should be safe.
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttySHSF0, using link /dev/modem in config.
Modem configuration written to wvdial.conf.
ttySHSF0<Info>: Speed 115200; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"


[root@localhost root]# updatedb


[root@localhost root]# kedit /root/wvdial.conf
bash: kedit: command not found

[root@localhost root]# kedit /etc/wvdial.conf
bash: kedit: command not found




Here is what you find in the wvdial config files:

[Dialer Defaults]
Modem = /dev/modem
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = 1470*******3432
Username = *******@evemail.net
Password = ********

(my asterisks)

I have longer versions of the above config files containing more details that I found elsewhere, but this is the edited version of the new ones in /root and /etc that I edited as you said.


I also tried replacing the above with a fuller version.

..and no, Network Device activate doesn't work either - I get error message 8 whatever that is!
 
Old 05-04-2004, 10:03 PM   #8
sweet*amber
Member
 
Registered: Apr 2004
Location: Philippines
Distribution: Red Hat 9.0 - Suse 8.0 - Slackware 7.0 - Fedora Core 2 test 3
Posts: 133

Rep: Reputation: 15
sorry, i did not point out that kedit is used for kde desktop so if you are using gnome you might want to do this. open the /root and click the wvdial.conf and right click then open with (open with any editor blah blah) (please login as 'root') then again, open the /etc and click the wvdial.conf and right click and open with (again open with any editor) and that's it, do the rest.
 
Old 05-04-2004, 10:05 PM   #9
sweet*amber
Member
 
Registered: Apr 2004
Location: Philippines
Distribution: Red Hat 9.0 - Suse 8.0 - Slackware 7.0 - Fedora Core 2 test 3
Posts: 133

Rep: Reputation: 15
never mind that wvdialconf, just the wvdial.conf ok just fiddle with the settings and try again
 
Old 05-05-2004, 06:34 AM   #10
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
I've fiddled and fiddled.... but still get the same error message:

--> WvDial: Internet dialer version 1.53
--> Warning: section [Dialer Defaults] does not exist in wvdial.conf.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Configuration does not specify a valid phone number.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.
[root@localhost root]# wvdial


I now have three separate wvdial.conf files in different locations EACH with all the correct data in them (as far as I know)....

I must be doing something stupid, but I really am trying hard with this. My modem seems to initialise Ok, but then it says data is missing... but I have supplied the data it wants...


AAAAARRRRGGGGHHH!!!!

(Sorry about that!)
 
Old 05-06-2004, 03:21 AM   #11
sweet*amber
Member
 
Registered: Apr 2004
Location: Philippines
Distribution: Red Hat 9.0 - Suse 8.0 - Slackware 7.0 - Fedora Core 2 test 3
Posts: 133

Rep: Reputation: 15
[dialer defaults} is located in /root/wvdial.conf type in console gedit(for gnome or kedit for kde)
gedit /root/wvdial.conf or
kedit /root/wvdial.conf

select everything written in there [dialer defaults] down till the last line

then open this again, type in console
gedit /etc/wvdial.conf or
kedit /etc/wvdial.conf

and paste the one you copied, and copy your init2 strings (the one you can see with AT&..... blah blah) and paste it in init1
 
Old 05-06-2004, 01:51 PM   #12
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Thanks again for the help sweet*amber .. it is appreciated. However, still no joy. I tried the above, but it didn't work.

I searched around for another solution and I found out from a useful site that if you run wvdialconf <filename> you get your details listed... here have a look:


[root@localhost root]# wvdialconf bloodything
Scanning your serial ports for a modem.

Port Scan<*1>: Scanning ttySHSF0 first, /dev/modem is a link to it.
ttySHSF0<*1>: ATQ0 V1 E1 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 Z -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttySHSF0<*1>: Modem Identifier: ATI -- 56000
ttySHSF0<*1>: Speed 4800: AT -- OK
ttySHSF0<*1>: Speed 9600: AT -- OK
ttySHSF0<*1>: Speed 19200: AT -- OK
ttySHSF0<*1>: Speed 38400: AT -- OK
ttySHSF0<*1>: Speed 57600: AT -- OK
ttySHSF0<*1>: Speed 115200: AT -- OK
ttySHSF0<*1>: Max speed is 115200; that should be safe.
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttySHSF0, using link /dev/modem in config.
bloodything<Warn>: Can't read config file bloodything: No such file or directoryModem configuration written to bloodything.
ttySHSF0<Info>: Speed 115200; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
[root@localhost root]#



So I go to the new file that has been created in root called /root/bloodything and open it and yes, new defaults have been created for me to use as you can see:


[Dialer Defaults]
Modem = /dev/modem
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
; Phone = <Target Phone Number>
; Username = <Your Login Name>
; Password = <Your Password>



At this point, I remove the ';' symbols, then add my details as shown below:


[Dialer Defaults]
Modem = /dev/modem
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = ************** (my asterisks added)
Username = *************
Password = ************


Then I run wvdial in a terminal and get:

[root@localhost root]# wvdial
--> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Configuration does not specify a valid phone number.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.
[root@localhost root]#


I also tried changing the Init1 details to the Init2 ones given above as suggested... but still no good!


A website I looked agrred with you sweet*amber and said that your details are stored in /etc/wvdial.conf so I looked in there (again) and found the details below:

[Dialer Defaults]
[Modem0]
Modem = /dev/ttySHSF0
Baud = 57600
SetVolume = 3
Dial Command = ATDT
Init1 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
FlowControl = CRTSCTS
[Dialer Evemail]
Area Code = 1280
Username = *************** (my asterisks added)
Password = ************
Phone = *********
Dial Prefix = 1470
Stupid Mode = 1
Inherits = Modem0


All these details are valid and I have identical files as the above in /root/wvdial.conf as well as in /etc/wvdial.conf

I modify and cut and paste the details in the /etc/wvdial.conf file as stated, but no joy.


Why Oh Why am I still getting such grief with this ..... look, here it is again:



[root@localhost root]# wvdial
--> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Configuration does not specify a valid phone number.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.
[root@localhost root]#



My new Linux installation (Redhat9) seems to refuse to play ball. Yes I AM supplying a valid phone number!

Please folks... HEEEEEEEELLPPPP!!!!!!!!!
 
Old 05-07-2004, 06:18 AM   #13
sweet*amber
Member
 
Registered: Apr 2004
Location: Philippines
Distribution: Red Hat 9.0 - Suse 8.0 - Slackware 7.0 - Fedora Core 2 test 3
Posts: 133

Rep: Reputation: 15
[Dialer Defaults]
Modem = /dev/modem
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
; Phone = <Target Phone Number>
; Username = <Your Login Name>
; Password = <Your Password>

here's what it should look like:
[Dialer Defaults]
Modem = /dev/modem
Baud = 115200
Init1 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
; Phone = <Target Phone Number>
; Username = <Your Login Name>
; Password = <Your Password>

did you see, i copy the init2 string and paste it in init1?

ok.. don't connect via a terminal or konsole... so instead of typing wvdial to connect, just open your network device control and click the dialer you are using and then click activate... do not connect via wvdial... i have that problem too
 
Old 05-07-2004, 01:02 PM   #14
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Well I tried exactly what you said (and I do appreciate the assistance) but I still get exactly the same error message. I'm happy that I've learned a lot about Linux commands and how stuff works, but still no Internet connection!!

There must be some other problem here now. wvdial doesn't work, neither does ppp0 (never has) as when I try to activate it, it fails with error message 8.

My modem is a winmodem, but with a correct driver for Linux and it should be OK. It works when I boot up in XP and wvdial says it is OK in Linux, it is the details it can't find.

I'm really at a loss to solve this, but will persist as I'm learning new stuff about Linux all the time.

Any suggestions from anywhere/any site/anyone greatfully received.
 
Old 05-08-2004, 08:07 AM   #15
sweet*amber
Member
 
Registered: Apr 2004
Location: Philippines
Distribution: Red Hat 9.0 - Suse 8.0 - Slackware 7.0 - Fedora Core 2 test 3
Posts: 133

Rep: Reputation: 15
is what i've said, do not connect via a terminal by dialing wvdial, instead, just connect by activating your network device control.

that doesn't work?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dist-upgrade wvdial cant find modem short101 Debian 6 03-19-2005 07:48 PM
using wvdial to dial out from behind a phone system. carmalt Linux - Networking 2 04-15-2004 02:55 AM
kppp, phone number error DeNieD Linux - Software 1 08-17-2003 03:50 AM
how do u find AS Number of an IP address? knight_ridda Linux - Networking 4 02-28-2003 01:16 PM
How to find out the port number fmohideen76 Linux - General 3 07-11-2002 08:18 AM


All times are GMT -5. The time now is 10:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration