LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-14-2009, 05:07 PM   #1
boerkees
LQ Newbie
 
Registered: Mar 2008
Location: Beverwijk, Nederland
Distribution: Ubuntu 8.10
Posts: 2

Rep: Reputation: 0
Wrong keys on keyboard when in terminal mode


Hello,

I'm using Ubuntu 9.04 on a desktop (i486) computer with een Fujitsu Siemens keyboard.

When in X-mode, all keys behave like they should, including all the diacrites like etc.

When i switch tot terminal (Ctrl-Alt-F2) and login, Linux thinks i possess a genuine Dutch keyboard.
In X-mode the top row reads (when the Shift-key is pressed):
~ ! @ # $ % ^ & * ( ) _ +
In terminal-mode the top row reads (when the Shift-key is pressed):
╜ ! " # $ % & _ ( ) ' ? ~

This is annoying as i don't know where the / - etc are by heart.

When in terminal mode, how do i change the keyboard layout whithout changing the layout in X-mode??

Kind regard,

Kees de Boer
Beverwijk, Netherlands,
 
Old 05-14-2009, 06:11 PM   #2
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Try running sudo dpkg-reconfigure console-setup to select your preferred layout. Only the keyboard layout should be edited, the rest of the options should be fine (unless you also want a different charset, font size, font style, etc. on your consoles).

Last edited by jay73; 05-14-2009 at 06:13 PM.
 
Old 05-15-2009, 03:51 PM   #3
boerkees
LQ Newbie
 
Registered: Mar 2008
Location: Beverwijk, Nederland
Distribution: Ubuntu 8.10
Posts: 2

Original Poster
Rep: Reputation: 0
Thumbs up

Thanks Jay73,

That did the trick. I ran it and left virtual all configurations as the were, except that i choose the 102-key Intel PC-keyboard with the USA-INTL keyboard layout with dead keys and Alt-Gr for the special characters ( and the like).

Thanks,

With regards,

Kees de Boer,
Beverwijk,
Netherlands
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
In terminal mode, why the arrows and delete keys doesn't work alejandroye Mandriva 5 05-05-2009 01:09 AM
USB keyboard function keys/numeric keys on boot raypen Linux - Hardware 4 04-17-2008 03:07 PM
Keyboard mode keys not working Silverdaz Linux - Laptop and Netbook 0 07-29-2004 10:37 AM
Grey Cat Linux on old laptop...wrong keyboard keys vdogvictor Linux - Laptop and Netbook 0 05-27-2004 12:28 PM
Assigning keyboard shortcuts to keyboard keys the who Linux - Hardware 3 02-20-2004 09:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration