LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2014, 03:13 PM   #1
antarctidaonline
LQ Newbie
 
Registered: Jun 2013
Location: Russia
Distribution: debian wheezy
Posts: 4

Rep: Reputation: Disabled
Wrong keyboard layout


Just installed last version of Ubuntu - and found, that when I press "7" key on my digital keyboard (in right part of keyboard) - system types "1" digit!
"8" instead of "2", "9" instead of "3" and vice versa. I found that keyboard layout is wrong. When I open keyboard layout window, I see that buttons "1", "2", "3" is at top line. They are at bottom line on my keyboard! How can I change keyboard layout so that it will correspond my "hardware" keyboard?
On my Debian linux keyboard worked correctly!
 
Old 08-28-2014, 01:00 AM   #2
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware
Posts: 893

Rep: Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524
This is what you get for switching from Debian to something easier ;-)

You can see what map you ended up with:

Code:
setxkbmap -query
and then set it to your preferred one:

Code:
setxkbmap dvorak
(except instead of dvorak, whatever layout you actually use...)

Hope that solves it!
 
Old 08-28-2014, 12:00 PM   #3
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,162

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
This is nothing to do with the keyboard layout, but with numeric keypad one. I'm not familiar with Ubuntu, but somewhere there should be a keyboard configuration tool where you can set special options. Under Keypad, you should have it set to "default', and yours has been set to "phone-style".
 
Old 08-29-2014, 12:33 PM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,321
Blog Entries: 1

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
$ sudo dpkg-reconfigure keyboard-configuration
 
2 members found this post helpful.
Old 09-14-2014, 06:56 AM   #5
antarctidaonline
LQ Newbie
 
Registered: Jun 2013
Location: Russia
Distribution: debian wheezy
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thumbs up Thanks to Shadow_7!

Shadow_7, dpkg-reconfigure keyboard-configuration was right answer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrong Keyboard layout ukuleleray Linux - Newbie 6 08-17-2014 07:51 AM
Wrong keyboard layout spiky0011 Linux From Scratch 1 05-11-2011 02:09 AM
Wrong keyboard layout at boot vlachakb Linux - Newbie 6 03-26-2009 01:54 AM
keyboard layout is wrong quarry_06 Debian 5 12-14-2005 03:37 PM
Keyboard layout wrong at Mandrake 9.1 depailler Mandriva 1 09-02-2003 07:49 AM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration