LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-01-2008, 05:08 AM   #1
vlachakb
LQ Newbie
 
Registered: Jul 2008
Location: Belgium
Posts: 3

Rep: Reputation: 0
Unhappy Wrong keyboard layout at boot


Yesterday I installed Fedora 9(Gnome)on my Medion Desktop and have an issue with the keyboard layout at boot. I am using a AZERTY(Dutch ver.) Medion wireless keyboard with receiver connected to a USB port.

If I wish to edit GRUB or enter my password at login the keyboard layout is always US. During installation I had selected Dutch layout for keyboard and had noticed that while setting up the password and user account the wrong characters appeared. After first login I set the keyboard to Dutch and within the user account it works fine once logged in. Yet at boot and login screen the layout is always US (have to think where the character of AZERTY are compared to QWERTY).

Can anyone shead some light on this for me.
 
Old 08-01-2008, 05:20 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
In my opinion before FC 9 is active the keyboard works according the settings in the BIOS
So my advice check you,re BIOS settings
 
Old 08-01-2008, 05:29 AM   #3
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
I have never done one, but it sounds like you need to edit your /boot/grub/menu.lst to include

setkey

http://www.gnu.org/software/grub/man...ey.html#setkey

Here is an example

http://www.kanotix.com/index.php?mod...rubBootManager

http://linuxforum.at/agora/beitrag.php?id=106&start=0

In case you need blunt advice...the setkey command must exist one per line in your menu.

I will have to find keyboard layout maps or do you already have them?

here is one
http://en.wikipedia.org/wiki/Keyboard_layout

Last edited by aus9; 08-01-2008 at 05:38 AM.
 
Old 08-07-2008, 01:43 AM   #4
vlachakb
LQ Newbie
 
Registered: Jul 2008
Location: Belgium
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ronlau9 View Post
In my opinion before FC 9 is active the keyboard works according the settings in the BIOS
So my advice check you,re BIOS settings
No entry or option was found in the BIOS that has to do with keyboard layout. Tried installing Mandriva Spring 2008 and have no problems with keyboard layout.

Installing OpenSusse 11.0 and Fedora 9, the keyboard layout at boot is not correct. Very strange...

The method of aus9 works, but I still find it odd That Madriva Spring 2008 has no problem with it. Any ideas, I am curious.

Last edited by vlachakb; 08-07-2008 at 02:00 AM.
 
Old 08-07-2008, 03:01 AM   #5
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Hi,

I was recently surprised to run into the same issue. I am using an nvidia 9600GT, which means I have to use the latest drivers (still a bit beta). Well, all of a sudden I could not log in anymore because my password was rejected for some reason. I tried all sorts of tricks on the command line trying to figure out what was wrong until I realized that my machine had for some reason reverted to US keyboard layout. I had a look at my xorg.conf, and I found out that it did NOT specify any keyboard layout. So I simply copied those two or three lines of information from the xorg.conf.failsafe and the problem appears to be gone. If you haven't got a failsafe, try this:
Quote:
Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection
 
Old 08-10-2008, 12:56 PM   #6
vlachakb
LQ Newbie
 
Registered: Jul 2008
Location: Belgium
Posts: 3

Original Poster
Rep: Reputation: 0
Jay73,

Thanks very much for your advice. It has cured all keyboard layout problems. Your are the MAX...



Quote:
Originally Posted by jay73 View Post
Hi,

I was recently surprised to run into the same issue. I am using an nvidia 9600GT, which means I have to use the latest drivers (still a bit beta). Well, all of a sudden I could not log in anymore because my password was rejected for some reason. I tried all sorts of tricks on the command line trying to figure out what was wrong until I realized that my machine had for some reason reverted to US keyboard layout. I had a look at my xorg.conf, and I found out that it did NOT specify any keyboard layout. So I simply copied those two or three lines of information from the xorg.conf.failsafe and the problem appears to be gone. If you haven't got a failsafe, try this:
 
Old 03-26-2009, 12:54 AM   #7
abcdef
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
Question Have a problem with my keyboard

I have installed fedora 10 in HP 540 laptop.In this single,double qoutes key is not working only this key is not working..
need some help to recover this problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard layout config error 1 key wrong flebber Linux - General 4 12-10-2006 11:46 PM
keyboard layout is wrong quarry_06 Debian 5 12-14-2005 02:37 PM
wrong keyboard layout (Latin America) - SuSE 9.2 retiem Suse/Novell 2 03-14-2005 08:15 AM
Wrong keyboard layout in XFree86 on Compaq Evo n1005v anotherlimey Linux - Laptop and Netbook 0 03-15-2004 01:04 AM
Keyboard layout wrong at Mandrake 9.1 depailler Mandriva 1 09-02-2003 06:49 AM


All times are GMT -5. The time now is 04:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration