LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2004, 02:10 PM   #1
trollman
Member
 
Registered: Jan 2004
Location: Virgina Tech
Posts: 41

Rep: Reputation: 15
write premission on mounted partition


Hello, i just installed Crossover Office, and i have a data partition on my windows harddrive. It hold my office PST file and and My documents and other stuff. The problem i am having is that i cant edit files that are on this shared partition. I dont want to copy the the files over to my linux hard drive because when i go over to windows i wont have the same files. i want Linux and Windows to share the same files.
Is their to make the files that are mounted belong to my user? To sum it up, i was to be able to edit files on this mounted partition. Thanks.

Karl
 
Old 02-12-2004, 03:11 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,793

Rep: Reputation: 292Reputation: 292Reputation: 292
"The problem i am having is that i cant edit files that are on this shared partition."

You did not mention what file system is used on the shared partition. If it is ntfs then the problem is that Linux treats ntfs as read only. If that is your problem then create a small vfat partition for the shared data. vfat can be read/write for both Windows and Linux.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 02-12-2004, 04:54 PM   #3
trollman
Member
 
Registered: Jan 2004
Location: Virgina Tech
Posts: 41

Original Poster
Rep: Reputation: 15
sorry, it is fat, here is my fstab file. Before i made the changes this was the premission of a file on the partition: rwxrwxr-x 1 root users; after i made the changes the premissions look like this: rwxrwxrwx 1 root users. But i still cant save changes i make to files.
 
Old 02-12-2004, 07:30 PM   #4
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,793

Rep: Reputation: 292Reputation: 292Reputation: 292
"sorry, it is fat, here is my fstab file. Before i made the changes this was the premission of a file on the partition: rwxrwxr-x 1 root users; after i made the changes the premissions look like this: rwxrwxrwx 1 root users. But i still cant save changes i make to files."

Your permissions are OK. It is possible for the corresponding entry in /etc/fstab to restrict access to less than what the permissions allow. Could you post your /etc/fstab?

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 02-13-2004, 12:29 PM   #5
trollman
Member
 
Registered: Jan 2004
Location: Virgina Tech
Posts: 41

Original Poster
Rep: Reputation: 15
sorry it took so long to respond, too much work to do, but anyway here is my fstab file:

/dev/hdb5 / reiserfs defaults 1 1

/dev/hda1 /windows/C vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0

#/dev/hda5 /windows/D vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0

/dev/hda5 /windows/D vfat users,gid=users,umask=0000,iocharset=iso8859-1,code=437 0 0

This line that is commented out is the original line in the file. I can open files already on the partition, but can not save changes. I can create new files on the partition, and any changes i make to that file will save.
 
Old 02-13-2004, 02:20 PM   #6
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Did you remount to apply the changes?
mount -a -o remount
 
Old 02-13-2004, 05:25 PM   #7
trollman
Member
 
Registered: Jan 2004
Location: Virgina Tech
Posts: 41

Original Poster
Rep: Reputation: 15
yes i did.
 
Old 02-13-2004, 10:54 PM   #8
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,793

Rep: Reputation: 292Reputation: 292Reputation: 292
"/dev/hda5 /windows/D vfat users,gid=users,umask=0000,iocharset=iso8859-1,code=437 0 0"

I checked the mount man pages and there is no mount option called code. Take a look at:
man mount
section:
Mount options for fat

I suggest that you experiment with the code=437 option in your fstab. Try changing it to codepage=437. You could also try removing ,code=437 from the entry.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 02-14-2004, 11:20 AM   #9
trollman
Member
 
Registered: Jan 2004
Location: Virgina Tech
Posts: 41

Original Poster
Rep: Reputation: 15
hey jailbait, thanks for the help. making the change from "code=437" to "codepage437" made the difference. i can now edit pre-existting files. :O) but sadly it really doesnt help now, the only reason i wanted to be able to do this was so i could run outlook using crossover office, and i just found out that it doesnt support office XP. oh well. Thanks for the help though.

Karl
 
Old 02-14-2004, 01:53 PM   #10
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,793

Rep: Reputation: 292Reputation: 292Reputation: 292
Go Hokies!

----------------------
Steve Stites
Class of 66
 
Old 02-14-2004, 05:14 PM   #11
trollman
Member
 
Registered: Jan 2004
Location: Virgina Tech
Posts: 41

Original Poster
Rep: Reputation: 15
haha, thats awesome. Yea lets go hokies!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounted read-write Fat32 partition suddenly becomes read-only?? hohead Linux - General 8 04-05-2007 01:17 PM
can not write data to Mounted partition thachphathien Linux - Newbie 1 09-30-2004 01:41 PM
Allowing read/write on mounted captive-ntfs partition divsky Linux - General 6 04-15-2004 11:52 AM
Why I can only write in mounted windows partition in "su" mode Allen T Linux - Software 5 02-18-2003 02:10 AM
can't write on mounted windows partition! icecube Linux - Hardware 21 12-07-2002 12:29 PM


All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration