LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-07-2004, 06:41 PM   #1
divsky
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake 10.0 for AMD 64 and SuSE 9.0
Posts: 4

Rep: Reputation: 0
Allowing read/write on mounted captive-ntfs partition


Partial

Recently installed captive-ntfs and it works great. Now I want to have it fully read/write accessible to multiple users (just me and one other person, actually). I've been able to do this for just myself with-
mount -t captive-ntfs -o uid=500 /dev/hda1 /windows/C
But this, obviously, wouldn't let any other users than myself (me having the user id 500) read/write to the drive. So I made a group named winfsa (windows file system access.. I thought it was creative) and tried putting myself and the other user in that group. Once we were both in group winfsa I tried
mount -t captive-ntfs -o gid=1001 /dev/hda1 /windows/C
1001 of course being the winfsa group id. This didn't seem to work at all. Security isn't a very big issue to me, I'm just on a stand-alone desktop machine in a dorm-room, so I tried looking up how to make the partition accessible to anyone. Tried
mount -t captive-ntfs -o users,exec,rw /dev/hda1 /windows/C
But it still won't work. I've been trying all sorts of things but nothing seems to work at all. Here is my current /etc/fstab
/dev/hda3 / reiserfs defaults 1 1
/dev/hda2 /boot ext2 defaults 1 2
/dev/hda5 /windows/D vfat user,exec,umask=0 0 0
/dev/hda6 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs noauto 0 0
/dev/cdrecorder /media/cdrecorder auto ro,noauto,user,exec 0 0
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
/dev/dvd /media/dvd auto ro,noauto,user,exec 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
/dev/hda1 /windows/C captive-ntfs user,exec,umask=0 0 0

And, btw, everything I tried on the captive-ntfs file-system I also tried on that vfat partition you see up there, just because I thought captive-ntfs might have some wierd things going on that might cause it not to work. But with both vfat and captive-ntfs neither one has worked.

So someone help me. I just need the partition to be read/write accessible to me and one other person.. at the same time. Shouldn't be too hard.

Using a fresh install of SuSE 9.0 if it helps.
 
Old 04-07-2004, 07:32 PM   #2
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 57
I hope you can afford to lose the NTFS filesystem as I understand R/W is very pre-alpha at this time.

Sorry, I can't help. Maybe, don't mount it at boot and let the user that needs it mount the partition?

Last edited by fancypiper; 04-07-2004 at 07:37 PM.
 
Old 04-07-2004, 07:58 PM   #3
Pauli
Member
 
Registered: Feb 2004
Location: Montreal
Distribution: Gentoo/Debian
Posts: 365

Rep: Reputation: 30
You cannot write safely in linux, to a ntfs partition. Well thats not quite true, you can EDIT files, but when you save them they must be the same size, which is next to impossible. If you need to use a hard drive from windows and linux, make a fat32 partition and use that for both. NTFS write is very unstable and not recommended to use.
 
Old 04-07-2004, 08:36 PM   #4
divsky
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake 10.0 for AMD 64 and SuSE 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
http://www.jankratochvil.net/project/captive/
This is what I'm using. And yes, it does work. I've written completely new files, editing existing files, deleted files in NTFS in Linux using this software. And so far I havn't lost anything.
 
Old 04-07-2004, 09:31 PM   #5
urzumph
Member
 
Registered: Jan 2004
Location: Australia
Distribution: Debian
Posts: 168

Rep: Reputation: 30
try the umask option when mounting (umask = 0). You might want to read up on the umask option to secure it a little better - umask=0 give full rwx permissions to all users....

Incidentally, As far as I know, when you specify all the options on the command line (eg : mount -t captive-ntfs -o users,exec,rw /dev/hda1 /windows/C) mount ignores your fstab, so if you want to use the umask=0 in your fstab, just
mount /dev/hda1
 
Old 04-15-2004, 05:25 AM   #6
kjoe
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
according to the docs, you should be able to specify umaks=0 and othmask=0 but both have no effect on my mounted directories. they will not mount other than drwxr-xr-x which would give only the user write permissions. anybody know how to change that to at least rwx for groups too?
 
Old 04-15-2004, 10:52 AM   #7
InEeDhElPlInUx
Member
 
Registered: Sep 2003
Posts: 107

Rep: Reputation: 15
Your fstab file should look like this

/dev/hda1 /windows/C captive-ntfs noauto,user,rw,umask=0000 0 0

That shoud work. You should just have to run mount /dev/hda1 and it should follow the rules you created in fstab. The only thing I'm not 100% use about is if you should use user or nouser. Try one and if it doesn't work try the other.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounted read-write Fat32 partition suddenly becomes read-only?? hohead Linux - General 8 04-05-2007 12:17 PM
Captive NTFS-still can't write Please help fatenabu Linux - Software 1 12-02-2005 10:57 AM
NTFS and Read-write mode (captive and other solutions) in mandrake 9.1 (bamboo) mimithebrain Linux - Newbie 5 05-19-2004 11:23 AM
NTFS Partition Read/Write Access Help Bomb187 Fedora 6 03-17-2004 08:00 PM
Does captive support write access for Win2k NTFS partitions? dreamtheater Linux - Software 1 03-09-2004 02:06 AM


All times are GMT -5. The time now is 12:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration