LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-05-2008, 02:13 PM   #1
luvthepenguin
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
Unhappy Wireless not working


The network manager in upper right does show available wireless networks but selecting them does not seem to work. When I do ifconfig, wlan0 does not show an IP address. The hardware should work because it worked fine until I tried to switch from my work wireless to my home wireless.

when I try a command like:
$ iwconfig wlan0 ap any

I get this as a response:
Error for wireless request "Set AP Address" (8B14) :
SET failed on device wlan0 ; Operation not permitted.

I also get a permissions error when I try ifup
$ ifup wlan0
ifup: failed to open statefile /var/run/network/ifstate: Permission denied

I am the admin on my computer so not sure the reason for these errors. I am on Ubuntu 7.10. How can I get my machine to recognize the wireless networks, manually or otherwise? Thanks so much for your help!!
 
Old 11-05-2008, 03:46 PM   #2
zakonnik
LQ Newbie
 
Registered: Nov 2008
Location: Elbląg, Poland
Distribution: Slackware64-current
Posts: 22

Rep: Reputation: 16
Not sure what you've got in mind but try 9as root):
Code:
iwconfig wlan0 up
iwlist wlan0 s
 
Old 11-05-2008, 07:17 PM   #3
luvthepenguin
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Original Poster
Rep: Reputation: 0
thank you zakonnik, I got it to work by editing the /etc/network/interfaces file... would you or someone else be able to point me to a resource to install a wireless card (for a different computer)? I downloaded the driver but not sure where to put the files and to get it working. The resources I found on the web so far don't walk me through command by command.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel PRO/wireless 4965 ANG wireless card on hpdv9500 not working(off and on) Quargar Linux - Hardware 0 08-02-2008 10:06 PM
Intel Wireless 3945ABG Wireless NIC card not working after 8.04 clean install creature124 Linux - Hardware 4 05-03-2008 12:58 PM
Wireless and Wired connection on Belkin wireless G F5D7230 not working together ernie79 Linux - Hardware 1 02-10-2008 07:50 AM


All times are GMT -5. The time now is 06:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration