LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-30-2008, 02:37 PM   #1
creature124
Member
 
Registered: May 2007
Distribution: Kubuntu
Posts: 40

Rep: Reputation: 15
Intel Wireless 3945ABG Wireless NIC card not working after 8.04 clean install


Hi,

I upgraded my Kubuntu installation to 8.04 (doing a clean install, as I am somewhat wary of kernel upgrades since my windows time) and now I am rushing around getting all these little problems sorted.

I reinstalled the driver for my wireless NIC card just as I did under 7.10, but that does not appear to be the problem.

For starters, my nic cards little green light no longer comes on when I switch it on. The interface is recognized by Kubuntu, as shown by my ifconfig output:

Code:
creature124@creature-lappy:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:13:a9:84:84:1a
          inet addr:75.62.210.42  Bcast:75.62.210.255  Mask:255.255.255.0
          inet6 addr: fe80::213:a9ff:fe84:841a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35498 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37847 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14636074 (13.9 MB)  TX bytes:15125946 (14.4 MB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:53 errors:0 dropped:0 overruns:0 frame:0
          TX packets:53 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3308 (3.2 KB)  TX bytes:3308 (3.2 KB)

wlan0     Link encap:Ethernet  HWaddr 00:18:de:d5:bf:b5
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-18-DE-D5-BF-B5-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
I have no idea what wmaster0 is, it never appeared in my ifconfig output under 7.10. Also, my wireless nic used to be called eth1, but I suppose the name change is part of the kernel upgrade.

The card seems to be recognized, but any attempt to enable it result in the follow error:

Code:
creature124@creature-lappy:~$ sudo ifup wlan0
Ignoring unknown interface wlan0=wlan0.
I have no idea why the interface is 'unknown' even though it is listed in ifconfig.

Does anyone have any ideas?

Thanks,
Greg
 
Old 04-30-2008, 11:41 PM   #2
bugmenot
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Rep: Reputation: 0
Press Alt + F2 and type "gksudo gedit /etc/network/interfaces" and add "iface wlan0 inet dhcp" to the bottom of the file, then save.

Next, open a console and type the following:
Code:
sudo ifdown wlan0
sudo ifup wlan0
sudo iwconfig wlan0 channel XX essid XXXXX mode Managed
Make sure you replace XX with your router's channel and XXXXX with your router's ESSID.

Finally, test your connection by unplugging any other connections to the internet and type "ping -c 1 www.google.com" into the console.

If it pings successfully you're all set.

Last edited by bugmenot; 05-01-2008 at 04:50 PM.
 
Old 05-02-2008, 02:54 PM   #3
creature124
Member
 
Registered: May 2007
Distribution: Kubuntu
Posts: 40

Original Poster
Rep: Reputation: 15
Thanks much bugmenot, I can now get my interface to go up and down. However, I don't have a wireless network in my home, so I can't test the last step right now.

I do have a neighbors wifi in range (which I have obtained permission to use for testing purposes). I don't know its 'channel', which I guess would cause a problem with your method.

Under 7.10 I used a tool called KWiFiManager which detected and connected to wireless networks for me, however this tool will not detect the network (which I know is present).

Can you help with this?
 
Old 05-02-2008, 04:26 PM   #4
bugmenot
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Rep: Reputation: 0
Try typing "iwlist wlan0 scan" into a console, that should produce a list of all wireless networks within range as well as displaying various information about each one, including the channel.
 
Old 05-03-2008, 11:58 AM   #5
creature124
Member
 
Registered: May 2007
Distribution: Kubuntu
Posts: 40

Original Poster
Rep: Reputation: 15
That command has produced 'no scan results'. Yet I know for a fact that there is a wireless network in range. Is there any reason why the scan wouldnt be functioning correctly? The light on my WLAN switch on my lappy still doesn't turn green when I switch it on...maybe the problem is in the way the OS and the card are communicating?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel PRO/Wireless 3945ABG not working!! geek_man Suse/Novell 5 01-20-2008 11:25 AM
Fedora 7 with Intel Pro 3945ABG wireless card jigkin22 Linux - Hardware 1 10-15-2007 06:30 AM
Intel 3945ABG Wireless card smiffy848 Linux - Newbie 1 06-23-2007 10:21 AM
Cannot get intel wireless pro 3945abg card to work Jen Fraggle Linux - Wireless Networking 2 01-25-2007 01:29 PM
Intel PRO/Wireless 3945ABG card not working in SuSE 10.1 iamjunko Suse/Novell 6 07-29-2006 12:10 PM


All times are GMT -5. The time now is 10:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration