LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-16-2005, 04:45 AM   #1
bitterbird
LQ Newbie
 
Registered: May 2005
Location: Gold Coast Australia
Distribution: -
Posts: 4

Rep: Reputation: 0
Winodws and Linux


Hi guys look im new to linux, i have recently set up a machine with red hat 8. i also have a machine running windows xp which is able to acces the internet via a dialup modem, what i want to do is allow my linux machine to access the internet too, but through the XP machine.
I have them linked by a crossover cable but dont really know what to do next

can anyone help me
 
Old 05-16-2005, 05:01 AM   #2
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 32
Hi,

It's relatively straightforward.

First, if it's just the two machines, then yes, you'll want an ethernet (Cat 5) crossover cable.

On the windows machine, open up control panel and go to 'network connections' (I think that's what it's called). Right-click on the connection you want to share and select 'properties'. A panel should open. On one of the tabs in there, there will be an option to share the connection - check it.

Once you've done that, close the panel and then right-click on the internal network interface connection. A panel should open; in the list of protocols, click on TCP/IP, then click 'Properties'. Check the address of the machine - it should be 192.168.0.1 (or similar). I use static addresses for the DNS settings - you'll need to look up the domain name server addresses for your ISP and enter the values in the relevant boxes in the panel.

On your Linux machine, you'll need to configure your network card with a separate address (eg, 192.168.0.2) and set the default gateway to your windows machine (192.168.0.1). You'll also want to set the nameserver addresses as per the windows machine; these normally go in the text file /etc/resolv.conf, in the format -

nameserver 123.123.123.123
nameserver 123.123.123.124
...

And you should be done..

Hope this makes reasonable sense!
 
Old 05-16-2005, 05:17 AM   #3
bitterbird
LQ Newbie
 
Registered: May 2005
Location: Gold Coast Australia
Distribution: -
Posts: 4

Original Poster
Rep: Reputation: 0
ok mate, i did the ip addresses etc but didnt do the DNS is this really needed?

after doing the IP address, default gateways etc i cannot reach the other machines via ping

any more ideas

please go easy on me im a beginner
thanks guys
 
Old 05-16-2005, 05:22 AM   #4
bitterbird
LQ Newbie
 
Registered: May 2005
Location: Gold Coast Australia
Distribution: -
Posts: 4

Original Poster
Rep: Reputation: 0
sorry mate, i just tried the resolveconf in the linux box and access was denied
any ideas
 
Old 05-16-2005, 06:29 AM   #5
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 32
Hi,

I think you will need the DNS addresses - try having a look on your ISP's website for their tech help, or check any documentation you received when you signed up.

As for lack of success with ping - this could be more of a problem. Check to see if XP has enabled its firewall (look at the internet connection, see if it says it is firewalled); it's just possible that the Windows firewall isn't allowing pings, but my hunch is that this isn't the case. Otherwise, double check that you've fitted a crossover cable between the machines, not an ordinary non-crossover type (it's caught me out before). When pinging, are you using the numeric IP address, or the name of each machine?

Resolv.conf - you'll need to be root to edit this file. Easiest (quickest) way is to open a terminal window (you're using Red HAt 8, so I'm assuming you're running Gnome - look in the menu for 'terminal' or similar). Then change to the root user by typing

Code:
su
Enter your root password (you won't get any feedback on screen). When successful, you can edit the /etc/resolv.conf file by typing

Code:
vi /etc/resolv.conf
This will open the file for editing. Press the 'insert' key on your keyboard, then type in the names of your nameservers, as outlined previously. When you're done, press the 'ESC' key, then type : (colon) followed by 'w' (omit quotes!) to write the file. To get out of Vi, type : then 'q'.
 
Old 05-16-2005, 07:36 AM   #6
bitterbird
LQ Newbie
 
Registered: May 2005
Location: Gold Coast Australia
Distribution: -
Posts: 4

Original Poster
Rep: Reputation: 0
ok i have diabled all firewalls, and checked that the cable is a crossover it is, its one of those u purchase in apcket etc

umm im really lost on this connectivity issue

one more thing i get these messages as my linux box boots,
something about bringing up the eth0 interface (this stalls here for a little while)
then it says information for eth0 failed

any clues
thanks mate
 
Old 05-16-2005, 11:53 AM   #7
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 32
OK,

if there's a problem with eth0 during boot, we could do with having a look at the boot log - have a look in /var/log and check any or all of syslog, messages and boot.log files (not sure what they'll be called in RH8) - post anything relating to eth0 here. Oh, you might need to be root to view the logs.

In the meantime, as root, in a terminal try typing

Code:
ifup eth0
and see what messages (if any) are returned..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 11:37 PM
Remote Access to solaris from winodws PC zillah Solaris / OpenSolaris 29 02-25-2006 10:44 AM
Winodws profile bartron Linux - Networking 1 10-31-2004 07:55 PM
StartX for Winodws David@330 Linux - Newbie 4 07-28-2004 04:23 AM
Winodws XP machines can't access Linux server lansman Linux - Networking 3 03-02-2003 11:19 AM


All times are GMT -5. The time now is 07:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration