LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-14-2004, 07:23 PM   #1
Kasperisa
LQ Newbie
 
Registered: Jul 2003
Posts: 26

Rep: Reputation: 15
Why does "Starting sendmail" take so long at boot up


I'm having a problem with Fadora Core 2. When I boot up, and it's going through the initialization there is a halt about halfway through for about 2-3 minutes.
Does anyone know why the line "starting sendmail" takes forever to "OK"
Thanks in advance
 
Old 07-15-2004, 05:13 AM   #2
cck23
Member
 
Registered: Jun 2004
Location: Surrey, UK
Distribution: Mandrake 10 Download
Posts: 73

Rep: Reputation: 16
This is more of a general response than a specific answer to your problem but i hope that it still helps....

When i get problems with scripts, I quite often make a copy of the script and insert debug messages.

e.g.

date >> /tmp/delete
echo "a useful bit of text" >> /tmp/delete

That way, boot up as normal and when the boot process is complete then you can inspect the file /tmp/delete and by looking at the times and messages, you might hopefully have a good chance at working out where the delays are in the sendmail script.

Good luck

cck
 
Old 07-15-2004, 07:47 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
$50 says you've changed your network configuration. This problem is normally symptomatic of the server's hostname being incorrectly changed. ensure that your local hostname is set in /etc/hosts
Code:
127.0.0.1 localhost localhost.localdomain kevslinuxbox
and restart sendmail. if that doesn't do it, there will be more detailed into added to the system log, /var/log/messages
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Freezes on boot "starting ppp0" RAMMS+EIN Mandriva 6 05-01-2006 01:01 PM
Boot hangs for 3 minutes at "Starting syslogd daemons" DaneM Slackware 4 06-29-2005 10:52 PM
Boot hangs at "Starting resource manager" robintw SUSE / openSUSE 0 01-13-2005 02:43 PM
Lost DHCP Lease when putting computer in "Standby" mode for a "long" time pnellesen Linux - Networking 1 01-06-2005 11:44 PM
boot freezes after "starting driverloader" steve_hess Linux - Newbie 1 07-05-2004 10:48 AM


All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration