LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-21-2016, 08:56 AM   #1
luofeiyu
Member
 
Registered: Aug 2015
Posts: 166

Rep: Reputation: Disabled
Why can't install the latest version firefox-48.0.1 on debian?


1.download it firefox-48.0.1.tar.bz2
2.mkdir /opt/firefox
3.extract firefox into /opt/firefox
4.chmod 777 /opt/firefox/run-mozilla.sh
5. sh /opt/firefox/run-mozilla.sh

An error info occur: cannot executed!
How to install the latest version firefox-48.0.1 on debian?
 
Old 08-21-2016, 09:08 AM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,687

Rep: Reputation: 1259Reputation: 1259Reputation: 1259Reputation: 1259Reputation: 1259Reputation: 1259Reputation: 1259Reputation: 1259Reputation: 1259
Try leaving out step 4.

And next time include the exact error.

Last edited by jpollard; 08-21-2016 at 09:09 AM.
 
Old 08-21-2016, 09:11 AM   #3
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora
Posts: 2,259

Rep: Reputation: 401Reputation: 401Reputation: 401Reputation: 401Reputation: 401
Or try
Code:
$ /opt/firefox/./firefox-bin
 
Old 08-21-2016, 09:48 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 5,802

Rep: Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376
which debian version? stable?
i think there's a reason why it's not in the repositories.
just run the version you can install with apt-get.
like this:
Code:
sudo su
apt-get update
apt-get upgrade
apt-get install firefox-esr
and post output if you need help. in code tags.
you have been here long enough to know that.
 
Old 08-22-2016, 02:00 AM   #5
luofeiyu
Member
 
Registered: Aug 2015
Posts: 166

Original Poster
Rep: Reputation: Disabled
Code:
apt-get install firefox-esr
 
Old 08-23-2016, 01:13 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 5,802

Rep: Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376Reputation: 1376
^ yes, that will give you the latest version supported by whichever debian version you're using.
a wise choice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Running The Latest Firefox Version On Debian Squeeze LXer Syndicated Linux News 1 02-10-2012 06:26 PM
How do I install the Latest version of Firefox & Java? marinegruntswife Linux - Software 26 07-29-2010 04:34 PM
Browser firefox 3.0b 5pre need to install latest version Papillon 123 Linux - Newbie 1 07-01-2010 08:00 AM
I Can't Install Latest Version Of Java Without Installing Firefox - Help! davidx Linux - Software 2 10-15-2008 11:19 PM
How to install latest version of Firefox on CentOS Dmjmusser Linux - Software 3 02-20-2007 12:02 PM


All times are GMT -5. The time now is 09:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration