LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-15-2003, 06:24 PM   #1
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Rep: Reputation: 0
want to see fat32


hi i'm really new to redhat .

before this i use windows ..

how can i see my fat32 partition ...

i find the hda1 , i think it my drive c . isn't it ?

when i click at it , there is an error .

"nautilus has no install viewer capable of displaying /dev/hda1"

can you help me?
 
Old 09-15-2003, 07:45 PM   #2
beolach
LQ Newbie
 
Registered: Jul 2003
Distribution: Gentoo
Posts: 29

Rep: Reputation: 15
The problem you are having is that you're trying to access the
raw device file, /dev/hda1, rather than the files on that partition.

This is one of the first differences between windows & linux that
people run across. Linux has special "device files" that represent
hardware on the system; the closest Windows parallel is probably
the device manager.

In order to access the files on your fat32 (aka vfat) partition, you
will need to "mount" the fat32 filesystem, if it isn't already. You
most likely won't actually have to do this, since most installations
automatically detect fat32 partitions & do this for you. You can
check to see if it is already mounted by opening a console prompt
and typing "mount -t vfat". This will list all of the vfat (aka fat32)
filesystems that are already mounted. If your old windows
partitions are already mounted (most likely) it will print a line
something like:
/dev/hda1 on /mnt/win/c type vfat (rw)

This shows where the device (possible /dev/hda1) is mounted, in
this example /mnt/win/c. What this means is that you can access
all the files on the /dev/hda1 partition in the /mnt/win/c directory.

If it's not mounted, you will want to edit the file "/etc/fstab". This
file contains info on filesystems & where to mount them. You will
want to add a line somthing like:
Code:
# Device	Mount point	Type	Options		Special
/dev/hda1	/mnt/win/c	vfat	defaults	0	0
Changing the bold text to what would be best for you. Make sure
the mount point (i.e. /mnt/win/c) exists. It should be an empty
directory.

Additional information:
man mount
man fstab
Filesystems HOWTO - very technical & in depth.
 
Old 09-15-2003, 07:45 PM   #3
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
You don't look at /dev/hda1, you mount it to a folder and look at that, using the mount command:
mount -t vfat /dev/hda1 /mnt/hd
This mounts your win partition to the /mnt/hd folder. The folder has to exist before you mount.
 
Old 09-15-2003, 10:04 PM   #4
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Original Poster
Rep: Reputation: 0
thanks you very much
it really help

i really appreciate it
 
Old 09-15-2003, 10:20 PM   #5
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Original Poster
Rep: Reputation: 0
sorry .. it is ok when i do at my drive c

but when i try to do with my drive e thats mean hda3 .
it doesnt work

it says that " wrong fs type ,bad option, bad superblock on /dev/hda3, or too many mounted file system

what should i do ?
 
Old 09-15-2003, 10:29 PM   #6
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
is it an fat32 partition?

Open a terminal window, become root with the su command and do
fdisk -l /dev/hda
Could you post the output of this?
 
Old 09-15-2003, 11:35 PM   #7
skora
LQ Newbie
 
Registered: Aug 2003
Location: Somewhere out in space
Distribution: SuSe 8.0
Posts: 18

Rep: Reputation: 0
I have the same problem and I got this..

linux:~ # fdisk -l /dev/hda

Disk /dev/hda: 240 heads, 63 sectors, 7941 cylinders
Units = cylinders of 15120 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 646 4883728+ 12 Compaq diagnostics
/dev/hda2 647 2069 10757880 f Win95 Ext'd (LBA)
/dev/hda3 * 2070 7941 44392320 7 HPFS/NTFS
/dev/hda5 647 780 1013008+ 82 Linux swap
/dev/hda6 781 2069 9744808+ 83 Linux


so what should I do?
thank you very much
 
Old 09-15-2003, 11:39 PM   #8
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
for an ntfs partiton, you mount it by

mount -t ntfs /dev/hda3 /mnt/win

You'll have to make appropriate changes depending on the partiton and the desired mount point. Also, ntfs needs to be supported by your kernel. I hear some distributions disable it by default...
 
Old 09-16-2003, 12:17 AM   #9
skora
LQ Newbie
 
Registered: Aug 2003
Location: Somewhere out in space
Distribution: SuSe 8.0
Posts: 18

Rep: Reputation: 0
thank you very much!!!
this worked!
 
Old 09-16-2003, 01:04 AM   #10
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Original Poster
Rep: Reputation: 0
i'm really sorry ...
i was wrong i think e: is hda3
but it is hda5 .

sorry , because i'm really new with redhat .

thanks for helping me
 
Old 09-16-2003, 03:59 AM   #11
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Original Poster
Rep: Reputation: 0
more problem ...

before this i have mount all the drive and it success ..

but after i restart ...
i cant open all the drive again ..

can u xplain ???????
 
Old 09-16-2003, 08:20 AM   #12
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
You can't mount or you have to mount all over again? If you don't want to mount every drive every single time you restart, you can put entries for them in your /etc/fstab file so it will be done automatically on startup. Put a line the way beolach explained it.
 
Old 09-16-2003, 02:59 PM   #13
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Original Poster
Rep: Reputation: 0
i have done bleolach step ..
but still i have to mount all over again except drive c:

this is what i have done

/dev/hda1 /mnt/hd vfat defaults 0 0
/dev/hda5 /mnt/hd2 vfat defaults 0 0
/dev/hda6 /mnt/hd3 vfat defaults 0 0
/dev/hda7 /mnt/lagu vfat defaults 0 0
/dev/hda8 /mnt/hd4 vfat defaults 0 0

is there any wrong ?
 
Old 09-16-2003, 04:27 PM   #14
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
All the mount points exist, right? That is, you did
mkdir /mnt/hd2; mkdir /mnt/hd3; etc.

Do they get mounted when you do
mount -a
(as root). If not, do you get any error messages?
 
Old 09-20-2003, 04:45 AM   #15
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Original Poster
Rep: Reputation: 0
it works .

thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 08:54 PM
fat32 Razza2004 Linux - General 2 04-01-2004 12:44 AM
About FAT32 M_Ghani Red Hat 3 03-23-2004 10:09 AM
2 fat32 partitions on fbsd5/w2k dual. Can only access one fat32 so far.. mipia *BSD 1 10-06-2003 03:10 AM
Fat32 JediDrunk Linux - Newbie 3 08-13-2003 12:17 AM


All times are GMT -5. The time now is 01:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration