LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-07-2003, 01:49 PM   #1
gbj
Member
 
Registered: Jul 2003
Posts: 142

Rep: Reputation: 15
vfat and redhat 9


Hi I'm a complete newbie on linux. This is my problem. I have a fat32 drive that I would like to be able to access from my linux system.
I can mount this drive just fine but I would like to access the drive as a normal user, that is delete,move,rename files, etc.

I have modified my fstab to be the following

/dev/hdd5 /mnt/share vfat auto,rw,user,uid=500,umask=000 0 0


So my question is this, how can I read/write to this drive as a normal user? Is there something I'm missing?

Any help is greatly appreciated
 
Old 08-07-2003, 02:38 PM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Check the permissions on the files on the mounted partition - as root user (su to root) type

ls -l /mnt/share

check to see the bit pattern on most of the files - they should be

-rwxrwxrwx

Also - Make sure youve got the correct uid number - to check - su to root then type

id username (substitute in your username)


This line is taken from my /etc/fstab in Red Hat 9:

/dev/hda1 /mnt/windows vfat auto,uid=500,umask=000 0 0

This works fine for me to have complete read/write/execute access on the mounted partition.

Personally - I wouldnt use these options below in addititon to the ones outlined above:

user
rw

they're not neccesary.

Last edited by Skyline; 08-07-2003 at 03:13 PM.
 
Old 08-07-2003, 03:11 PM   #3
gbj
Member
 
Registered: Jul 2003
Posts: 142

Original Poster
Rep: Reputation: 15
well when i type ls -l /mnt/share I get this output;

drwxrwxrwx 12 gbj root 4096 Aug 5 19:23 Linux
dr-xr-xr-x 11 gbj root 4096 Aug 5 17:56 Shared Folder
drwxrwxrwx 2 gbj root 4096 Jul 20 02:02 Unfinished

Any ideas?
 
Old 08-07-2003, 03:16 PM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Modify your /etc/fstab to use just the 3 options I use namely

auto
uid=
umask=000

ie get rid of rw,user and see what happens

then re-check your permissions

This is my line and it works perfect

/dev/hda1 /mnt/windows vfat auto,uid=500,umask=000 0 0



Last edited by Skyline; 08-07-2003 at 03:34 PM.
 
Old 08-07-2003, 04:30 PM   #5
gbj
Member
 
Registered: Jul 2003
Posts: 142

Original Poster
Rep: Reputation: 15
Well I have done what you suggested and my fstab reads as ;
/dev/hdd5 /mnt/windows vfat auto,uid=500,umask=000 0 0
I still cannot get execute acess, that is I get permission denied when I try to delete, rename files.. So I'm beginning to think this has something to do with file permissions?

The output of ls -l /mnt/windows is;

drwxrwxrwx 12 gbj root 4096 Aug 5 19:23 Linux
dr-xr-xr-x 11 gbj root 4096 Aug 5 17:56 Shared Folder
drwxrwxrwx 2 gbj root 4096 Jul 20 02:02 Unfinished

Any ideas? Is there any way to change file permissions for the whole partition?
 
Old 08-07-2003, 06:28 PM   #6
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Your original mount point was /mnt/share

You could try as Root user (su to root)

chmod 777 /mnt/share


Strangely - on the 3 directories in /mnt/share - 2 of them youve got full rwx access - 1 youve got rx access - according to those permissions you should be able to get full access to 2 of those directories.
 
Old 08-07-2003, 07:04 PM   #7
gbj
Member
 
Registered: Jul 2003
Posts: 142

Original Poster
Rep: Reputation: 15
Yes I changed the mount point to /mnt/windows instead of /mnt/shared...

I tried chmod and the output of ls -l /mnt/windows is;
drwxrwxrwx 12 gbj root 4096 Aug 5 19:23 Linux
drwxrwxrwx 11 gbj root 4096 Aug 7 21:41 Shared Folder
drwxrwxrwx 2 gbj root 4096 Jul 20 02:02 Unfinished

When I check the permission for the windows folder in konqueror I see that the ownership is gbj but the group is root? When I try to change the group to gbj I get an error message saying that I have insufficient access to change the file permission...

Any toughts or ideas and by the way thanks for all the help..
 
Old 08-07-2003, 07:19 PM   #8
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Quote:
I tried chmod and the output of ls -l /mnt/windows is;
drwxrwxrwx 12 gbj root 4096 Aug 5 19:23 Linux
drwxrwxrwx 11 gbj root 4096 Aug 7 21:41 Shared Folder
drwxrwxrwx 2 gbj root 4096 Jul 20 02:02 Unfinished
Nice!

Just put an entry in /etc/fstab for your GID

As root - if you do

id username (subs.your username)

the second piece of info will be your GID number

just insert this into the appropriate line in etc/fstab in the options field

You should then have something like this

/dev/hda1 /mnt/windows vfat auto,uid=500,gid=500,umask=000 0 0

Last edited by Skyline; 08-07-2003 at 07:24 PM.
 
Old 08-07-2003, 07:50 PM   #9
gbj
Member
 
Registered: Jul 2003
Posts: 142

Original Poster
Rep: Reputation: 15
Well(sigh) adding the GID to fstab did not change anything. I'm thinking that this has something to do with the ownership now. Ive tried chmod 777 to no effect and then i tried chgrp gbj/mnt/windows to change the ownership from root to gbj, but I get "operation not permitted" when I try this even as su...
 
Old 08-07-2003, 09:00 PM   #10
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
gid=xxx

is definately the right option to put in to force all files and directories in the mounted partition to assume the group xxx

Ive just tried my /etc/fstab with both, it in - and with it not in - when its in I get

mikki mikki (my username)

from ls -l /mnt/windows

when its not in I get

mikki root

as expected - so its definately the right option to put in.

In your situation I'm not sure what's stopping it having the intended effect.
 
Old 08-10-2003, 08:34 AM   #11
gbj
Member
 
Registered: Jul 2003
Posts: 142

Original Poster
Rep: Reputation: 15
Well I finally found the problem and now I have full access to my fat partition The reason why my modifications to fstab were not having the intended effects was a simple one. I had disabled kudzu(the hardware probe) so that fstab was not updated at boot time. Anyway I'm a happy user now, so thanks Skyline for all your help..I really appreciate it..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 9.1 and vfat gbj Linux - Newbie 5 08-05-2003 05:06 PM
vfat InsaneBob Linux - Software 1 03-22-2003 12:01 PM
Vfat and Redhat 8 nathanv117 Linux - General 1 12-29-2002 09:05 PM
vfat and Redhat 8 nathanv117 Linux From Scratch 1 12-29-2002 09:04 PM
copy files from vfat to vfat from linux? purpleburple Linux - General 2 12-11-2002 04:24 PM


All times are GMT -5. The time now is 08:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration