LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2003, 03:39 PM   #1
gbj
Member
 
Registered: Jul 2003
Posts: 142

Rep: Reputation: 15
Redhat 9.1 and vfat


Hi I'm a complete newbie on linux. This is my problem. I have a fat32 drive that I would like to be able to access from my linux system. I can mount this drive just fine but I can not read or write to it from linux. I'm using Redhat 9.1 and my fstab line is like the following;
/dev/hdd5 /mnt/share vfat defaults 0 0

So my question is this, how can I read/write to this drive as a normal user? Any help is greatly appreciated
 
Old 08-05-2003, 04:10 PM   #2
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Put under options, instead of "defaults", "user,umask=000". This lets users mount it and sets the permissions to rwxrwxrwx (you have to set them in the fstab because fat doesn't support permissions),
 
Old 08-05-2003, 04:20 PM   #3
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
There's nothing in

user,umask=000

that will automatically mount your filesystem on boot up - you'll need this option aswell

auto
 
Old 08-05-2003, 04:38 PM   #4
gbj
Member
 
Registered: Jul 2003
Posts: 142

Original Poster
Rep: Reputation: 15
thank you Skyline and aaa I added this line to fstab
/dev/hdd5 /mnt/share vfat auto,user,umask=000 0 0
and now I can move files between my home directory and my fat disk, but I'm getting errors when i use konqueror, especially when I'm deleting files? Then i get access denied. Am i missing something?
 
Old 08-05-2003, 04:45 PM   #5
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Just put one other option in aswell namely your

User ID - ( uid )

You can get your User ID Number by becoming Root user on the command line ( su - root password) and typing:

id username (substitute username with Aaron or Sofie or whatever your username is)

you'll get a little info - one of the bits will be something like

uid=501

just insert this into your options - your new line will look something like this

/dev/hdd5 /mnt/share vfat auto,user,uid=501,umask=000 0 0

Last edited by Skyline; 08-05-2003 at 04:48 PM.
 
Old 08-05-2003, 05:06 PM   #6
gbj
Member
 
Registered: Jul 2003
Posts: 142

Original Poster
Rep: Reputation: 15
thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vfat and redhat 9 gbj Linux - Newbie 10 08-10-2003 08:34 AM
vfat InsaneBob Linux - Software 1 03-22-2003 12:01 PM
Vfat and Redhat 8 nathanv117 Linux - General 1 12-29-2002 09:05 PM
vfat and Redhat 8 nathanv117 Linux From Scratch 1 12-29-2002 09:04 PM
copy files from vfat to vfat from linux? purpleburple Linux - General 2 12-11-2002 04:24 PM


All times are GMT -5. The time now is 02:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration