LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-07-2005, 02:17 PM   #1
amer_58
Member
 
Registered: Mar 2004
Distribution: Slackware 10.2
Posts: 213

Rep: Reputation: 30
usb mouse is not working, slackware 10.2


I have trouble getting my usb mouse working, i tried different methods based on my search here, but i couldnt make it work, here is my file, i did comment some lines that i did try but i couldnt run the startx command so i did disable them till i get some feedback, thanks in advance, i use slackware 10.2

Code:
# Identifier and driver

    Identifier    "Mouse1"
    Driver        "mouse"
#  Identifier    "USB Mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

    Option     "Protocol"      "Auto"

    Option "Protocol"    "IMPS/2"

    Option "Buttons" "5"

    Option "ZAxisMapping" "4 5" 

    Option "Device"      "/dev/mouse"
    Option "Device"      "/dev/input/mice"

    InputDevice "Mouse1" "CorePointer"
#  InputDevice "USB Mouse" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
 
Old 11-07-2005, 04:56 PM   #2
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 530

Rep: Reputation: 30
At first glance I'd say you have too many "option" and "protocol" enabled in your file.
I would try something like

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
# Identifier "USB Mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

Option "Protocol" "Auto"

#Option "Protocol" "IMPS/2" COMMENT OUT THIS

#Option "Buttons" "5" AND THIS

#Option "ZAxisMapping" "4 5" AND THIS

Option "Device" "/dev/mouse"
#Option "Device" "/dev/input/mice" AND THIS

InputDevice "Mouse1" "CorePointer"
# InputDevice "USB Mouse" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

If that works, then uncomment the ZAxisMapping line in order the wheel is enabled.
The Buttons line shouldn't be necessary.
Make sure you enabled HID devices in your kernel (either as modules).
If using a standard kernel they should
Hope this helps
Ciao
 
Old 11-07-2005, 05:01 PM   #3
amer_58
Member
 
Registered: Mar 2004
Distribution: Slackware 10.2
Posts: 213

Original Poster
Rep: Reputation: 30
Code:
Make sure you enabled HID devices in your kernel
how do i do that?
 
Old 11-07-2005, 05:32 PM   #4
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 530

Rep: Reputation: 30
I took this from my kernel 2.4.31 config file (standard or if you prefer what comes from slackware 10.2)

at some point at USB section

# USB Human Interface Devices (HID)
#
CONFIG_USB_HID=m *
CONFIG_USB_HIDINPUT=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_KBD=m *
CONFIG_USB_MOUSE=m *
CONFIG_USB_AIPTEK=m
CONFIG_USB_WACOM=m
CONFIG_USB_KBTAB=m
CONFIG_USB_POWERMATE=m

check by lsmod if occourencies (marked with *) are loaded

If you compiled the kernel from scratch make sure it is configured as above (for HID devices at least)

Ciao
 
Old 11-07-2005, 05:44 PM   #5
amer_58
Member
 
Registered: Mar 2004
Distribution: Slackware 10.2
Posts: 213

Original Poster
Rep: Reputation: 30
thats what i found and i assume its ok, right?

# USB Human Interface Devices (HID)
#
CONFIG_USB_HID=m
CONFIG_USB_HIDINPUT=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_KBD=m
CONFIG_USB_MOUSE=m
CONFIG_USB_AIPTEK=m
CONFIG_USB_WACOM=m
CONFIG_USB_KBTAB=m
CONFIG_USB_POWERMATE=m

#
 
Old 11-07-2005, 05:44 PM   #6
mokele
Member
 
Registered: Jan 2005
Location: Puerto Rico
Distribution: Slackware 13
Posts: 146

Rep: Reputation: 15
Xorg is looking for your mouse in two different places.
/dev/mouse
/dev/input/mice

USB mice should easily be detected on /dev/input/mice
just comment line: /dev/mouse

West
 
Old 11-07-2005, 05:55 PM   #7
amer_58
Member
 
Registered: Mar 2004
Distribution: Slackware 10.2
Posts: 213

Original Poster
Rep: Reputation: 30
thanks guys, but the scroll is not
 
Old 11-07-2005, 06:26 PM   #8
mokele
Member
 
Registered: Jan 2005
Location: Puerto Rico
Distribution: Slackware 13
Posts: 146

Rep: Reputation: 15
Ok, here are the lines you need.

Identifier "Mouse1"
Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/input/mice"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

Uncomment this lines, write the ones you don't have
and comment the unnecessary.

west.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.2 USB Mouse Configuration not working right. PastorFrederick Linux - Newbie 3 10-09-2005 07:31 PM
Logitech USB Mouse Wheel not working on Slackware 9.1 Ken Ju-On Linux - Hardware 9 04-11-2004 10:39 PM
ps/2-mouse via usb-adaptor not working - usb error=-110 mule Fedora 0 01-30-2004 06:23 AM
slackware 9.1 USB mouse and other usb devices not working jimMC Linux - Hardware 11 01-24-2004 10:58 AM
USB Optical Mouse and Slackware 9 - I cannot get it working GIJoe Linux - Newbie 0 10-13-2003 01:36 PM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration