LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2007, 08:11 PM   #1
Frame360
LQ Newbie
 
Registered: Jan 2007
Posts: 8

Rep: Reputation: 0
Question USB Modem Installation problem in SUSE 10.2


Hi,i'm having problems again with my newly installed suse 10.2, now with my Compaq 56K usb fax modem, suse inmediately recognized the modem, then in the .conf archive of my modem, i entered the phone number to dial, the user and the password. The file name is wvdial.conf, then i copy the vwdial.conf archive to my /etc directory and finally i execute the command wvdial, but every try i get this message:

--> WvDial: Internet dialer version 1.54.0
--> Cannot open /dev/ttyACM0: Device or resource busy
--> Cannot open /dev/ttyACM0: Device or resource busy
--> Cannot open /dev/ttyACM0: Device or resource busy

Early in the morning everything was working fine, but i rebooted my computer in the afternoon and when i tried to connect again i got the error message. Now my question is, what should i change or input to gain access again? or if anyone knows a good tutorial for usb modem installation on suse gnome it would be of great help.

Thanks in advance, Frame360

Last edited by Frame360; 01-23-2007 at 08:17 PM.
 
Old 01-23-2007, 09:00 PM   #2
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Did you install/compile drivers for the modem?

Most Linux distros do not supply pre-compiled modem drivers as the source is proprietary and Linux distros are GPL.

EDIT: sorry just noticed "everything was working this morning", watch for my next post

Last edited by Junior Hacker; 01-23-2007 at 09:01 PM.
 
Old 01-23-2007, 09:06 PM   #3
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
During initial setup of your modem, did you create a symbolic link from /dev/ttyACM0 to /dev/modem. If your distro uses UDEV, symbolic links disappear upon re-boot.

Also check to see if you have a file in /etc called modprobe.preload or similar which should contain an entry for the .ko driver module for your modem.

Biggest question I need answers to are:
What steps did you take in setting up this modem?
Did it actually have you surfing on-line before?

Last edited by Junior Hacker; 01-23-2007 at 09:10 PM.
 
Old 01-24-2007, 11:16 AM   #4
Frame360
LQ Newbie
 
Registered: Jan 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Question Trying to obtain privileges for kppp or wvdial

Thanks for the help JuniorHacker, i just found my mistake, i accidentally changed the Baud number in the wvdial.conf archive used for the default settings of my modem, and when i checked it this morning it had like 3 extra zeros hehe. Now i'm having another trouble, i want my users to have access to wvdial, i've read some tutorials and all of them said: "create a group called dialout, add yourself to the group and change a ton of permissions for the /dev/ttyACM0 and your .conf archive, and also change the SUID" i've tried all of them without success. Then i started to try with the kppp, as root i can use both commands perfectly but with my users now in kppp i got this message on screen every attempt to connect:

Could not read network connection list.
/home/dryclean/.DCOPserver_sucursal1_0

and this one in my terminal:

Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
kdeinit: Aborting. No write access to '/home/dryclean/.ICEauthority'.

So, my questions are: Is there a way to gain access with unprivileged users to the wdial or the kppp? and about the error messages above, How can i fix them?

Thanks in advance again, Frame360
 
Old 01-24-2007, 04:11 PM   #5
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Sorry, just woke up.

Did you download and use a small tool called scanModem from http://linmodems.org/

If not, click on highlighted scanModem on that page it will take you to another page, again, keep clicking on highlighted scanModem until download window appears. You may also want to read as you go to find instructions on how to use it. Or if you prefer, download it to your home directory and go there within terminal and issue these three commands:

gunzip scanModem.gz
chmod a+x scanModem
./scanModem

After a few seconds your prompt will re-appear, now there should be a folder named "Modem" in your home directory, in there is a ton of useful information regarding setting up modems. It also has links to linmodem maintainers who can help also, links to all kinds of things/places.

I have never seen a case where a user could not use kppp, but then I opt to use wvdial first in most cases, only in the Fedora 6 I'm in now, is the first time wvdial does not work (tried a 100 different installs with no success). I have no SUSE experience also.

I have also seen in the past, probably in one of the documents produced by scanModem, the command for permission changes for wvdial. I'm looking around now and will eventualy find it and post it if I do not see a post from you saying you got it straightened out.
 
Old 01-26-2007, 02:57 PM   #6
Frame360
LQ Newbie
 
Registered: Jan 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Talking Following your advice!!

Thanks JuniorHacker!! i've finally defeated monster kppp and my users are allowed to use the command, so i'm surfing again and with no problems at all. Just one more thing, i'm really interested in the document you talked about regarding the posibility to allow users to the wvdial, so if by chance you find it, i would be grateful if you notice me about it, if you don't find it don't worry i'll keep searching for it, thanks again and see you soon.

Frame360
 
Old 01-26-2007, 04:18 PM   #7
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
OK,

I know the maintainers at linmodems.org will mention it to people who contact them to resolve their problems. At the linmodems.org site is a highlighted link called "archives" in the first sentence on the web-page, through that link a person can view all cases that were discussed and in some of those cases is where the maintainers mention the command for wvdial permissions. One might want to look for a case with wvdial in the title. If I beat you to it I will post it.
 
Old 01-26-2007, 04:58 PM   #8
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Try some of these suggestions:

http://wiki.archlinux.org/index.php/...al_with_wvdial

One thing I found for sure is the directory you need to change permissions is /usr/bin/wvdial

Last edited by Junior Hacker; 01-26-2007 at 05:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgraded to SuSe 10, usb cable modem problem rebel penguin SUSE / openSUSE 5 11-29-2005 10:21 AM
Smartlink USB modem installation on SuSE 9.2 dborzasi SUSE / openSUSE 3 06-03-2005 04:10 PM
USB modem installation problem Kabuto Linux - Hardware 1 01-22-2005 09:31 PM
USB cable modem problem with suse pro 9 solved det187 Linux - Hardware 0 11-22-2003 07:46 PM
Installation problem: MS USB optical Intellimouse with SuSE 8.0 michapma Linux - Newbie 5 10-28-2003 05:23 PM


All times are GMT -5. The time now is 02:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration