LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-23-2009, 11:25 PM   #1
lunardragon
Member
 
Registered: Mar 2006
Posts: 57

Rep: Reputation: 16
Unable to mount external drive


OK im not a newb but having problems with permissions:
Logged in as root and set permissions for user, relogged as user and can read but not write to external drive.
As root I made all changes in system/admin/authorizations and made changes in users and groups.....what am I missing?
Using Ubuntu 9.10 Karmic Koala

Last edited by lunardragon; 11-23-2009 at 11:29 PM.
 
Old 11-24-2009, 10:38 AM   #2
Davno
Member
 
Registered: Mar 2004
Location: Montreal, Canada
Distribution: Mandriva 2010.2
Posts: 148

Rep: Reputation: 24
Quote:
Originally Posted by lunardragon View Post
OK im not a newb but having problems with permissions:
Logged in as root and set permissions for user, relogged as user and can read but not write to external drive.
Is your drive format in ntfs?
You may need the nfts-3g driver
 
Old 11-24-2009, 11:13 AM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200
What's the filesystem and how exactly do you mount it?
What about the ownership of the files/directories?
 
Old 11-24-2009, 11:29 AM   #4
lunardragon
Member
 
Registered: Mar 2006
Posts: 57

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Davno View Post
Is your drive format in ntfs?
You may need the nfts-3g driver
The file system is FAT32 all was fine until I had an audio problem and removed PULSE Audio.
For some reason the uninstaller removed my gnome desktop and set me to "user".
I recovered the desktop and audio but can't seem to get permissions right
system will not mount cd or usb drives
I logged in as root and made changes to system/Administration/Authorizations

I then checked etc/fstab..but not sure what to look for here.

# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=f246a06b-f90a-4e05-98e5-97355ab51cc6 / ext3 relatime,errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=54416246-4366-437a-a8f8-b0d6f5fe176f none swap users,sw,user 0 0
# /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
# /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
# acl /.Reboot
# /dev/sdb1 /media/sdb1 vfat defaults 0 0
 
Old 11-24-2009, 12:24 PM   #5
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200
Quote:
For some reason the uninstaller removed my gnome desktop and set me to "user".
That's why I stay away from so-called 'user-friendly' package managers that 'know better' what I want.

Have you just pasted it like that from your editor or is your fstab all commented out?

Try to add the option: umask=000 to your vfat entry in fstab.
 
Old 11-24-2009, 01:16 PM   #6
lunardragon
Member
 
Registered: Mar 2006
Posts: 57

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by sycamorex View Post
That's why I stay away from so-called 'user-friendly' package managers that 'know better' what I want.

Have you just pasted it like that from your editor or is your fstab all commented out?

Try to add the option: umask=000 to your vfat entry in fstab.
I just pasted it from my editor.
I added the umask=000 to my vfat entry in fstab, still no change
 
Old 11-24-2009, 11:26 PM   #7
Davno
Member
 
Registered: Mar 2004
Location: Montreal, Canada
Distribution: Mandriva 2010.2
Posts: 148

Rep: Reputation: 24
You know that this "#" before the line:
Code:
/dev/sdb1 /media/sdb1 vfat defaults 0 0
tell fstab not to read that line.
If you have # before that line remove it and it should work.
Sorry for mad bad english.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to mount USB external hard drive Irene Chan Linux - Newbie 11 03-13-2010 02:02 PM
Unable to mount external drive after crash blairm Linux - Newbie 2 08-07-2009 07:34 AM
Unable to mount external hard drive JenovaProject Linux - Hardware 1 04-06-2008 04:14 PM
Unable to mount iStore USB External Hard Drive LupisYonderboy Linux - Newbie 3 10-20-2007 10:12 AM
unable to mount external dvd bamsesbilledbog Linux - Newbie 10 11-28-2005 03:34 PM


All times are GMT -5. The time now is 12:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration