LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-30-2013, 04:33 AM   #1
sho`sh
LQ Newbie
 
Registered: Apr 2010
Distribution: rhel
Posts: 7

Rep: Reputation: 0
Unhappy Unable to get to x


Hi ,

I am on RHEL 6.0 [2.6.32-71.el6.i686] and since the last time I installed some softwares like vlc player. Oracle 11 etc I am not able to get to the x system.

Each time the system boots, the last line I see is

Starting CIM Server:

and then the screen comes to REDHAT ENTERPRISE on black screen but nothing happens.

Earlier, it used to come to login.

so I tried inslalting x window system system


#yum groupinstall "X Window System" Desktop


It downloads all the files but at the time if install the transaction check fails with following errors:


Transaction Check Error:

file /etc/issue from install of oraclelinux-release-6:6server-4.0.4.i686 conflicts with file from package redhat-release-server-6server-6.0.0.37.el6.i686
...
...
...
...



Not sure if its related. but I am unable to get X working.

I checked the runlevel it was set to 5. I managed to change it to 3 using a rescue disk.And then tried startx. This command also blacks out.


#startx

xauth: creating new authority file /root/bin/X: undefined symbol: pci_legacy_open_io
giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error.



Please help.

Last edited by sho`sh; 06-30-2013 at 04:37 AM.
 
Old 06-30-2013, 05:21 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Assuming you paid for RHEL I think you can call them for technical support. Isn't that the case? Have you tried? If you haven't paid then why not use CentOS?
jdk
 
Old 06-30-2013, 05:44 AM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Have you got both Oracle Linux and RHEL repos?
Code:
 file /etc/issue from install of oraclelinux-release-6:6server-4.0.4.i686 conflicts with file from package redhat-release-server-6server-6.0.0.37.el6.i686
Please show
Code:
yum repolist
 
Old 06-30-2013, 02:21 PM   #4
sho`sh
LQ Newbie
 
Registered: Apr 2010
Distribution: rhel
Posts: 7

Original Poster
Rep: Reputation: 0
@jdkaye

hello sir

I have installed RHEL 6 on my home test machine and not paid for it I mainly use it for testing and trying new things.


@chrism01

hello sir

That appears to be the case. Here it is:

#yum repolist
Loaded plugins: refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
repo id repo name status
epel Extra Packages for Enterprise Linux 6 - i386 7,629
google-chrome google-chrome 3
google-talkplugin google-talkplugin 1
remi Les RPM de remi pour Enterprise Linux 6 - i386 1,064
rpmfusion-free-updates RPM Fusion for EL 6 - Free - Updates 199
rpmfusion-nonfree-updates RPM Fusion for EL 6 - Nonfree - Updates 48
repolist: 8,944
--------------------------------------------------
additionally --->


#pwd
/etc/yum.repos.d
#ls

epel.repo
epel-testing.repo
google-chorme.repo
packagekit-media.repo
public-yum-ol6.repo
remi.repo
rpmfusion-free-updates.repo
rpmfusion-free-updates-testing.repo
rpmfusion-nonfree-updates.repo
rpmfusion-nonfree-updates-testing.repo


after some googling I disabled the

[OL6_UEK_latest] from the public-yum-ol6.repo




but the problem still remains
 
Old 06-30-2013, 02:27 PM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,919

Rep: Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689
Quote:
Originally Posted by sho`sh View Post
I have installed RHEL 6 on my home test machine and not paid for it I mainly use it for testing and trying new things.
Then if you're not PAYING for RHEL, DON'T USE IT...this is one good reason why you shouldn't. If it's only for testing, then load CentOS instead, which is 99.x% IDENTICAL to RHEL, but FREE. You will then have none of these issues.
Quote:
That appears to be the case. Here it is:

#yum repolist
Loaded plugins: refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
repo id repo name status
epel Extra Packages for Enterprise Linux 6 - i386 7,629
google-chrome google-chrome 3
google-talkplugin google-talkplugin 1
remi Les RPM de remi pour Enterprise Linux 6 - i386 1,064
rpmfusion-free-updates RPM Fusion for EL 6 - Free - Updates 199
rpmfusion-nonfree-updates RPM Fusion for EL 6 - Nonfree - Updates 48
repolist: 8,944
--------------------------------------------------
additionally --->


#pwd
/etc/yum.repos.d
#ls

epel.repo
epel-testing.repo
google-chorme.repo
packagekit-media.repo
public-yum-ol6.repo
remi.repo
rpmfusion-free-updates.repo
rpmfusion-free-updates-testing.repo
rpmfusion-nonfree-updates.repo
rpmfusion-nonfree-updates-testing.repo


after some googling I disabled the [OL6_UEK_latest] from the public-yum-ol6.repo but the problem still remains
How did you disable the repository? With what command?
 
Old 06-30-2013, 02:58 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
This is an unfixable issue
Code:
This system is not registered with RHN.
RHN support will be disabled.
until you buy the required support contract and register your install


there are two ways to fix this
1) buy the required support contract !
Desktop license
https://www.redhat.com/apps/store/desktop/
but you are running Oracles Database , so this is likely a server install
-- the server license
https://www.redhat.com/apps/store/server/

2)
install the FREE rebuild of RHEL ( rhel6.0 is outdated , the current is 6.4 )
CentOS 6.4
http://www.centos.org/

you have the 32 bit RHEL6.0 installed
So i am assuming that this is a rather OLD 32 bit computer

the 32 bit iso
http://mirrors.arsc.edu/centos/6.4/isos/i386/

but if this is new hardware the 64 bit os would be a bit better
http://mirrors.arsc.edu/centos/6.4/isos/x86_64/
 
Old 06-30-2013, 08:12 PM   #7
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
You have a mess of repos there that will conflict.

Assuming this is not running a prod system, I'd highly recommend replacing the whole thing with the latest Centos6.4; a free rebuild of RHEL6.4 - the latest version.
Start from there and do not add repos at random.

You can try adding EPEL repo to extend the multi-media capabilities, but you MUST install/setup yum-priorities first or it will conflict.
http://wiki.centos.org/PackageManagement/Yum/Priorities

I'm assuming you are not willing to pay for RHEL and in any case, they will not support any non-RHEL SW.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to boot RHEL 5.2 and Unable to mount root file system in rescue mode vknemannavar Red Hat 5 01-29-2010 10:05 AM
Unable to use wget and unable to ping machine from external source grunshaw Linux - Networking 3 10-24-2006 09:46 AM
Unable to Build ELDK3.1 for kernel 2.4.25. On Booting Unable to mount root fs.. kannath Debian 0 05-11-2006 10:26 AM
Unable to logon on as non-root user after update as unable to set executable context pls198 Fedora 2 04-09-2004 12:41 PM
Volume control is unable to run correctly. Unable to open audio device '/dev/mixer'. sevenreams Slackware 1 05-16-2003 08:29 PM


All times are GMT -5. The time now is 12:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration