LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2006, 04:58 PM   #16
PingFloyd
Member
 
Registered: Jun 2006
Posts: 94

Rep: Reputation: 16

I have the same problem as well.

Mine used to shutdown automatically before I upgraded to kernel 2.6. I used to use 2.4 and it worked ok.

I think I know a little bit of why it does this.

I've noticed that during bootup it gives an ACPI related message about my BIOS being "too old". I've done some reading up on this. Here is appearantly what is going on.

Back when I was using kernel 2.4 my system was probably utilizing APM instead of ACPI. There is appearantly some advantage to ACPI (I'm not sure what they are because I haven't had the time to do some serious research on the tons of info on ACPI out there. But suffice it to say that ACPI goes beyond just power management and has to do with configuration of some PCI devices etc.). Anyway, I believe alot of stock kernels come compiled by default to disable ACPI if your bios dates after a fairly more recent date (can't remember the exact date) just to play things safe.

There is a way to override this though. I've read of how to do it before, but can't remember exactly. I do believe there is actually a few different ways. One way that I remember was to force ACPI support through a kernel parameter on bootup.

The problem for me is that I can't seem to find any information to determine what the ramification of forcing ACPI support are. For example, how can one determine if it is or isn't safe when their BIOS is "too old"? Would it be a better idea to somehow enable APM instead for one of these "too old" BIOS?

Sorry I can't be of more help. But I'm guessing that those of you who are having the issue of where the computer used to shut down automatically, but now doesn't, have probably upgraded your kernel up to 2.6 by whatever means (upgraded distribution etc etc.) like in my case.

I think that probably the more important thing is finding out what the ramifications, of why ACPI is being disabled, are. And then take things from there be it to figure out how to reenable APM or force ACPI to be enabled if it can be determined that it will not create any less than obvious issues.
 
Old 08-01-2006, 05:08 PM   #17
AAnarchYY
Member
 
Registered: Sep 2004
Location: Carlisle, MA
Distribution: Debian 8
Posts: 419

Rep: Reputation: 30
for me what worked was adding the line append="apm=power-off" to lilo
Code:
image = /boot/bzImage-2.6.17.6
  root = /dev/hda1
  label = 2.6.17.6
  read-only
  append="apm=power-off"
 
Old 08-02-2006, 01:57 PM   #18
spank
Member
 
Registered: Aug 2003
Location: Romania
Distribution: Ubuntu 6.06
Posts: 278

Original Poster
Rep: Reputation: 30
thank you for your answers but i still wasn't able to solve the problem, nothing worked for me.
 
Old 08-02-2006, 11:19 PM   #19
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Just make sure the obvious isn't being missed, try

poweroff

or

halt -p
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start, stop, turn on, and turn off deamons BuckRogers01 Debian 3 08-16-2005 10:39 AM
telnet comand ylawayjdp Linux - Newbie 2 10-14-2004 02:01 PM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 09:05 AM
halt -p can't turn off power in debian lsj Linux - Newbie 2 04-05-2004 06:16 AM
Help w/comand line dolvmin Linux - Software 2 09-23-2003 05:28 PM


All times are GMT -5. The time now is 04:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration