LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-31-2006, 06:27 AM   #1
spank
Member
 
Registered: Aug 2003
Location: Romania
Distribution: Ubuntu 6.06
Posts: 278

Rep: Reputation: 30
turn off after halt comand


How can I make my computer turn off after i give the halt command? I think it is something related with enabling the ACPI function but i don't know how.
 
Old 07-31-2006, 07:14 AM   #2
carambar
LQ Newbie
 
Registered: Dec 2005
Location: Swindon, UK
Distribution: Debian
Posts: 26

Rep: Reputation: 15
Yes, I believe you're right... and I think that it's something you need to have enabled in the BIOS, hopefully someone will be along who can confirm this shortly
 
Old 07-31-2006, 07:22 AM   #3
spank
Member
 
Registered: Aug 2003
Location: Romania
Distribution: Ubuntu 6.06
Posts: 278

Original Poster
Rep: Reputation: 30
well it is enabled. when i had redhat on the same system with the same config it worked
 
Old 07-31-2006, 07:31 AM   #4
raskin
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: approximately NixOS (http://nixos.org)
Posts: 1,900

Rep: Reputation: 68
did you check commands like shutdown (I don't remember arguments) and 'init 0' ?
 
Old 07-31-2006, 07:32 AM   #5
spank
Member
 
Registered: Aug 2003
Location: Romania
Distribution: Ubuntu 6.06
Posts: 278

Original Poster
Rep: Reputation: 30
yes i did and it still waits for me to press the power button on the case
 
Old 07-31-2006, 08:22 AM   #6
raskin
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: approximately NixOS (http://nixos.org)
Posts: 1,900

Rep: Reputation: 68
Did you try to
modprobe acpi
?
 
Old 07-31-2006, 11:37 AM   #7
spank
Member
 
Registered: Aug 2003
Location: Romania
Distribution: Ubuntu 6.06
Posts: 278

Original Poster
Rep: Reputation: 30
Code:
root@marlboro[~/apache] # modprobe acpi
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.15-23-server/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device
nope... doesn't work

Last edited by spank; 07-31-2006 at 11:40 AM.
 
Old 07-31-2006, 11:42 AM   #8
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
I find that on my computer it's the apm module that needs to be enabled, as opposed to the acpi one. in slackware you need to uncomment the line in /etc/rc.d/rc.modules (if I remember rightly) which says /sbin/modprobe apm. reboot your machine, and next time you shutdown, it should completely turn off. it could be slightly different in red hat, although I'm sure the principle is roughly the same...

EDIT: maybe modprobe apm?
 
Old 07-31-2006, 11:52 AM   #9
raskin
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: approximately NixOS (http://nixos.org)
Posts: 1,900

Rep: Reputation: 68
Well, I don't remember any wrong modprobe command which brings more havoc than reboot. And most of them just fail. Try.
 
Old 07-31-2006, 12:20 PM   #10
spank
Member
 
Registered: Aug 2003
Location: Romania
Distribution: Ubuntu 6.06
Posts: 278

Original Poster
Rep: Reputation: 30
if i do a lsmod i get:
Code:
Module                  Size  Used by
apm                    23408  0
...
if i modprobe apm i don't get no message and if i halt it doesn't shutdown it still waits for me to touch that button
 
Old 07-31-2006, 12:22 PM   #11
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
might be worth checking in your BIOS settings to see if there's an apm option, to make sure that's enabled as i had to change that too.

of course, it could just be that apm isn't the solution...
 
Old 07-31-2006, 12:25 PM   #12
spank
Member
 
Registered: Aug 2003
Location: Romania
Distribution: Ubuntu 6.06
Posts: 278

Original Poster
Rep: Reputation: 30
yes it is enabled. The last distro that i had on this pc was fedora core 3 and it worked just fine with halt, but then i didn't pay any atention on how it halts.
 
Old 07-31-2006, 12:42 PM   #13
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
ah, I've got no more ideas then. sorry
 
Old 08-01-2006, 04:49 AM   #14
Lotharster
Member
 
Registered: Nov 2005
Posts: 144

Rep: Reputation: 18
I recently had the same problem with ubuntu dapper (on a 5 years old computer). I added the line
Code:
apm power_off=1
to /etc/modules. Then it worked for me.
 
Old 08-01-2006, 01:08 PM   #15
spank
Member
 
Registered: Aug 2003
Location: Romania
Distribution: Ubuntu 6.06
Posts: 278

Original Poster
Rep: Reputation: 30
now i've notice during boot time the following message:
Code:
ACPI: Unable to locate RDSP
It is related to my problem ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start, stop, turn on, and turn off deamons BuckRogers01 Debian 3 08-16-2005 09:39 AM
telnet comand ylawayjdp Linux - Newbie 2 10-14-2004 01:01 PM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 08:05 AM
halt -p can't turn off power in debian lsj Linux - Newbie 2 04-05-2004 05:16 AM
Help w/comand line dolvmin Linux - Software 2 09-23-2003 04:28 PM


All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration