LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2005, 02:53 AM   #1
Zharduron
LQ Newbie
 
Registered: Jan 2005
Location: Norway
Distribution: Mandrake 10.0
Posts: 4

Rep: Reputation: 0
Trying to install apache in Mandrake


I have used th guide I found at: cowbox.coe.uky.edu/stu/linux/apache/
But because of me using Mandrake and not SlackWare it does not work.
Everything went well until I came t the rc.httpd bit...
Could anyone please help me?

 
Old 01-10-2005, 03:32 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,732

Rep: Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584
If you have created the rc.httpd copy it to /etc/rc.d/init.d and make it executable:
Code:
cp rc.httpd /etc/rc.d/init.d
chmod +x /etc/rc.d/init.d/rc.httpd
Then create symlinks for your default runlevel (usually 5)
Code:
ln -s /etc/rc.d/init.d/rc.httpd /etc/rc.d/rc5.d/S99apache
ln -s /etc/rc.d/init.d/rc.httpd /etc/rc.d/rc5.d/K99apache
You can test if it works by running:
Code:
/etc/rc.d/rc5.d/S99apache
More details about runlevels and start-up scripts for Mandrake here
 
Old 01-11-2005, 12:58 PM   #3
Zharduron
LQ Newbie
 
Registered: Jan 2005
Location: Norway
Distribution: Mandrake 10.0
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks a bunch...
It realy helped...
I'm going to ask more questions later.
Please help me again if you can...


uhm... I got a new problem here...
the computer say this when I try to open S99apache;

[root@vvs-2ita-10 rc.d]# /etc/rc.d/rc5.d/S99apache start
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Do you know how to fix this? Because I have no idea...

Last edited by Zharduron; 01-12-2005 at 01:30 AM.
 
Old 01-12-2005, 02:00 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,732

Rep: Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584
That means that apache is already running. Run:
Code:
ps -ef|grep httpd
to verify it.
If it's not, then something else uses port 80. To see what:
Code:
fuser -v -n tcp 80
Also take a look at apache error-log (according to the guide you followed it's should be in /home/httpd/logs) to see if you see anything wrong.
BTW note that "make install" must be run as the root user, so perhaps that's the reason that port 80 cannot be opened, if nothing is listening at that port.
Regards
 
Old 01-12-2005, 02:29 AM   #5
Zharduron
LQ Newbie
 
Registered: Jan 2005
Location: Norway
Distribution: Mandrake 10.0
Posts: 4

Original Poster
Rep: Reputation: 0
Thumbs up

Thanks again!
It was running. ^_^'
Now I'm trying to install PHP, but my download did not contain the necessary files.
Do you know a good download that works, and mayby how to use it and install it?
It would help me allot...
Thanks again for the help earlier. ^_^
 
Old 01-12-2005, 03:31 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,732

Rep: Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584
Go to http://www.php.net and d/l the latest release sources from there.
Then since you installed apache with DSO (dynamic module) support, follow the instructions in the INSTALL file about installing php as a DSO. You should run something like:
Code:
./configure --with-apxs2=/home/httpd [--other-options-you-want-to-use]
make; make install
make install will hopefully make the necessary changes to httpd/conf (check to be soure) and then restart apache.
 
Old 01-14-2005, 05:28 AM   #7
Zharduron
LQ Newbie
 
Registered: Jan 2005
Location: Norway
Distribution: Mandrake 10.0
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks, but when I try it I end up with my PC saying this:


Sorry, I cannot run apxs. Possible reasons follow:

1. Perl is not installed
2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is displayed)

The output of /home/apache follows:
./configure: line 5085: /home/apache: is a directory
configure: error: Aborting


Do you have any idea what I could be doing wrong?

Wait it is doing something...

Now it is saying:
configure: error: xml2-config not found. Please check your libxml2 installation.

Do you know where that file is?

Last edited by Zharduron; 01-14-2005 at 05:32 AM.
 
Old 01-14-2005, 04:32 PM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,732

Rep: Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584
Quote:
apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
You have to give the full path to apxs "/home/httpd/bin/apxs" to ./config
As for libxml2 you have to install it, if it's not already installed, either from source (http://xmlsoft.org/downloads.html), or using Mandrake's package manager (apt-get). Note that you must install libxml2 and libxml2-devel to compile php.
If it's installed give the path to the installation directory at the ./config script.
 
Old 01-19-2005, 04:14 AM   #9
nadezico
LQ Newbie
 
Registered: Jan 2005
Posts: 3

Rep: Reputation: 0
I tried to install PHP but failed as I tried to make some changes in the /configure file, this was the error she gave me:

configure: warning: You will need bison if you want to regenerate the PHP parsers.
checking for flex... lex
checking for yywrap in -ll... no
checking lex output file root... ./configure: line 2420: lex: command not found
configure: error: cannot find output from lex; giving up

Do anybody have any idea of what I have done wrong?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10 - Install Apache (BEGINNER) mattyk6 Linux - Software 3 01-15-2005 04:53 PM
Apache and Mandrake 10.1 rbudj Mandriva 4 12-17-2004 10:51 AM
Mandrake 8.2: getting error on Apache-2.0.43 install robroto88 Mandriva 2 02-02-2004 04:46 PM
RH8.0 : Need to uninstall Apache 2 and install Apache 1 ericcarlson Linux - Software 1 02-10-2003 02:13 PM
Removing apache rpm and install apache from source john lee Linux - Software 2 11-15-2001 08:44 PM


All times are GMT -5. The time now is 08:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration