LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-29-2014, 06:07 PM   #1
Bruno Zero
LQ Newbie
 
Registered: Apr 2014
Posts: 7

Rep: Reputation: Disabled
Question Trouble with keyboard in Lubuntu 13


Hello everybody,

I am new Linux user (Lubuntu 13.0.4) and I am having a problem with my keyboard. My keyboard is French (Canadian), which is just a QWERTY keyboard adapted to French. In this keyboard some important accents and special characters are typed by pressing Ctrl + Alt + certains keys. In my case these accents and special characters do not show at all. For exemple, the «at» that you need to type an email address is obtained by typing Ctrl + Alt + 2 and it doesn't show at all. If I try to type it when using AbiWord instead of showing this character it changes the size of the text from 12 to 14. More worringly, when I try to use the terminal prompt I am able to enter thre command that I want (ex: sudo apt-get install flashplugin installer), but when I press enter and the prompt asks me to type my passsword I am totally unable to do it because my keyboard ceases to work completely and I am no longer able to type anything.

I have reinstalled Lubuntu to try to correct this problem paying special attention to the selection of the keyboard. Although my keyboard was selected correctly, I tested the keyboard at the installer prompt but he characters did not show up anyway.

Could this be just be my keyboard (an old Dell Quietkey USB keyboard which came with my Dell Dimension 2400 series with a Celeron processor that I bought way back in 2005) ? Or is this a Lubuntu/Ubuntu issue? This is strange because my keyboard works fine in the Windows XP enviroment ( I have a Dual Boot).

Any help will be appreciated. Thank you in advance.

Bruno Zero
 
Old 04-30-2014, 08:01 AM   #2
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
Sorry to tell you this, but ubuntu/lubuntu/etc. 13.04 versions are 'end of life', out of support'. I'd get a newer install disc, like lubuntu 14.04 which has just been released, and try that.
 
Old 04-30-2014, 11:32 AM   #3
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,159

Rep: Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822
on my keyboard, i can access @ with "Alt Gr" + "2". The "alt Gr" key is on the right side of the space key.

if you give your password in a terminal, it does not give any feedback. just type your password as you normally would and press return.

both these "problems" will occur on lubuntu 14.04 as well, nevertheless cascade9 is right.
 
1 members found this post helpful.
Old 04-30-2014, 11:52 AM   #4
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,158

Rep: Reputation: 1222Reputation: 1222Reputation: 1222Reputation: 1222Reputation: 1222Reputation: 1222Reputation: 1222Reputation: 1222Reputation: 1222
Ctrl + Alt + 2 is not a proper Linux keystroke! Is it what you use in Windows? The way to get "@" is AltGr + 2. You can find the keyboard driver file at /usr/share/X11/xkg/symbols/ca. It has entries like
key <AE02> {[ 2, quotedbl, at ]};
Which means that in the alphanumeric area (A), 5th row up (E), the second key (02) produces a "2", a double-quotation mark with Shift, and a @ with AltGr.
Similarly,
key <AD11> {[ dead_circumflex, dead_circumflex, bracketleft ]};
shows that the key after P gives you a combining circumflex, but a "[" with AltGr.
 
1 members found this post helpful.
Old 04-30-2014, 12:20 PM   #5
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Ctrl+Alt+n is a windows thing that let you add different symblos. I get around that by using a character map type of thing.

http://askubuntu.com/questions/30245...-cant-input-it

https://wiki.gnome.org/Apps/Gucharmap
 
Old 04-30-2014, 12:31 PM   #6
Bruno Zero
LQ Newbie
 
Registered: Apr 2014
Posts: 7

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by ondoho View Post
on my keyboard, i can access @ with "Alt Gr" + "2". The "alt Gr" key is on the right side of the space key.

if you give your password in a terminal, it does not give any feedback. just type your password as you normally would and press return.

both these "problems" will occur on lubuntu 14.04 as well, nevertheless cascade9 is right.
Thank you very much. You were right on both counts.
 
Old 04-30-2014, 02:21 PM   #7
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,159

Rep: Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822
Quote:
Originally Posted by Bruno Zero View Post
Thank you very much. You were right on both counts.
could you mark this solved then?
others will benefit.
 
Old 04-30-2014, 02:39 PM   #8
Bruno Zero
LQ Newbie
 
Registered: Apr 2014
Posts: 7

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by DavidMcCann View Post
Ctrl + Alt + 2 is not a proper Linux keystroke! Is it what you use in Windows? The way to get "@" is AltGr + 2. You can find the keyboard driver file at /usr/share/X11/xkg/symbols/ca. It has entries like
key <AE02> {[ 2, quotedbl, at ]};
Which means that in the alphanumeric area (A), 5th row up (E), the second key (02) produces a "2", a double-quotation mark with Shift, and a @ with AltGr.
Similarly,
key <AD11> {[ dead_circumflex, dead_circumflex, bracketleft ]};
shows that the key after P gives you a combining circumflex, but a "[" with AltGr.
Thank you very much, David. I always used Crtl + Alt in Windows to get the special characters that I needed, but I didn't know that this wouldn't work in the Linux environment. Now I know that I should use instead the Alt Gr key to get them. By the way, the Alt Gr key also works fine in Windows but, ignorant me, I didn't know that or I didn't remember it.
Bruno
 
Old 04-30-2014, 02:47 PM   #9
Bruno Zero
LQ Newbie
 
Registered: Apr 2014
Posts: 7

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by cascade9 View Post
Sorry to tell you this, but ubuntu/lubuntu/etc. 13.04 versions are 'end of life', out of support'. I'd get a newer install disc, like lubuntu 14.04 which has just been released, and try that.
Thank you, cascade9. I didn't want to upgrade before I pinpointed whta was the trouble with my keyboard. Now that I know there was nothing wrong with it, I have already updated my version of Lubuntu and my computer is working fine.
Bruno
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lubuntu PPC 13.04 trouble installing on iBook G4 acantony Linux - Desktop 1 01-17-2014 09:41 PM
keyboard trouble JS_SAVES Linux - Newbie 2 06-12-2007 12:59 PM
Keyboard trouble max2004 Linux - Hardware 6 11-12-2006 07:43 AM
Keyboard trouble TheMusicGuy Linux - Hardware 0 05-04-2004 04:33 PM
Keyboard trouble seriv Linux - Hardware 3 09-02-2003 02:07 PM


All times are GMT -5. The time now is 04:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration