LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-09-2006, 03:08 PM   #1
max2004
Member
 
Registered: Feb 2005
Posts: 57

Rep: Reputation: 15
Keyboard trouble


Hi,

I run Gentoo with KDE and I have a german keyboard (Cherry RS 6000 M). However only the "basic" keys work, i.e. no "@", no "|", no umlauts like "", no backslash. And the KDE Keyboard Tool (the little flag in the panel that indicates which keyboard layout you are using) shows "ERR: Error changing keyboard layout to 'de(nodeadkeys)'" (or "... to 'en(basic)'"). In the KDE Control Center I set
  • Keyboard model: Generic 104-key PC (tried several other)
  • Active layouts: "us basic" and "de nodeadkeys" (tried also "de basic")

Here is my /etc/X11/xorg.conf:
Code:
Section "ServerLayout"
	Identifier	"X.Org Configured"
	Screen	0	"Screen0" 0 0
	InputDevice	"Keyboard0" "CoreKeyboard"
	InputDevice	"PS/2 Mouse" "AlwaysCore"
...
Section "InputDevice"
	Identifier	"Keyboard0"
	Driver	"kbd"
	Option	"CoreKeyboard"
	Option	"XkbRules" "xorg"
	Option	"XkbModel" "pc104"
	Option	"XkbOptions" "grp:toggle,grp_led:scroll"
	Option	"XkbVariant" ",winkeys"
EndSection
...
Any idea anyone?

Thanks a lot guys!
Max
 
Old 11-09-2006, 03:10 PM   #2
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
try "pc105" instead of "pc104".
 
Old 11-10-2006, 05:22 AM   #3
max2004
Member
 
Registered: Feb 2005
Posts: 57

Original Poster
Rep: Reputation: 15
Hi uselpa,

thx for your post. I changed Option "XkbModel" "pc104" to Option "XkbModel" "pc105" in the xorg.conf and set the keyboard model to "Generic 105-key (Intl) PC" in the KDE Control Center. Didn't work though.

What else could I try?
Max
 
Old 11-10-2006, 02:22 PM   #4
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Try something minimalistic, without CoreKeyboard, Options and Variant. Here's mine, for example (for a swiss-french keyboard):
Code:
Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option     "XkbModel"      "pc105"
    Option     "XkbLayout"     "ch"
    Option     "XkbVariant"    "fr"
EndSection
so yours should be
Code:
Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option     "XkbModel"      "pc105"
    Option     "XkbLayout"     "de"
EndSection
 
Old 11-11-2006, 09:01 AM   #5
max2004
Member
 
Registered: Feb 2005
Posts: 57

Original Poster
Rep: Reputation: 15
Sweet! It works!
You cannot imagine how good it feels to just press the button for "@" and see it appearing on the screen

Thx again!
 
Old 11-12-2006, 05:09 AM   #6
max2004
Member
 
Registered: Feb 2005
Posts: 57

Original Poster
Rep: Reputation: 15
Arg!! I just realized something weired: When I do a console login and then startx, they keyboard works. When I do a graphical login to KDE, the keyboard doesn't work (e.g. behaves as described above)!

What could the problem be?

Thanks again,
Max
 
Old 11-12-2006, 06:43 AM   #7
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
One possible reason I see is that you have more than one xorg.conf (or any of its other possible names) and that, when X is started from the initscripts, it uses another conf file or another combination of conf files than the one used by a manual startx command.

If you start it manually, you're probably not root, but your init scripts are run by root. So your root user might have a personal .xserverrc that changes the keyboard settings. Try to log in as root and type "startx", does the keyboard work? What if you are another user?

If that doesn't clarify the issue, look for local configuration files, analyse your initscripts and see how X is started in your 'graphical' runlevel, or the brute-force method: as root, type "cd / && grep -R Keyboard * | less". The latter will take some time, though.
 
  


Reply

Tags
german, keyboard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble configuring keyboard yakotey Debian 5 02-21-2006 05:00 AM
Keyboard trouble with install Cripple Linux - Newbie 1 11-12-2005 12:38 AM
Keyboard trouble TheMusicGuy Linux - Hardware 0 05-04-2004 03:33 PM
Trouble on keyboard map SykoMachine Slackware - Installation 9 01-29-2004 04:01 PM
Keyboard trouble seriv Linux - Hardware 3 09-02-2003 01:07 PM


All times are GMT -5. The time now is 06:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration