LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-05-2004, 04:07 PM   #31
lamedavis
Member
 
Registered: Jan 2004
Location: Ashland, Oregon
Distribution: Fedora Core 1 & 2
Posts: 51

Rep: Reputation: 15

bump
 
Old 06-05-2004, 05:48 PM   #32
daemonspyre
LQ Newbie
 
Registered: Jun 2004
Location: NJ
Distribution: RH9
Posts: 14

Rep: Reputation: 0
In your my.cnf file, you need to edit the InnoDB section. REM out the lines that talk about InnoDB (using the # symbol). Your /etc/my.cnf file should look something like this:

*****************************************
[client]
#password = your_password
port = 3306
socket = /tmp/mysql.sock

[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 384M
max_allowed_packet = 1M
table_cache = 512
sort_buffer_size = 2M
read_buffer_size = 2M
read_rnd_buffer_size = 8M
myisam_sort_buffer_size = 64M
thread_cache = 8
query_cache_size = 32M
thread_concurrency = 8

log-bin
server-id = 1

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
safe-updates

[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout
**************************************

If it doesn't, make it by
shell> cp mysql/support-files/my-huge.cnf /etc/my.cnf

Let me know if that helps you out. Don't forget to shutdown the mysqld first, then edit the cnf file, then restart the server.
 
Old 06-05-2004, 07:53 PM   #33
lamedavis
Member
 
Registered: Jan 2004
Location: Ashland, Oregon
Distribution: Fedora Core 1 & 2
Posts: 51

Rep: Reputation: 15
the /etc/my.cnf file does not refer to that at all...here it is

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

[mysql.server]
user=mysql
basedir=/var/lib

[safe_mysqld]
err-log=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid


so I dont know what to do from here.

thanks
Jeremy
 
Old 06-06-2004, 08:07 AM   #34
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 939

Rep: Reputation: 32
I just came aross that file i was on about before.

did you look in your php.ini file there are setting in there for mysql

TT
 
Old 06-06-2004, 10:35 PM   #35
daemonspyre
LQ Newbie
 
Registered: Jun 2004
Location: NJ
Distribution: RH9
Posts: 14

Rep: Reputation: 0
What version of mysql are you using? It seems as though you are using 3.23, while the latest stable version is 4.1.2.

Did you copy the my-huge.cnf to my.cnf like I said before? That would have made your cnf look more like the one I put in.

shell> cp /path/to/mysql/support-files/my-huge.cnf /etc/my.cnf
 
Old 06-07-2004, 02:16 AM   #36
lamedavis
Member
 
Registered: Jan 2004
Location: Ashland, Oregon
Distribution: Fedora Core 1 & 2
Posts: 51

Rep: Reputation: 15
sorry I just did that...I guess all I need now is to set it up to start up at boot?

I appreciate all your help,

Jeremy
 
Old 06-07-2004, 07:54 AM   #37
daemonspyre
LQ Newbie
 
Registered: Jun 2004
Location: NJ
Distribution: RH9
Posts: 14

Rep: Reputation: 0
OK, to start up at boot is a fun, but not too hard (just not intuitive).

There are a few steps, and I will start them with line numbers. All shell> mean you should be root, at the /path/to/mysql (ie [root@localhost mysql] >). If you are not root, these inst. won't work...

1. shell> cp support-files/mysql.server /etc/init.d
2. shell> chmod +x /etc/init.d/mysql.server
3. shell> ln -s /etc/init.d/mysql.server /etc/rc.d/rc3.d/S99mysql
4. shell> ln -s /etc/init.d/mysql.server /etc/rc.d/rc5.d/S99mysql
5. shell> ln -s /etc/init.d/mysql.server /etc/rc.d/rc0.d/S01mysql

to make life easy on you (if you didn't install the RPM and installed the binary) you will need to copy a couple of files to your /usr/bin directory. Still as root and still at mysql dir:

6. shell> ln -s bin/mysqladmin /usr/bin/.
7. shell> ln -s bin/myisamchk /usr/bin/.
8. shell> ln -s bin/mysql /usr/bin/.
9. shell> ln -s bin/mysqldump /usr/bin/.
10. shell> ln -s bin/myisampack /usr/bin/.

Those are the big ones that you will use more often than not. Let me know if you need anything else for your MySQL. And have fun with it. To make life easy to start learning SQL syntaxt, you might want to download the MySQL Control Center. It makes it easy to learn syntaxt from scratch.
 
Old 06-07-2004, 12:03 PM   #38
lamedavis
Member
 
Registered: Jan 2004
Location: Ashland, Oregon
Distribution: Fedora Core 1 & 2
Posts: 51

Rep: Reputation: 15
awesome thanks again for all of your help

Jeremy
 
Old 06-16-2004, 05:04 PM   #39
darklordzim
Member
 
Registered: Apr 2004
Location: Minnesota USA
Distribution: Ubuntu 9.10 desktop, and 9.4 server
Posts: 50

Rep: Reputation: 15
strange

i seem to be having a similar problem, but it appears i dont have a 'my-huge.cnf' anywhere in my system..
any ideas?
 
Old 06-16-2004, 05:33 PM   #40
daemonspyre
LQ Newbie
 
Registered: Jun 2004
Location: NJ
Distribution: RH9
Posts: 14

Rep: Reputation: 0
Did you install the binaries or the RPMs? If you installed the RPMs, look at /etc/my.cnf for your config. If you installed the binaries, they are in your mysql/support-files folder
 
Old 06-16-2004, 07:32 PM   #41
darklordzim
Member
 
Registered: Apr 2004
Location: Minnesota USA
Distribution: Ubuntu 9.10 desktop, and 9.4 server
Posts: 50

Rep: Reputation: 15
my install

well i installed straight off the fedora core 1 cd. so i would assume its the rpm since thats the "red hat way"
my.cnf doesn't look like what you posted it should.. it looks like the first one:

i ran this: cat /etc/my.cnf (which returned the following)

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

[mysql.server]
user=mysql
basedir=/var/lib

[safe_mysqld]
err-log=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

now i've gotten my password changed but i still cant connect with mysql cc from my other computer.. i get an error message "the host <my local ip> is not allowed to access this mysql server"
so my main qustion is how the HECK do i add an ip to the connect list

the main reason is becaues i'm using the other computer for all my website administration, i have an ssh connection and stuff.. so i just remote to my server, because its easier than running accross the house to make a quick change ^_^
 
Old 06-16-2004, 11:01 PM   #42
daemonspyre
LQ Newbie
 
Registered: Jun 2004
Location: NJ
Distribution: RH9
Posts: 14

Rep: Reputation: 0
Step 1 - UNINSTALL the Fedora version. 1) it's old and there is a much more stable version out there 2) the binaries are easier to work with.

Step 2 - Download version 4.1 from http://www.mysql.com/downloads/index.html and get the binaries from there.

Step 3 - Read the README on the installation. Email me directly or just look up on here if you have any problems.

Step 4 - To add a computer account, log onto mysql (on Fedora) using the
shell> mysql -u <username> -p <database_name>

Then:
mysql> GRANT <privileges> ON <database> TO 'username'@'computer_name' IDENTIFIED BY <password> USING GRANT OPTION;

<privildges> range from SELECT, UPDATE, DELETE (see documentation or MySQL CC for other options)

'username'@'comp_name' you must use the backticks. Use '%' as a wildcard (example ... to '_darklordizm_'@'%' ... means any computer anywhere. This can be a security problem, so it's best if you put the individual hostname in for every user).

That's it. Email me if you have any other questions!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble logging in spartn119 Slackware 11 12-14-2004 04:31 PM
trouble logging in into Linux Redhat 6.0 irmwakimn Linux - Software 2 07-21-2004 09:52 AM
Trouble Logging in to mysql jevnin Linux - General 6 05-31-2004 01:23 AM
having trouble logging in paul62 Slackware 2 03-28-2004 07:52 AM
Logging out of X and into trouble LonnieB Linux - General 2 07-05-2003 08:31 AM


All times are GMT -5. The time now is 08:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration