LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2004, 04:58 PM   #1
BeetleBailey
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Rep: Reputation: 0
trouble installing libavifile-0.7-0.7.38 (for mjpeg tools installation)


I'm new to Linux, so bear with me....
I'm trying to install libavifile b/c it's listed as a dependency of the mjpegtools library
It configures, but will not make or make install
I'm running Pink Tie Linux (variant of Red Hat)
after the ./configure and trying the make command I get this error at the end of the output:

rm -fr .libs/libaviplay.la .libs/libaviplay.* .libs/libaviplay-0.7.*
gcc -shared codeckeeper.lo Uncompressed.lo -Wl,--whole-archive aviplay/.libs/libaviplay.al aviread/.libs/libaviread.al aviwrite/.libs/libaviwrite.al common/.libs/libcommon.al subtitle/.libs/libsubtitle.al video/.libs/libvideo.al -Wl,--no-whole-archive -Wl,--rpath -Wl,/root/avifile-0.7-0.7.38/ffmpeg/libavformat/.libs -Wl,--rpath -Wl,/root/avifile-0.7-0.7.38/ffmpeg/libavcodec/.libs -Wl,--rpath -Wl,/root/avifile-0.7-0.7.38/drivers/vidix/.libs -Wl,--rpath -Wl,/root/avifile-0.7-0.7.38/drivers/libdha/.libs -Wl,--rpath -Wl,/usr/local/lib -L/root/avifile-0.7-0.7.38/drivers/libdha/.libs -L/usr/X11R6/lib /root/avifile-0.7-0.7.38/ffmpeg/libavformat/.libs/libaviplayavformat.so -lz /root/avifile-0.7-0.7.38/ffmpeg/libavcodec/.libs/libaviplayavcodec.so /usr/lib/libSDL.so -lm -lX11 -lXext /root/avifile-0.7-0.7.38/drivers/vidix/.libs/libaviplayvidix.so /root/avifile-0.7-0.7.38/drivers/libdha/.libs/libaviplaydha.so -lpthread -lnsl -ldl -Wl,-soname -Wl,libaviplay-0.7.so.0 -o .libs/libaviplay-0.7.so.0.0.38
/usr/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
make[2]: *** [libaviplay.la] Error 1
make[2]: Leaving directory `/root/avifile-0.7-0.7.38/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/avifile-0.7-0.7.38/lib'
make: *** [all-recursive] Error 1


Does anyone know what -lX11 is or how I can fix this ????

Thanks in advance!!!!!
 
Old 07-10-2004, 05:46 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,487

Rep: Reputation: 88
X11 is the X11 development libraries - did you install Pink Tie with something like "XWindows development" checked? In the RedHat 9 install you get this option. If you do NOT check it, the X11 development libraries are NOT installed and this means that any program/library which needs them will not compile - 'cause it can't find them.

Your best bet is to either download the X11 libraries from the xwindows website (xfree86.org if I remember right) but this is a bit of tough one. I would rather recommend to re-install Pink Tie and look for an option somewhere during installation that refers to X11 or XWindows development. As far as I know, you need to install the whole shebang (i. e. Xwindows itself, all the fonts, drivers, AS WELL AS any development libraries or Xwindows development stuff).

In short, the error you posted is 'cause your gcc can't find the X11 libraries to link into the libavifile library.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What are MJPEG-tools? How do I use them? rrrssssss Linux - Software 1 11-20-2005 07:41 AM
Trouble installing wireless-tools & trying to install Wireless PCI pragmatic Linux - Wireless Networking 1 06-21-2005 08:39 AM
Trouble with Wine Tools / Xdialog qwaven SUSE / openSUSE 1 02-20-2005 12:13 PM
trouble installing mandrake 9.1 freezing during installation skilgannon Mandriva 1 11-19-2003 07:21 PM
Having Trouble compiling mii-tools LinuxRacr Linux - Software 1 06-07-2002 02:28 PM


All times are GMT -5. The time now is 04:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration