LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-29-2003, 05:46 AM   #1
Minotaur
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Rep: Reputation: 0
Question textmode/graphicmode


I use suse 8.2

When I usually boot linux it automaticly opens the graphic mode, but now it boots in the textmode, how I can switch this back, because I have absolutly no idee how to go from text to graphic mode or the other way around...
 
Old 10-29-2003, 05:52 AM   #2
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
Try startx to get back into x, windows, GUI whatever. Not sure how to make it do it automatically in SuSE though. In Mandrake you tell it to boot into init 5. No clue really.

If you get into x, you may can find a setting that will change the booting.

It also may be that something is configured wrong. If you type startx and get nothing or a error then you need a SuSE guru. I'm not one of those.

Hope that gets you started anyway.

Later

 
Old 10-29-2003, 06:07 AM   #3
Minotaur
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
nope it didnt work... I head something of init 5 but is says it is not a valid bash command
 
Old 10-29-2003, 06:39 AM   #4
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
Login and type

Code:
startx
no spaces and all one word. You should get a error at least. Post that and maybe a SuSE guru will come along.

Sorry not much more help.

Later

 
Old 10-29-2003, 06:45 AM   #5
quarryman
LQ Newbie
 
Registered: Oct 2003
Location: Dublin, Ireland
Distribution: Mandrake 9.1, RedHat 9.0
Posts: 15

Rep: Reputation: 0
this is a pretty obvious question but it happened to me and couldn't figure out what was going wrong...

Is there a boot disk in the floppy drive?! That happned to me with mandrake and i kept rebooting not noticing it was booting off the disk!

just a thought
 
Old 10-29-2003, 06:50 AM   #6
Minotaur
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
nope no bootdisks

and I will try that startx
 
Old 10-29-2003, 07:16 AM   #7
Minotaur
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
okay the startx message was a bit long so I picked the essential parts of it:

Code:
(EE) nod evices detected

fatal server error: no screen found

X10: fatal IO error 104 (connection reset by peer) 

after 0 requests (0 known proccesed) with 0 evnts remaining ":0.0:
the rest was info over senting the error etc and what (EE) etc means an if you have the newest Xblahblah version.

but I always worked... until today...
 
Old 10-29-2003, 07:22 AM   #8
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
I think Mandrake has a runlevel in /etc/inittab, the same as everybody else. I think their gui level is '5'. So edit that file.

As far as switching, 'startx' is the usual way to go from console to gui. A normal exit from the window manager should take you to from gui to console (ctrl-alt-backspace is the violent way) but a lot of graphical login managers trap that and leave you stuck in the damn gui.

The standard way to move from one to the other without actually exiting X is to do 'ctrl-alt-f?' which will take you through the terminals, 1-6 usually being text and 7 usually being gui, just like 'alt-f?' takes you through the terminals once you're out of the gui.

I boot to console by default and do startx to get to X because xdm, gdm, kdm, and all that stuff is a pointless annoying waste and, if your X gets screwed up, you get entirely screwed up. With console and startx and ctrl-alt-backspace working, no gui problem is any big deal and movement from one to the other is easy.
 
Old 10-29-2003, 07:25 AM   #9
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Man I'm slow. Sounds like you need to run xf86config or xf86cfg or something and set up your X again, or look at your XF86Config file and see if anything looks funny. But I really don't know about Mandrake. I ran it for a couple of days, but that's it.
 
Old 10-29-2003, 07:29 AM   #10
Minotaur
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
Ehhmm tnx, but I am a bit a linux n00b so could you use a bit less terms and be a bit more clear of what I am suppost to do
 
Old 10-29-2003, 08:17 AM   #11
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Well, like I say, I don't know what resources Mandrake has for setting up X. If you're at a command prompt, you can type

'xf86config'

assuming that's on your system, which it probably is, and follow the steps that it presents to give information about your hardware. Or type

'xf86cfg'

which will pop up a minimal graphics environment in which you can try to configure it that way. It could be something else, but 'no screen found' usually just means it has no idea what or where your display is. So you have to say 'I've got this monitor and this video card and want this resolution' and so on. But there may well be some Mandrake wizard that you can jump start from the command line, so you might want to look for something like that or wait for an actual Mandrake user to come along and pitch in.

I initially thought you were just having difficulty getting in and out of X and thought I could help with that but, if you're having problems getting X to run properly even when activating it properly, it's a bit more than I thought.
 
Old 10-29-2003, 08:31 AM   #12
gazza
Member
 
Registered: Jun 2003
Distribution: Mandrake 10.1 Official
Posts: 157

Rep: Reputation: 30
Try this type telinit 5
 
Old 10-29-2003, 11:51 AM   #13
Minotaur
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
telinit 5 is still an invalid bash command

and I tried xf86config set it al up, but it still didnt work

for xf86cfg I need to be the root, and I have no idea how to become it (although i know the passord)
 
Old 10-29-2003, 04:14 PM   #14
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
becoming root, type in

Code:
su -
and then your password for root. It should look something like this.

Code:
[dale@smoker dale]$ su -
Password:
[root@smoker root]#
Note where it changed from dale, regular user, to root and the password is hidden.

Hope that helps.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I force 2.6.14 kernel to use 80x25 textmode in console? rylan76 Linux - Newbie 3 11-26-2005 04:24 PM
Gentoo 4.2 LiveCD : textmode only gjo Linux - Distributions 1 05-29-2005 02:45 PM
those quotes after textmode-login artificialGekko Slackware 6 03-19-2005 08:42 AM
Runlevel 4 & textmode logins BorisMcHack Slackware 8 05-23-2004 11:24 PM
Relogin in textmode Rex_chaos Linux - General 2 03-31-2002 01:17 PM


All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration