LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-25-2005, 02:19 PM   #1
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
How can I force 2.6.14 kernel to use 80x25 textmode in console?


Hi guys

I managed to compile my first working kernel 2.6.14 kernel today! Yay - only problem is it starts up in runlevel 3 (the text mode one) with a really offensive looking VGA graphic console - on my particular monitor it just looks sick...

How can I force the kernel to use 80x25 textmode when it starts, INSTEAD of the VGA one?

I tried editing the .config in the kernel source tree and set

CONFIG_VGA_CONSOLE=y

to

#CONFIG_VGA_CONSOLE is not set

but as soon as I do make all in the source directory this gets reset to CONFIG_VGA_CONSOLE=y

So - is there a kernel "parameter" I can put in GRUB somewhere to force the kernel to use 80x25 text instead of the VGA console? What must my grub.conf look like to pass a kernel parameter?

Thanks a lot!
 
Old 11-25-2005, 02:24 PM   #2
BinJajer
Member
 
Registered: Sep 2005
Location: Warsaw, Poland
Distribution: Slackware 10.2, Caldera OpenLinux 3.1, Corel Linux (Thanks xhi!), Debian GNU/HURD etc...
Posts: 296
Blog Entries: 1

Rep: Reputation: 30
Allrightey:
1. Redhat is old, go get something more recent.(No offence, but gentoo is fab)
2.Why not a framebuffer splash? Look around LQ, you'll find a HOWTO somewhere...

Peace

Binjajer
 
Old 11-26-2005, 11:26 AM   #3
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Original Poster
Rep: Reputation: 87
Haha - ok, but it works for me.

I HATE those splash screen thingies - just a personal opinion.

Anyway, I got it to go away by fiddling with some kernel options - now the darn PC won't turn off! *sigh*

Time to start fiddling with the ACPI stuff... and then DMA - it never stops!

Thanks for the help
 
Old 11-26-2005, 03:24 PM   #4
BinJajer
Member
 
Registered: Sep 2005
Location: Warsaw, Poland
Distribution: Slackware 10.2, Caldera OpenLinux 3.1, Corel Linux (Thanks xhi!), Debian GNU/HURD etc...
Posts: 296
Blog Entries: 1

Rep: Reputation: 30
LOL, the kernel doesn't react to sig 0 ?

Look around LQ, I've seen someone with a similar prob ...

As for the other issues, modern ;D distros have the support default, so I still suggest getting something more umm... say ... modern era?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How-To Set Terminal to 80x25? longtex Suse/Novell 4 10-01-2005 01:03 PM
80x25 256 color? coldsalmon Linux - General 2 03-24-2005 02:56 PM
80x25 and Greater... SpEcIeS Debian 4 02-07-2005 11:10 AM
textmode/graphicmode Minotaur Linux - Newbie 13 10-29-2003 03:14 PM
Relogin in textmode Rex_chaos Linux - General 2 03-31-2002 12:17 PM


All times are GMT -5. The time now is 07:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration