LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 08-26-2005, 01:06 PM   #1
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
Telnet : Temporary failure in name resolution : Host name lookup failure


Hi,

I am connected to the outside world via a proxy server. The I.P. of the proxy server is 10.10.11.2
I cannot telnet to a remote computer.

Here is what I am doing :

Code:
koodoo@knapsacker:~$ export http_proxy=http://10.10.11.2:8080
koodoo@knapsacker:~$ export ftp_proxy=http://10.10.11.2:8080
koodoo@knapsacker:~$ telnet drill.hackerslab.org
telnet: drill.hackerslab.org: Temporary failure in name resolution
drill.hackerslab.org: Host name lookup failure
koodoo@knapsacker:~$
I have not done any other changes anywhere.
I am currently using Slackware 10.0
I know I have to do some settings somewhere, (maybe edit some files to tell telnet where to lookup for hosts etc)

But at this point I am completely clueless

Thanks in anticipation
 
Old 08-26-2005, 01:42 PM   #2
nixcraft
Member
 
Registered: Nov 2004
Location: BIOS
Distribution: RHEL3.0, FreeBSD 5.x, Debian 3.x, Soaris x86 v10
Posts: 379

Rep: Reputation: 30
Yup you need to setup linux as dns client see by editing /etc/resolv.conf file
http://www.cyberciti.biz/nixcraft/vi...ns-client.html
 
Old 08-26-2005, 04:25 PM   #3
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Hi,

Thanks Nixcraft for the reply and the link. I'll check it out and see if I can get telnet running.
Thanks
 
Old 08-27-2005, 08:55 AM   #4
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Hi Nixcraft,

I read the link you gave me. It said :

Code:
1) Open /etc/resolv.conf file:
vi /etc/resolv.conf

2) Add ISP nameserver as follows:
search isp.com
nameserver 202.54.1.110
nameserver 202.54.1.112
nameserver 202.54.1.115

Note Max. three nameserver can be used/defined at a time.

3) Test it with nslookup or dig:
dig www.nixcraft.com
nslookup www.nixcraft.com


This is what I know about my network :

I.P. address of the proxy server : 10.10.11.2
default gateway : 203.200.130.1
preferred dns server : 202.54.1.30

So, I believe my /etc/resolve.conf should look like this :
Code:
search isp.com  <should this be there or not ?>
nameserver 202.54.1.30
Is this right ?

I am not at my Linux box right now, so I cannot test it right now.
Thanks in anticipation.

Last edited by koodoo; 09-08-2005 at 03:31 PM.
 
Old 08-28-2005, 04:15 AM   #5
nixcraft
Member
 
Registered: Nov 2004
Location: BIOS
Distribution: RHEL3.0, FreeBSD 5.x, Debian 3.x, Soaris x86 v10
Posts: 379

Rep: Reputation: 30
Following shoud do the work:

Code:
nameserver 202.54.1.30
You need to add default gatway using command:

Code:
route add default gw 203.255.255.0 dev eth0

Btw proxy has no use to telnet as it will be used by ftp or http or https protocols only.
 
Old 08-28-2005, 01:39 PM   #6
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Sorry, I couldn't get it to work
My /etc/resolv.conf looks like :
Code:
root@knapsacker:/home/koodoo# cat /etc/resolv.conf
nameserver 202.54.1.30
root@knapsacker:/home/koodoo#
Then I tried to execute the command "route add default gw 203.200.130.1 dev eth0" and got the following error message :
Code:
root@knapsacker:/home/koodoo# route add default gw 203.200.130.1 dev eth0
SIOCADDRT: Network is unreachable
root@knapsacker:/home/koodoo#
Now this might be because my I.P. is 10.10.27.204 (private i.p.) while that of the default gateway is 203.200.130.1 (I mean they belong to different classes of I.P.'s)


I then tried those two commands and got the following error messages :
Code:
root@knapsacker:/home/koodoo# nslookup www.nixcraft.com
Note:  nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead.  Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
;; connection timed out; no servers could be reached

root@knapsacker:/home/koodoo# dig www.nixcraft.com

; <<>> DiG 9.2.3 <<>> www.nixcraft.com
;; global options:  printcmd
;; connection timed out; no servers could be reached
root@knapsacker:/home/koodoo#
Then I went to http://www.dnsstuff.com/tools/aboutyou.ch

That site told me that my D.N.S. servers were :
202.54.15.5
and
202.54.103.1

So then I added these two entries also into /etc/resolv.conf and tried the entire procedure again, but got identical results.

I would again like to mention the complete scenario here :
Code:
I am connected to a proxy server which has i.p. 10.10.11.2
We have been allotted private i.p.'s and mine is : 10.10.27.204
Other information is as follows : 
default gateway : 203.200.130.1
preferred dns server : 202.54.1.30
other dns servers : 202.54.15.5 and 202.54.103.1
What should I do ?
Help needed
Thanks in anticipation.

Last edited by koodoo; 09-08-2005 at 03:56 PM.
 
Old 08-29-2005, 08:08 AM   #7
nixcraft
Member
 
Registered: Nov 2004
Location: BIOS
Distribution: RHEL3.0, FreeBSD 5.x, Debian 3.x, Soaris x86 v10
Posts: 379

Rep: Reputation: 30
Get correct IP info from your ISP or net admin coz procedure is same and it should work out
 
Old 08-31-2005, 02:02 PM   #8
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Hi, I'm afraid I can't do that.
My University has got a dedicated lease line from the ISP, and then they have done campus wide networking.

We've been allotted these i.p.'s by the net administrator and we cannot change these.

Isn't there any way to connect to a site via telnet in a scenario like mine?
I think that there ought to be some way (Or maybe I am doing something very stupid)

Somebody, please help me out

Thanks in anticipation.
 
Old 09-08-2005, 04:10 PM   #9
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Hi,

Finally got it to work. I changed my i.p. to the same class as that of the default gateway. (I chose 203.200.130.79 as the i.p.). Then added the default gateway 203.200.130.1 and it worked.

But the problem still remains
I just changed my i.p. to test whether telnet was working or not. I cannot permanently keep this i.p. Ultimately I will have to use something like 10.10.27.204 and then the same problem would occur again. Isn't there any workaround, so that I can keep 10.10.27.204 as my i.p. also, and still connect to the outside world via telnet ??

Thanks in anticipation.
 
Old 02-11-2008, 04:09 PM   #10
kingkoti
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Rep: Reputation: 0
Thumbs up check this it may help you

this link may help u <http://www.meadowy.org/~gotoh/projects/connect>
 
Old 02-11-2008, 07:59 PM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,950
Blog Entries: 11

Rep: Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860
Ummm .... not that we have a hard and fast rule for this, but re-animating
a thread that was dead for over 2 years is at least considered weird. Plus
the guy had his problem resolved already?


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Host lookup failure with Sendmail MattiasLofgren Slackware 4 05-14-2009 03:00 PM
Temporary Failure in Name Resolution ewto Linux - General 2 07-15-2005 01:28 PM
Host name lookup failure mauroblanc Linux - Networking 2 06-16-2005 02:09 PM
DHCP: Host name lookup failure kaloyer *BSD 2 07-08-2004 11:01 AM
getting an error 0.0.0.0:Host name lookup failure udayan Programming 2 08-22-2002 11:23 PM


All times are GMT -5. The time now is 05:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration