LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-21-2012, 03:25 PM   #1
antares4141
LQ Newbie
 
Registered: Sep 2008
Location: truth or consequences, nm
Distribution: suse
Posts: 18

Rep: Reputation: 11
suse 12.1 rescue login "login incorrect"


I'm having trouble with grub boot loader, when I change it in yast it appears to switch to windows boot loader and locks me out of suse. If that isn't bad enough when I use the cd to rescue grub it ask's me for a user name and password. I enter them the exact same way I would if I were logging in normally to suse and get the error "login incorrect"

I've tried configuring the boot loader in yast two different ways, moving "windows" up to the top line in the order I want the boot menu to appear and leaving that alone and just selecting "windows" as default.

Both ways it appears to boot from the windows boot loader (no grub menu) which would be great if I had an easy way to switch it back (run suse and switch it back) when I needed.

Robert Christ
 
Old 11-23-2012, 08:34 AM   #2
phenyloxime
LQ Newbie
 
Registered: Sep 2009
Posts: 28

Rep: Reputation: 2
Just trying to get a picture of your process:

You are dual booting windows (7? XP?)
You are using your original suse 12.1 cd to rescue grub .. .
You boot from the disk, it gives you a list of options; Install new system, Rescue existing system etc...
You choose "Rescue", it prompts you for a username and password -- you provide those associated with your:

user account? or root ?

And can't log in.

A couple of things stand out:

It may be that the username and password your cd expects are some kind of default password ie; "admin" + "password"
or "blank" + "blank" or something other than your actual credentials.

The windows boot loader (at least last I was dual booting) will not boot (or even detect) a linux system.
You must have Grub (or lilo) installed as the boot loader (something to do with the MBR?)

If you want to change the order that OS's are listed in GRUB the easiest way to do this is by editing a file called menu.lst
I'd recommend reading up on menu.lst entries and setting up grub.

I'm unfamilliar with yast, I know it is the suse equivalent to synaptic on debian, perhaps a suse user can guide you there.
Quote:
moving "windows" up to the top line in the order I want the boot menu to appear and leaving that alone and just selecting "windows" as default
By doing this you may be disabling grub, and setting the windows boot loader in its place.

good luck

Last edited by phenyloxime; 11-23-2012 at 08:38 AM.
 
Old 11-24-2012, 12:58 AM   #3
antares4141
LQ Newbie
 
Registered: Sep 2008
Location: truth or consequences, nm
Distribution: suse
Posts: 18

Original Poster
Rep: Reputation: 11
Smile

Quote:
Originally Posted by phenyloxime View Post
You are using your original suse 12.1 cd to rescue grub
Yes

Quote:
Originally Posted by phenyloxime View Post
it prompts you for a username and password -- you provide those associated with your : user account? or root?
This is what is weird, when I log in after I re installed, (it defaults to log in automatically but I turned this option on "log in" so I could see) I used my "user account name" (which it put in the blank automatically) but my "root" password (which is the only password I have). So that is the first thing I tried when I ran the rescue utility (a second time) and couldn't get access to the utility. So I still haven't solved this riddle. Didn't try admin but tried just about every other combination I could think of.

Quote:
Originally Posted by phenyloxime View Post
The windows boot loader (at least last I was dual booting) will not boot (oreven detect) a linux system. You must have grub (or lilo) installed as the boot loader (something to do with the MBR?)
When I changed the order so windows was on the top of the grub menu list it defaulted to windows and didn't even give me the option to even load suse. (grub menu simply didn't appear) After I re-installed suse I backed up the boot directory and imaged the partition (/sda6) with suse on it, than I went into yast ran boot loader and switched the default from suse to windows and still got my grub menu on boot so everything is good now. I thought I tried that also and it locked me out but apparently not.
Quote:
Originally Posted by phenyloxime View Post
If you want to change the order that OS's are listed in GRUB the easiest way to do this is by editing a file called menu.lst
I'd recommend reading up on menu.lst entries and setting up grub.
I've done that in the past but it was time consuming and I forgot everything I learned. I should probably give up windows and switch to linux full time than I wouldn't forget everything I learn because I'd be using it often enough.

Quote:
Originally Posted by phenyloxime View Post
By doing this you may be disabling grub, and setting the windows boot loader in its place.
I think that's what happend, I didn't even have a grub menu to choose from.
Anyways I think I solved the boot loader problem, "don't change the order" the options appear in the menu or list, just change which one you have selected as "default" and that one will be the one that boots automatically.

Thanks for the reply
Robert Christ
 
Old 11-24-2012, 01:30 AM   #4
Adol
Member
 
Registered: Feb 2011
Location: Osaka, Japan
Distribution: Gentoo, Opensuse
Posts: 248

Rep: Reputation: 4
on the live cd to get to root the username is "root" and there is no password. It wont be your username and password because its not actually booting up your system.

you may also want to try sudo if su isn’t working.

And yes, if you don’t have the grub menu its disabled.
 
1 members found this post helpful.
Old 11-24-2012, 06:40 PM   #5
antares4141
LQ Newbie
 
Registered: Sep 2008
Location: truth or consequences, nm
Distribution: suse
Posts: 18

Original Poster
Rep: Reputation: 11
Quote:
Originally Posted by Adol View Post
on the live cd to get to root the username is "root" and there is no password. It wont be your username and password because its not actually booting up your system.

you may also want to try sudo if su isnít working.

And yes, if you donít have the grub menu its disabled.
I think it had a prompt called "rescue login" And a prompt called "password". I assumed for some rudimentary Interface like safemode in windows. (Where I was hoping to find a utility to restore grub) Just for the heck of it I tried your suggestion for typing "root" And when I did this it didn't even ask for a password it just went straight to a terminal with full privileges.

Robert Christ
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "Login incorrect" error after boot - no password prompted rramesh1 Linux - Newbie 5 05-22-2011 12:39 PM
"cant login, login incorrect"init : Id "x" respawning too fast:disabled for 5 minutes allenwoxx Linux - Newbie 1 11-21-2008 10:45 AM
Get "530 Login incorrect." trying to FTP to Slackware 9.1 box. RichDawg Linux - Networking 1 07-22-2004 07:45 PM
Getting "530 Login incorrect" trying to ftp to slackware 9.1 box. RichDawg Linux - Newbie 0 07-22-2004 02:05 PM


All times are GMT -5. The time now is 11:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration