LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-29-2004, 07:09 PM   #1
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Rep: Reputation: 0
Unhappy Stuck in 800 x 600 resolution SuSe 9.1


Ok, I am a total noob to Linux. After playing with the Knoppix Live distro for a few weeks I tried to install Debian with no luck. Now I have settled on SuSe 9.1. I have installed it alongside Windows XP, and made it through all the nonsense of getting them both to boot from grub. Now in Linux I am stuck with 800 x 600 @60Hz monitor resolution, very annoying. I have a Nvidia FX5200 card, but I have no other options to change resolution, etc in the control center. the driver version i have is 1.0-5336 i think. I have been trying to install Nvidia'a newest driver (1.0-6111) but it keeps telling me it needs to compile a Nvidia kernel. I have read the readme from Nvidia, but it isn't helping me much. It wants me to run the script like this (from shell, run level 3): sh NVIDIA-Linux-x86-1.0-6111 -q --kernel -source -path= /usr/src/linux . I have no idea what to put after the -q part. My linux kernel is 2.6.5-7.104. I've tried typing that and many other combinations of stuff in there, but I really have no clue what I am doing. Nvidia no longer releases their drivers as rpms, so I am kind screwed till i can get a Linux book. The Nvidia driver That is already installed is not that old, so I don't think it's causing the problem with resolution. I keep reading that I need to configure xfree86 or sax2, but i have no idea how. I've tried sax2 from within kde and in the shell, and all it does is show a grayscale crosshatch pattern,(that isn't centered correctly) with an X for my cursor, some text pops up too fast to read, and then goes right back to my desktop. Also every time I start SuSe, i get a hardware message saying that my monitor didn't report x-y settings and asks if i want to configure them manually. When I click yes, it does the same thing that sax2 does (effectively nothing). I just want to get my 1024 x 768 @ 85 back, it worked in Knoppix. That and I need to know how to get this blasted new Nvidia driver installed. I also need to learn how to configure sax2 or xfree86, not sure if they're the same thing or not. If anyone out there has some moron-level instructions or tips, I would greatly appreciate it. Thanks.
 
Old 08-29-2004, 07:49 PM   #2
rm6990
Member
 
Registered: Aug 2004
Location: Canada
Distribution: SUSE 9.1 Pro and Debian Testing on Server
Posts: 469

Rep: Reputation: 30
Little tip Sax2 is a piece of $h!t program. Log in as root, open the file /etc/X11/xorg.conf (It may also be XF86Config something or other, this changes with the distro). Scroll to the very bottom and it should have a bunch of color depths and what resolutions to use. Make it so that "1024x768" is the only option for all the available color depths. Now, log out, Ctrl+Alt+Backspace to restart X, and it should be fixed. Also, download the latest Nvidia driver through Yast Online Update and just enable it in Sax2 (the program has this one use) under video card, and it should work fine, even if it isn't the newest driver.
 
Old 08-29-2004, 08:33 PM   #3
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
Angry xfree86, still stuck 800 x 600

Ok, I have managed to get into xf86cfg. I have all the monitor specs i need, and I have configured xf86 with the right stuff. It says it is writing the new data to the config file, then i get a weird garbled grayscale screen, and i have to reboot. it does not remember the settings i put in (hsync, vsync, etc) it always seems to default to this crappy 800 x 600. sax2 does suck as far as i can tell, because it simply doesn't seem to do anything at all. Still doing all this from shell in runlevel 3 like nvidia's readme says to. Still haven't figured out how to install the newer driver. ARRRRGH! This is super annoying to me. I try to stay away from yast, because every time i've tried to use it to update things (I'm on my 3rd reinstallation in 2 days) it always ends up not working at all (yast that is). I have the fetch nvidia thing, but it never seems to work, so i downloaded the driver from nvidia's site. The drive that IS installed isn't all that old (not really planning to play games or anything) but i just want to be able to get my resolution and refresh rates back to where i don't get a headache after 10 minutes of staring at kde. Why won't xf86 remember the settings i put in?
 
Old 08-29-2004, 08:56 PM   #4
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by rm6990
Little tip Sax2 is a piece of $h!t program. Log in as root, open the file /etc/X11/xorg.conf (It may also be XF86Config something or other, this changes with the distro). Scroll to the very bottom and it should have a bunch of color depths and what resolutions to use. Make it so that "1024x768" is the only option for all the available color depths. Now, log out, Ctrl+Alt+Backspace to restart X, and it should be fixed. Also, download the latest Nvidia driver through Yast Online Update and just enable it in Sax2 (the program has this one use) under video card, and it should work fine, even if it isn't the newest driver.
Tried this, but bash says /etc/X11/xorg.conf is invalid. Looked around and found X11R6, but can't seem to find a way to configure it, whatever it is. I don't know if the newer nvidia driver would help or not, but as i don't know where my kernel path is I guess it doesn't really matter. Will tinker with it more tomorrow. Thanks
 
Old 08-29-2004, 10:17 PM   #5
rm6990
Member
 
Registered: Aug 2004
Location: Canada
Distribution: SUSE 9.1 Pro and Debian Testing on Server
Posts: 469

Rep: Reputation: 30
Try using emacs (emacs should come with SuSE)

OK, this is whut u type

emacs /etc/X11/XF<TAB> (It will finish it if SuSE uses XF86Config for it's config file), then press enter and you are in emacs. Change the file and then enter F10 and then f and then s to save. Then enter F10 and f then e to exit.
 
Old 08-30-2004, 12:44 AM   #6
kt_leohart
Member
 
Registered: Aug 2004
Location: Earth
Distribution: Switched back to good old SuSE 9.1 :D
Posts: 30

Rep: Reputation: 15
It's true that SUSE 9.1 does not include nVidia packages anymore but you can always fetch them off the internet directly from YAST.

Go to Start -> System -> Yast

Now after login as root, choose Online Update. Next choose the mirror server you want.

Finally, after a long time waiting, make sure you choose : nVidia Driver package (something like that)

Then, go on and install the packages, then, simply restart the computer.

NOW, SUSE 9.1 should enable 3d-acceleration ( if not you can always change it by go to YAST (as above), then choose Hardware -> Display and Graphic Card. Then choose the Resolution you want. Finish and that's it. It should work easy since nVidia has good drivers update system.

Have fun. Wish that you can get rid of that 800x600.
 
Old 08-30-2004, 04:10 PM   #7
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
Angry Still getting nowhere

Tried the emacs thing in bash, bash says no such directory. Tried just typing /etc/X11/XF86Config , and it told me I was denied access, even though I was in root. I did manage to run the graphical xf86cfg a few times, and I entered the information I got on my monitor, etc. It gives me 2 popups when I quit sayng it wants to write to X11's config files, so I just click ok on them, but it never remember the settings the next time I go to check. I have also tried repeatedly to use yast to update the driver, but I think all it's doing is trying to update the fetchnvidia utility. I don't understand why xf86cfg won't keep my settings, unless the default locations it tries to save to aren't valid, but i don't know where else to save them to. Can anyone recommend a good up-to-date book on linux? I need something that's not to beginner level, but not written for admins either, a nice in-depth mid-level book perhaps. I've found a bunch online, but most of them seem to date from 2000-2001. Thanks all for trying to help.
 
Old 08-30-2004, 04:27 PM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
It gives me 2 popups when I quit sayng it wants to write to X11's config files, so I just click ok on them, but it never remember the settings the next time I go to check.
Could that be because the location it's saving
to is NOT in /etc/X11 but somewhere in /usr/X11R6? :)



Cheers,
Tink
 
Old 08-30-2004, 04:29 PM   #9
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Tinkster
Could that be because the location it's saving
to is NOT in /etc/X11 but somewhere in /usr/X11R6?



Cheers,
Tink
Yes I believe that is where it tries to write to. Is this an incorrect location?
 
Old 08-30-2004, 04:46 PM   #10
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
xf86cfg

OK more specifically, here is what happens. I go into xf86cfg, enter my various settings, hit quit and I get these two popups:
"XF86Config
Write configuration to
/usr/X11R6/lib/X11/XF86Config"

and

"XKB
Write configuration to
usr/X11R6/lib/X11/xkb/X0-config.keyboard"

I just usually click yes to both of them as I don't know where else I could write them to. Is there somewhere else they should be saved to? Guess I need to pick up "Linux For Dummies"
 
Old 08-30-2004, 05:41 PM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
The first one DEFINITELY needs to go to /etc/X11
 
Old 08-30-2004, 06:38 PM   #12
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
xf86 blah blah justworkalready

Quote:
Originally posted by Tinkster
The first one DEFINITELY needs to go to /etc/X11
so i should change the location it saves to? keep in mind that i am essentially linux-ignorant. lol
i've managed to teach myself a few things so far, but i am still pretty much helpless... i am gradually getting more familiar with linux's file system/structure/bash commands, but i have much to learn. i assume you mean i should save the settings into /etc/X11, but is that all i should type into the dialog box? should i put in "/etc/X11/XF86Config"? also when i start xf86cfg from the shell there's a screen full of text that whizzes by too fast to read. is there any way to pause this so i can read it? same goes for when i start an x session, lots of info flies by, but i can't read what it says because it's gone too fast. i remember finding a command to pause this stuff, but i forgot what it was...
 
Old 08-30-2004, 06:46 PM   #13
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Yes, you should.

And the "whizzing by" things live in
/var/log/XFree86.0.log
 
Old 08-30-2004, 07:08 PM   #14
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
Sucess!!!

Tinkster, you are awesome. I now have a whole plethora of screen resolutions to pick from. Although my mouse wheel has stopped working, no biggy. I'm sure I can remedy that. On e minor niggle is that the SuSe hardware tool still pops up saying that my monitor doesn't report it's x-y settings, but hey, progress has been made.
 
Old 09-02-2004, 09:07 PM   #15
dchoward1977
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSe 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
AGGGGHH! lost mouse, can't start x anymore

Well, I posted this in the hardware forum, but no responses yet... After Tinkster helped me get my resolution where I wanted it to be, I lost my mouse wheel function. So being the noob that I am, I started playing around in XF86cfg again trying to get it back. Big mistake. Now I have no mouse at all, and I can't start the X server anymore. It says it can't find the Nvidia driver. I've tried every config I could think of, but nothing is working. For the record, my system is HP Pavilion, 2.7 GHz Celeron, 256MB PC2700DDR, 40 gig HD (20G windows/20G Linux) Logitech Optical wheel mouse. I just got a SoundBlaster Audigy LS (which is apparently now supported in ALSA 1.0.6, but that's another story) YaST DID update the "Linux kernel on x86 architecture" and I think that's when everything went haywire. Unless anyone knows how to fix all this (Tink? ) I think I am just going to have to re-install Linux (SuSe 9.1) for the 5th time. Oh well, live and learn I guess.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE: Unable to change to higher resolution then 800 x 600? Help me.. slamsonic Linux - General 1 07-27-2005 09:20 AM
How do I increase my screen resolution in FC3, I cant get it larger than 800 by 600? Nike Static Linux - Newbie 3 06-10-2005 01:18 PM
resolution problem,. i am stuck in 800x 600 peterthurgood Fedora - Installation 8 04-26-2005 06:40 AM
Resolution, stuck at 800 x 600!? Lintux Debian 6 03-30-2005 09:27 AM
Changing redhat screen resolution from 600-800 tej Linux - Newbie 2 09-18-2004 08:02 AM


All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration