LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2004, 04:09 AM   #1
Skaarjj
LQ Newbie
 
Registered: Mar 2004
Location: Melbourne, Victoria, Australia
Distribution: RedHat 9
Posts: 4

Rep: Reputation: 0
Question Strange resolution problem in RedHat 9 with a GeForce 4 Ti4400


Hey. I'm very new around here, and very new to linux as well. It's all going very well for me so far except for this one problem I'm having (besides the fonts, but that's cosmetic).

Under any of the GUIs I currently have available (X-Windows, GNOME or KDE) when I try to change the resolution to something other than 640x480 or 800x600 I come up against a problem. I can select the other resolutions in the list. They're all there (and god, do I ever want to go higher than 800 x 600. I'm used to 1600x1200 ) and Ican select them. I hit OK and I'm told that it has been changed and I need to restart X-Windows for it ot take effect. I do so, and I'm right back at 800 x 600 (did I mention that, becuase of the non-standard aspect ratio of my monitor 800 x 600 doesn't display properly?).

I read on these forums the trick of editing XF86Config and adding the extra values so that it would try the higher values automatically on bootup, and so tried that as well. When I go to the display properties area then, it tells me that I'm running at 1600 x 1200, but nothing has changed. I'm still at 800 x 600, even though I'm being told that I'm not. If I hit 'ok' on that dialog instead of 'cancel', then I'm yet again told that changes have been made and need to restart. If I do so, then my display once again tells me that I'm at 800 x 600.

This is most frustrating. I've downloaded the drivers that nVidia tells me sould work for my card under linux, but no dice.

Does Linux have any known conflicts with my card's chipset? Or does anyone else know what's going on? Please remember, I'm posting in here becuase I'm really, really a

Thanks All

Skaarjj
 
Old 03-01-2004, 04:20 AM   #2
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
I would not blame the NVIDIA card, I think it is a monitor problem.

I assume you have used this monitor on a windows box and it works great ey.

check that you have selecte the right monitor by going to

"system settings" --> "display"

then click on the "Advanced" tab

configure your monitor from there by selecting the right brand

-JAX
 
Old 03-01-2004, 04:22 AM   #3
Skaarjj
LQ Newbie
 
Registered: Mar 2004
Location: Melbourne, Victoria, Australia
Distribution: RedHat 9
Posts: 4

Original Poster
Rep: Reputation: 0
I'm sorry, I should have said. I tried that, and my monitor's brand isn't in that list. I've got a ViewMaster monitor, and the closest one there is a ViewSonic. Is it possible to get extra monitor definitions?
 
Old 03-01-2004, 04:26 AM   #4
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
Can you post your XF86Config file get it by typing

vi /etc/X11/XF86Config

use this only if you know how to use VI otherwise

gedit /etc/X11/XF86Config
or
kedit /etc/X11/XF86Config
 
Old 03-01-2004, 07:44 AM   #5
Skaarjj
LQ Newbie
 
Registered: Mar 2004
Location: Melbourne, Victoria, Australia
Distribution: RedHat 9
Posts: 4

Original Poster
Rep: Reputation: 0
OK...here it is:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 Ti4400"
VideoRam 131072
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Hope this helps reveal the problem
 
Old 03-01-2004, 07:57 AM   #6
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
Nothing obvious there

try commenting out The moded section by placing a # in front of it

#Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

and placing the following below it

Modes "1024x768" "800x600" "640x480"

Maybe it is defaulting to the 800x600 if it cant do 1280x1024

shouldn't though.

Something else you could check is you vertical and horizontal refresh rates and make sure they are correct for you monitor.

when you have done this save the file and exit X by going to the redhat --> "run program"

then type

init 3


that will exit the XServer

to get back in type startx

see what happens then

-JAX

Last edited by jax8; 03-01-2004 at 07:58 AM.
 
Old 03-01-2004, 02:53 PM   #7
Skaarjj
LQ Newbie
 
Registered: Mar 2004
Location: Melbourne, Victoria, Australia
Distribution: RedHat 9
Posts: 4

Original Poster
Rep: Reputation: 0
Isi t OK if I just stand here and feel stupid now?

God I can be an idiot sometimes. I had the correct values for my monitor entered in the HSync and VRefresh areas, but I'd put them in the wrong way round (HSync was under VRefresh). Now I have Display Joy. A state of finally having a resolution that you are used to available to you.

Tell me though, oh helpful ones, is it possible to get copies of the Arial and Verdana fonts for Linux? A number of other boards that I visit use these fonts, and they both look very strange in Helvetica.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
strange X resolution problem chunlee Linux - Newbie 2 12-31-2004 06:48 PM
Strange DNS Resolution Problem pmconway Fedora 1 11-10-2004 08:37 AM
Mandrake 10.0 and GeForce 4 TI4400? Diesel2k Linux - Hardware 3 07-22-2004 01:56 PM
Mandrake, Geforce 4 MX440, S-video Out TV Resolution problem zedraloth Linux - General 1 08-18-2003 09:30 PM
Strange problem with Xfree 4.3 and Geforce FX 5900 jhahn Linux - Hardware 0 07-24-2003 09:08 PM


All times are GMT -5. The time now is 09:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration