LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-13-2007, 12:57 AM   #1
Guilherme
Member
 
Registered: Jul 2006
Posts: 83

Rep: Reputation: 15
strange ALSA problem


hello
well I have a problem I can't find solution over google and LinuxQeustions.
I have mic on and if I incrise the volume, althouhg I can't record anything or even use Skype ...
How can I fix it?

Thanks you
 
Old 06-13-2007, 02:00 AM   #2
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
It would probably be of great help if you were to mention what kind of sound card/device you have?. And what Linux distribution you are using?. What desktop environment you use?.
Anyway, a good place to start is to look at the sound mixer applications like kmix, alsamixer, etc. to see if the microphone is muted. You can also try command:
Code:
$amixer set Microphone 100% unmute
 
Old 06-13-2007, 07:27 AM   #3
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
also check if it set as input source (in alsamixer: use tab to switch to record mode, go to mic and press space key)
 
Old 06-13-2007, 01:54 PM   #4
Guilherme
Member
 
Registered: Jul 2006
Posts: 83

Original Poster
Rep: Reputation: 15
oh sorry...
I could say it I forgot... I'm realy sorry
I have a Creatinve Sound Blaster Live!, Mandriva 2006 and KDE...
I start looking to Kmix and alsamixer as well and there is microphone active and I can hear me... anyway I realy can't record anything just because the /dev/dsp ... :X
 
Old 06-13-2007, 02:15 PM   #5
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
...is in use? in this case, start up kcontrol, go to the sound settings and disable the arts daemon, this will free your device. maybe it helps setting arts to use alsa instead of oss, but I turned it of completely and used a custom command for playback of the system sounds (look out for the "extended settings"): "aplay"
 
Old 06-13-2007, 02:37 PM   #6
Guilherme
Member
 
Registered: Jul 2006
Posts: 83

Original Poster
Rep: Reputation: 15
ok this is realy fine
anyway, now I am using OSS right?
 
Old 06-15-2007, 10:36 AM   #7
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
no, you are using alse with aplay, but alsa provides an oss emulation, some applications may use the oss interface and though this may block other applications, try starting then with aoss <commandname> if that happens...

hope this helped...
 
Old 06-16-2007, 12:31 AM   #8
Guilherme
Member
 
Registered: Jul 2006
Posts: 83

Original Poster
Rep: Reputation: 15
[guilherme@localhost suh]$ aoss
bash: aoss: command not found
 
Old 06-16-2007, 02:45 AM   #9
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
Hi,

What kind of Sound Blaster Live! are you using? Is it the 7.1 24bit version? If you take a look at ALSA's device compatibility list here, you'll see that the Live! cards that rely on the "ca0106" module instead of the "emu10k1" do not support sound capture yet.

Check which module you are using with the 'lsmod' command. If you find "snd-ca0106", you may not be able to record sound or use a mic for Skype for the time being. You can pull out the sound card, and switch to the computer's onboard sound device if you have one.

Hopefully the above is just old news and they've fixed it by now.

Sam
 
Old 06-17-2007, 02:38 PM   #10
Guilherme
Member
 
Registered: Jul 2006
Posts: 83

Original Poster
Rep: Reputation: 15
well I don't know the card model.. but I'll try to find it...
ANyway, I can perfectly use Skype although I need to activate and deactivate the sound before
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
strange alsa problem TimmyP Linux - General 0 11-17-2004 02:37 AM
strange, strange alsa problem: sound is grainy/pixellated? fenderman11111 Linux - Software 1 11-01-2004 06:16 PM
very strange...alsa volume control buldir Fedora 1 07-28-2004 05:20 AM
Strange sound problem in FC2T3 (ALSA) Thetargos Fedora 0 05-09-2004 06:35 PM
alsa : a strange problem loading modules TrueLenny Linux - General 4 03-29-2001 12:19 PM


All times are GMT -5. The time now is 01:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration