LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-25-2005, 08:01 PM   #1
Intacto
LQ Newbie
 
Registered: Feb 2005
Distribution: SuSE 9.2 Professional, Fedora Core 4, Darwin/GnuSTEP, FreeBSD, Ubuntu, Debian Sid, OS/360
Posts: 9

Rep: Reputation: 0
Starting X remotely


Ok I have a very simple question:

I was running FC4 over VNC and my user session had to be logged out. Now I set it to power back up automatically, but since it is stuck at the login screen, the only thing I can really do is to use SSH to perform CLI logins. I was wondering if there is a way to start the x server to get back to my gnome desktop over a PuTTY SSH connection from Windows XP?

Thanks!
 
Old 11-26-2005, 04:46 AM   #2
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 50
There is X forwarding in SSH; but that requires an X server, and it doesn't let you use a "desktop" kind of thing. So it's not what you're looking for. Shoudn't there be a way to configure the VNC server so that you don't need to be logged in and it can start a new session?
 
Old 11-26-2005, 11:22 AM   #3
dubya
Member
 
Registered: Mar 2004
Location: Kitchener, Ontario, Canada
Posts: 386

Rep: Reputation: 30
I just recently did something like this. I'm pretty new at it so I'm not well educated on how it all works, but under preferences in the desktop menu, there's a setting called remote desktop. You may need to change some of these settings.

For me, I had to connect remotely using port 5801 and then when the pop-up appeared with the ip, port, and display number, I entered '0'. This also means that I had to open port 5801 in addition on my system and in my router.

This is all accessed with a desktop already running. Just something you might want to try.
 
Old 11-28-2005, 10:00 PM   #4
ziggie216
Member
 
Registered: Oct 2003
Posts: 176

Rep: Reputation: 30
so do I enter in this? ip:5801:0
 
Old 11-28-2005, 10:36 PM   #5
dubya
Member
 
Registered: Mar 2004
Location: Kitchener, Ontario, Canada
Posts: 386

Rep: Reputation: 30
This is what I use:

http://ip:5801/

If VNC is set up correctly and are using RealVNC, you'll get a pop-up with http://ip:5801:0 in it. Change the last zero to a one and you're off.

Don't forget to start a VNC server on display 1 with the following command:
Code:
$ vncserver :1
Good luck. Post back if you have more problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
starting X application remotely spidy_123 Linux - Networking 2 10-19-2005 05:45 AM
Starting program remotely and have them continue to run after the session is ended OJAtkinson Linux - General 2 12-07-2004 12:06 PM
Won't Boot - Starting Printer Service - Starting CUPS jeansond Linux - Newbie 0 10-11-2004 06:39 PM
X remotely linuxnube Linux - General 3 01-26-2004 03:17 AM
starting an xserver remotely by script ?? jdaniel Linux - General 3 09-22-2003 01:06 AM


All times are GMT -5. The time now is 01:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration