LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-16-2004, 11:53 AM   #1
axelmang
Member
 
Registered: Mar 2004
Location: Athens
Distribution: Fedora 9
Posts: 72

Rep: Reputation: 15
slow mouse on X


Hi all!

I have a small problem in X. I am using redhat 9 and whenever I log on to X my mouse is extremely very slow. I run redhat-config-mouse and just click ok and then the mouse becomes as it should be. but if I log out of X and log on again then it becomes slow again.
here is a part of my XFree86 file

Code:
Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/psaux"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
	Identifier  "DevInputMice"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection
One of my questions is why there are two sections for the mouse? should I comment one of them?

There are similar threads regarding the topic but I did not find the solution I was looking for plus the threads where a bit old and left over. So I decided to make a new thread

thanx in advance for any help
axelmang
 
Old 09-16-2004, 01:57 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
What do you have, a USB mouse, a PS/2 Wheelmouse,
both? :)

The section with /dev/psaux corresponds to PS/2
the section with /dev/input/mice to USB. Comment
out the section of the device you don't have.


Cheers,
Tink
 
Old 09-16-2004, 03:17 PM   #3
axelmang
Member
 
Registered: Mar 2004
Location: Athens
Distribution: Fedora 9
Posts: 72

Original Poster
Rep: Reputation: 15
I only have a ps/2 wheel mouse. So I commented out the useless stuff and the XFfree86 became as follows:

Code:
Section "ServerLayout"

#	InputDevice    "DevInputMice" "AlwaysCore"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
and
Code:
Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/psaux"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection
the part concerning the entry for the usb mouse has disapeared (I believe its ok since I comented it and rebooted)
but the problem was not solved. again when I logged in the mouse was slow and when I run the redhat-config-mouse tool it came to it's sence. Any more suggestions because it's really furstrating...

Thanx for your immediate replay Tinkster
axelmang
 
Old 10-30-2004, 06:18 AM   #4
ShaanAli
Member
 
Registered: Jun 2003
Location: Bangalore, India
Distribution: RedHat 9, Sun solaris 10, Windows 2000
Posts: 46

Rep: Reputation: 15
axelmang, I also have very similar problem in my office PC with PS/2 mouse. At home i have USB, there its works fine.

Did u find solution of this? Let me know...

Thanks.

Shaan
 
Old 10-30-2004, 08:42 AM   #5
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
You might try this;
Right under this line:

Option "Emulate3Buttons" "no"

add this:

Option "Resolution" "3000"

That used to be the way to improve the speed of a mouse. It just sets the mouse resolution higher than the screen resolution. It should just default back to match whatever screen resolution you are using. You might also try using the larger of your two screen resolution numbers in place of "3000" (ie: 1024x768 resolution = "1024"). Worth a try.
 
Old 10-31-2004, 02:00 AM   #6
axelmang
Member
 
Registered: Mar 2004
Location: Athens
Distribution: Fedora 9
Posts: 72

Original Poster
Rep: Reputation: 15
thanx for the reply but I 've switched to fedora and I am not facing this problem now

thanx again
 
Old 11-01-2004, 12:29 AM   #7
ShaanAli
Member
 
Registered: Jun 2003
Location: Bangalore, India
Distribution: RedHat 9, Sun solaris 10, Windows 2000
Posts: 46

Rep: Reputation: 15
Thanks lotus,
I did what exactly u said. Its working now. I will play with resolution number to get better result. thanks any way.

regards,
Shaan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Mouse Problem. rvijay Linux - Hardware 1 11-05-2005 12:55 PM
How can I slow the mouse down? darkblade Linux - Newbie 3 09-16-2004 01:50 PM
mouse slow on startup..? marlor Slackware 4 07-10-2004 06:21 PM
Mouse too slow in Gnome oof Debian 2 12-22-2003 11:06 AM
My mouse is too slow mrsolo Linux - Software 2 03-01-2003 06:05 PM


All times are GMT -5. The time now is 08:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration