LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2004, 02:48 PM   #1
zazery
LQ Newbie
 
Registered: Apr 2004
Location: Canada
Distribution: Slackware 9.1
Posts: 2

Rep: Reputation: 0
Slackware, terminal won't open + other q's


Ok I was a windows user up until yesterday when I decided to give linux another try. Finally I got it installed and am using Slackware 9.1 right now.

1. My biggest problem I am finding is it wont let me open up the terminal. I boot into linux, login and then type startx to load Gnome. The button beside the home at the top (Terminal Command line) when I click on it, my cursor turns into a watch and then it appears in the panel at the bottom saying "Starting Terminal" however after that it does absolutely nothing. I simply can't get into the terminal.

2. I didn't know what LILO was so I forgot to install it and it would really be helpful if I did, how can I install it now?

3. I have many partitions on my 2 HD on my /hda I have around 7 partitions and I would like to access the files on all of them. On /hdb I have my linux partitions and also another partition. For some reason I can only see the primary partition of /hda which contains Windows on it. So my question is how do I see all those partitions.

4. Another problem I'm having is installing gaim. I noticed that my version of gaim (0.65) is really old and I need to install the newer version. I am having problems installing it and figuring out what file I need to install. Could someone please walk me through it or link me to a tutorial that I could use to set it up. I have never installed something before on linux.

Any help will be greatly appreciated,
Eric
 
Old 04-09-2004, 06:17 PM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
1) Try googling for 'devpts' or possibly a Gnome 'authority' type issue. I really don't know, but I know the issue *can* be related to those. It may also be related to an improper fstab. See below. I don't use Gnome, so I'm kinda vague there and my terms always load - it's the keys and whatnot that are the issue.

2) Make sure your cd is mounted and 'installpkg path/to/lilo'. Read the lilo and lilo.conf man pages. Edit lilo.conf, run 'lilo'. stdMsg=Be careful.

3) Edit /etc/fstab - do 'man fstab' - to include those partitions if you always want them mounted automatically. Else 'mount -t fstype /dev/whereitis /mnt/mountpoint'. -t may or may not be necessary and you may need more. I like putting stuff in /etc/fstab with 'noauto' even if I don't want them mounted at boot just because it makes the 'mount' command as simple as possible. However, if they are NTFS partitions, you probably don't want to be trying to write to them. Reading from them is fine, though. stdMsg
3b)I have
devpts /dev/pts devpts gid=5,mode=620 0 0
in my /etc/fstab. If you don't have that, it may explain Gnome's issues.

4) If you want to compile, there's a LinuxAnswer around here somewhere to help with that. Simplest terms: download the tarball (check Freshmeat) and untar it (tar xzf packagename) and then issue './configure --help', look over your options (you may not need to change anything), and then './configure' (plus options, if any), followed by 'make', 'su', 'make install'. If you just want a package, you could try this or some other package. Then it should be just a matter of 'installpkg gaim.blah' though you may need an additional lib or two depending on how it was compiled.

Welcome to Slack. And I'm not saying RTFM when I point to man - just saying that I can only say general stuff and those pages will help with specifics.

Last edited by slakmagik; 04-09-2004 at 06:20 PM.
 
Old 04-09-2004, 11:52 PM   #3
MikeFoo1
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1
Posts: 72

Rep: Reputation: 15
Well, installed Slackware yesterday.Needed three attempts to do it but got there at the end(there was some problem installing LILO , got a heap of 99's on boot up).Configured video card and sound.

The only thing that i really miss is the net.So, i went for help here :

http://users.ox.ac.uk/~mert1313/ltmodem.html .

What i have done so far :

/home/foo/ltmodem-8.26a9/

cd /ltmodem-8.26a9/

ran ./build_module

got error saying no kernel headers .Installed the source to /usr/src/linux-2.x.y-zzz.

Tried

./build_module again

same error .Do i need to create an empty directory /usr/src/linux/ and run ln -s /usr/src/linux-2.x.y-zzz /usr/src/linux ?

It's kind of frustrating but i have come this far and would like to make my modem work .

it would be great if someone could give a step - by -step guide how to do it .

Help
 
Old 04-10-2004, 12:07 AM   #4
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Not the directory - just 'ln -s /usr/src/linux-foo /usr/src/linux'. You really need the kernel headers in /usr/include, I think. If at all possible, get a hardware modem. It's worth a few dollars (not many) if you've got them. Not to discourage you - because I'm an idiot - but I don't think I ever did get my ltmodem working - but a used hardware modem was a (relative) piece of cake. I gave it another try on this box with a pctel when the hardware modem died (don't buy used or, if you do, buy a few ) and I got that to 'work'... when it didn't randomly lock the system up. DSL is the best, but any real modem on dialup blows away a winmodem. But good luck.

But you should really start a new thread for this sort of thing - has no bearing on the original post.
 
Old 04-10-2004, 01:19 AM   #5
MikeFoo1
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1
Posts: 72

Rep: Reputation: 15
Thank you for your reply .
Could you elaborate on "/usr/include" how do i use it ?

Yes, it would be less painfull not to use a software modem at all.The thing is , it worked fine in Mandrake 9.0 and it should be ok in Slackware as well.

Thanks.
 
Old 04-10-2004, 01:48 AM   #6
MikeFoo1
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1
Posts: 72

Rep: Reputation: 15
Anyone ?Don't we have a kind person who could help me out ?
 
Old 04-10-2004, 02:15 AM   #7
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Well, it should have been installed so it wouldn't be an issue, but it's a possibility - a package called something like 'kernel-headers-foo' should be installed, which will put the kernel headers in the /usr/include directory. You don't really need to 'use' it - the data just needs to be available when you compile.
 
Old 04-10-2004, 01:01 PM   #8
zazery
LQ Newbie
 
Registered: Apr 2004
Location: Canada
Distribution: Slackware 9.1
Posts: 2

Original Poster
Rep: Reputation: 0
Just a quick reply, my friend who uses slack was helping me out as well and I decided to reformat and install KDE over Gnome. I've got everything working so far. I'm going to try accessing the other partitions like you guys said right now. I got gaim working finally, I found out I had the wrong pkg.

Thanks for all the help.
 
Old 04-10-2004, 05:09 PM   #9
MikeFoo1
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1
Posts: 72

Rep: Reputation: 15
Quote:
Originally posted by digiot
Well, it should have been installed so it wouldn't be an issue, but it's a possibility - a package called something like 'kernel-headers-foo' should be installed, which will put the kernel headers in the /usr/include directory. You don't really need to 'use' it - the data just needs to be available when you compile.
Hi.

Yes, i had a look at my /usr/include and there were some headers there.So, i am guessing that i just could create /usr/src/linux/ directory and ln -s /usr/include ?Like ln -s /usr/src/linux/ /usr/include/ .Is it correct ?


Thank you.
 
Old 04-10-2004, 06:16 PM   #10
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
No, not that - you need to link your 'full kernel source-version' to the plain 'full kernel source' because things just look for 'Linux' rather than 'Linux-changing-numbers'. But /usr/include isn't versioned, so it's fine. Rather the opposite - you don't want to be changing your kernel headers, generally. So no symlinks there.
 
Old 04-10-2004, 06:27 PM   #11
MikeFoo1
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1
Posts: 72

Rep: Reputation: 15
Quote:
Originally posted by digiot
No, not that - you need to link your 'full kernel source-version' to the plain 'full kernel source' because things just look for 'Linux' rather than 'Linux-changing-numbers'. But /usr/include isn't versioned, so it's fine. Rather the opposite - you don't want to be changing your kernel headers, generally. So no symlinks there.
Ok, i feel like a "clueless fuck".

What i have is the following:


Quote:
cd /usr/src;ls -l

total 12
drwxr-xr-x 2 root root 4096 Apr 10 20:07 l
drwxr-xr-x 14 573 573 4096 Nov 28 2002 linux-2.4.20/
drwxr-xr-x 7 root root 4096 Dec 12 2002 rpm/

cd /linux-2.4.20/;ls -l


total 248
-rw-r--r-- 1 573 573 18691 Aug 2 2002 COPYING
-rw-r--r-- 1 573 573 79594 Nov 28 2002 CREDITS
drwxr-xr-x 30 573 573 4096 Nov 28 2002 Documentation/
-rw-r--r-- 1 573 573 42744 Nov 28 2002 MAINTAINERS
-rw-rw-r-- 1 573 573 18780 Nov 28 2002 Makefile
-rw-r--r-- 1 573 573 14239 Aug 2 2002 README
-rw-r--r-- 1 573 573 2815 Apr 6 2001 REPORTING-BUGS
-rw-r--r-- 1 573 573 9291 Aug 2 2002 Rules.make
drwxr-xr-x 19 573 573 4096 Nov 28 2002 arch/
drwxr-xr-x 41 573 573 4096 Nov 28 2002 drivers/
drwxr-xr-x 46 573 573 4096 Nov 28 2002 fs/
drwxr-xr-x 26 573 573 4096 Nov 28 2002 include/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 init/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 ipc/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 kernel/
drwxr-xr-x 4 573 573 4096 Nov 28 2002 lib/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 mm/
drwxr-xr-x 28 573 573 4096 Nov 28 2002 net/
drwxr-xr-x 4 573 573 4096 Nov 28 2002 scripts/

cd include/

total 104
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-alpha/
drwxr-xr-x 21 573 573 4096 Nov 28 2002 asm-arm/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-cris/
drwxr-xr-x 2 573 573 4096 Sep 20 2001 asm-generic/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-i386/
drwxr-xr-x 3 573 573 4096 Nov 28 2002 asm-ia64/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-m68k/
drwxr-xr-x 18 573 573 4096 Nov 28 2002 asm-mips/
drwxr-xr-x 11 573 573 4096 Nov 28 2002 asm-mips64/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-parisc/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-ppc/
drwxrwxr-x 3 573 573 4096 Nov 28 2002 asm-ppc64/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-s390/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-s390x/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-sh/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-sparc/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 asm-sparc64/
drwxrwxr-x 2 573 573 4096 Nov 28 2002 asm-x86_64/
drwxr-xr-x 12 573 573 12288 Nov 28 2002 linux/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 math-emu/
drwxr-xr-x 4 573 573 4096 Nov 28 2002 net/
drwxr-xr-x 2 573 573 4096 Dec 21 2001 pcmcia/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 scsi/
drwxr-xr-x 2 573 573 4096 Nov 28 2002 video/
is it what i need ?If it is then how exatly do i create a link to avoid this :


Quote:
====================================================================
Diagnostic information is progressively being written to BLDrecord.txt .
Often, contents of BLDrecord.txt will aid in solving a problem.

Now acquiring distribution data:
The Linux distribution is: slackware, Slackware 9.0.0
TARGET_CPU=
End of distribution check.


A supported Lucent/Agere DSP chipset modem is identified: PCI_ID=11c1:044c
VENDOR 0x11c1 DEVICE 0x044c
ID are within the serviced ranges for Lucent/Agere DSP modems:
------------------------------------------
LUCENT 0x11c1 0x0440-0x045c
XIRCOM 0x115d 0x0000-0x000F
XIRCOM 0x115d 0x0440-0x045c
XIRCOM 0x115d 0x0010-0x03ff
-------------------------------------------
Drivers and their compiler kits are available at:
http://www.heby.de/ltmodem/

For more details read the Recording file.



==================================================

Checking for any preliminary complications.
Kernel config file not recognized within the /boot folder.

OK thus far.

Removing old makings and expanding a clean source.tar.gz
Setting BLDrecord.txt link within source/ folder.
lrwxrwxrwx 1 foo users 16 Apr 10 20:13 BLDrecord.txt -> ../BLDrecord.txt
Following a successful check for matching kernel-headers,
the modem drivers will be compiled for the current kernel version: 2.4.20

Performing a configure trial and capturing the report to ../conf-report.txt.
Parsing the report:
No kernel headers found.
A sample successfull conf_out.txt is in the folder DOCs/
Read in DOCs/ ForNewbies, Compile-Properly.txt and Flavor.txt

For the Linux distribution SuSe and perhaps Others,
the resource test failure may merely be
because Root permission is needed to access kernel-headers/ folders.
Login in as Root and re-run ./build_module
Here is the report from ../conf-report.txt
------------------
creating cache ./config.cache
Checking OS
Checking machine type
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
Checking gcc major version 3
Checking for rpm build... rpmbuild
checking for a BSD compatible install... /usr/bin/ginstall -c
checking for make... yes
checking for ld... yes
Checking for kernel headers
... in /usr/src/linux: nope
... in /usr/src/kernel-headers-2.4.20: nope
... in /usr/src/linux-2.4.20: nope
... in /lib/modules/2.4.20/build: nope
ERROR: No kernel headers found.
If you have kernel headers installed but configure did not
find them, please try:
configuring the sources with utils/srcprep
if a Debian like System, see utils/kpkgprep
install the kernel headers from your distribution if available.
Do carefully read 1stREAD.
Two other common problems are unreadable kernel sources
(SuSE - build as root) or unconfigured kernel sources
(configure kernel sources and execute make dep in the
kernel source tree).

------------------

Could you post the command that would do it for me(suld be ln -s *stuff here*).
 
Old 04-10-2004, 07:35 PM   #12
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
What's this?
Code:
drwxr-xr-x 2 root root 4096 Apr 10 20:07 l
I think you want this (or similar, of course)
Code:
lrwxrwxrwx    1 root     root           12 Dec  4 20:50 linux -> linux-2.4.23
drwxr-xr-x   15 root     root          584 Nov 30 01:35 linux-2.4.23
So you need
Code:
cd /usr/src
ln -s linux-2.4.20 linux
There's more in that error message that confuses me, but let's try just that much and it may not be an issue.
 
Old 04-11-2004, 12:11 AM   #13
MikeFoo1
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1
Posts: 72

Rep: Reputation: 15
hey , there has been a major development :O !!I think everyting is installed now but i can't use it yet.

Quote:
The following information blocks just query some ppp support items.
====================================================================
grep ppp /etc/modules.conf
--------------------------------
--------------------------------
DEVPPP=crw-rw---- 1 root uucp 108, 0 Mar 25 2001 /dev/ppp
DEVFS=
DEVFSD=

-------------- ending SCANMODEM section ----------------
BASE=source
# ===SETTINGS===
LT_SERIAL_MODULE="lt_serial"
LT_PROPRIETARY_MODULE="lt_modem"
DOCS="1ST-READ CHANGELOG UPDATES-BUGS DOCs utils"
LT_VERSION="8.26a9"
KPKG="kernel"

FV=
checking whether we are using GNU C... yes
using /lib/modules/2.4.20/build
kernel headers are version 2.4.20
BUILD_LINK=/lib/modules/2.4.20/build -> /usr/src/linux-2.4.20
HEADERS_IN=/lib/modules/2.4.20/build/include/linux/
Sorry, assembly of the needed header file: modversions.h
was not specified during configuration of the kernel sources.
Withing the section LOADABLE MODULE SUPPORT:[*] Set version information on all module symbols
which is necessary to specify the assembly of modeversions.h
Consequently compiling of the drivers will fail at the next step.
MODVERH=

Next checking utilty versions, with ranges
Version_min
Utility or range for kernels
name 2.2.16 2.4.18 Actual_version
Gnu C 2.7.2.3 2.95.3-3.2.1 3.2.2
Gnu make 3.79.1 3.77
binutils 2.8.1.0.23 2.9.1.0.25 2.13.90.0.18


The gcc compiler resources available are:
----------------------------
lrwxrwxrwx 1 root root 9 Apr 9 10:16 /usr/bin/gcc -> gcc-3.2.2
-rwxr-xr-x 1 root bin 85328 Feb 8 2003 /usr/bin/gcc-3.2.2
-rwxr-xr-x 1 root bin 15694 Feb 8 2003 /usr/bin/gccbug
----------------------------
with your System currently using version 3.2.2
Do NOT mix the major versions of compilers for the kernel and modem drivers
or your System will crash! The following releases are using gcc version 3.2.x :
Mandrake 9, Redhat 8 and SuSE 8.1 in November 2002.
This build_module automatically adjusts its resources to the compiler version used.
See the utils/ltrename (by Mark Spieth) called by the Makefile.

-rw-r--r-- 1 root root 543093 Apr 11 15:13 lt_modem.o
-rw-r--r-- 1 root root 26046 Apr 11 15:13 lt_serial.o
DEPMOD=/sbin/depmod
EXTRAMOD=
succeeded: /sbin/depmod -e lt_modem.o
succeeded: /sbin/depmod -e lt_modem.o lt_serial.o

#=========== autoload section ====================
ENVIR=autoload
INSTALLER=./autoload
TMPM=/tmp/ltmodem/tmpfile
FAST=
LT_VERSION=8.26a9
TARGET_VERSION=2.4.20
TARGET_CPU=
SYSTEM_CPU=i686
GCC_DRIVERS=3
GCC_NOW=3.2.2
GCC_KERNEL=3

DEVFS=
MODEM=ttyS1
DEV_MODEM_LINK_ORIG=ttyS1

#=========== autoload section ====================
ENVIR=autoload
INSTALLER=./autoload
TMPM=/tmp/ltmodem/tmpfile
FAST=
LT_VERSION=8.26a9
TARGET_VERSION=2.4.20
TARGET_CPU=
SYSTEM_CPU=i686
GCC_DRIVERS=3
GCC_NOW=3.2.2
GCC_KERNEL=3

DEVFS=
DEV_MODEM_LINK_ORIG=
DEVICE_NODE=/dev/ttyLT0
SYM_LINK1=/dev/modem
With permissions to group: dialout

MCFILE=/etc/modules.conf

UPDATE_MOD=/sbin/depmod -a

Your system is lacking Default lines in /etc/modules.conf
which are usually needed to support the modem communications protocol PPP.
Some modem installations replace these Defaults
with lines specific to particular modem hardware.
There may be problems using the Lucent/Agere modem without these Default lines.
The suspect lines are:
------------------------------
cat /tmp/ltmodem/tmpfile
------------------------------
and are being inserted in BLDrecord.txt for your judgement.
Should you insert them in /etc/modules.conf, inform the System with
/sbin/depmod -a

DEPMOD_A=passed
The following block has been written to /etc/modules.conf:
/etc/modules.conf
# lt_drivers: autoloading and insertion parameter usage
alias char-major-62 lt_serial
alias /dev/tts/LT0 lt_serial
alias /dev/modem lt_serial
# The next two lines are syntax examples, only Rarely Needed, to automate parameter usage during lt_drivers insertion. See documentation for details.
# options lt_modem vendor_id=0x115d device_id=0x0420
# options lt_modem Forced=3,0x130,0x2f8,0
# section for lt_drivers ends


Please browse to benefit from DOCs/ and utils/ therein.
Firstly , i am using kppp to dial-up.Just have to make sure that i got the right device .Is it /dev/modem or /dev/ttyLT0 ? I tried both and they seem to say things like "Modem ie buisy " or "Modem ready" then "Can't dial" .

I will post the exact message .
 
Old 04-11-2004, 12:38 AM   #14
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Well, I'm going to bow out now and hopefully somebody else can help you the rest of the way. Because that's about as far as I ever got: kppp and error messages. I'd hit a bunch of buttons in the kppp interface in a process I can't remember anymore and it eventually, randomly, connected. Then my machine would randomly lock up and I'd have to reboot.
 
Old 04-11-2004, 01:59 AM   #15
MikeFoo1
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1
Posts: 72

Rep: Reputation: 15
Ok, what i have is that:

in my /dev/



Code:
modem -> /dev/ttyLT0
modem2 -> ttyS2root@****
when i set device (in kppp) as modem i get "Unable to open".
when i go with ttyS2 then i get "Modem is buisy".


Maybe i need to remove the ttyS2 from the /dev/ ?


Anyone ?

btw thanks for your help digiot :-) .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
from Terminal to GUI and other Q's swee7an Linux - Software 4 08-27-2005 02:57 PM
SLACKWARE RULES!, but i have some q's joker20 Linux - Newbie 10 09-16-2004 12:01 AM
How to open programs in terminal without being stuck to the terminal?? brynjarh Linux - Newbie 6 07-07-2004 01:52 PM
Slackware Q's StamfordRob Linux - Newbie 13 07-11-2003 05:12 AM
Two Slackware networking Q's NSKL Slackware 4 07-03-2002 07:41 AM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration