LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-26-2010, 06:11 PM   #1
porphyry5
Member
 
Registered: Jul 2010
Location: oregon usa
Distribution: Slackware 14.1, Arch
Posts: 437

Rep: Reputation: 19
slackware automatic boot and load


I've installed Slackware 12.2 on a 12 year old desktop. It is the only OS on the machine. When I press the Power button it stops at Slackware's splash screen asking me to choose an OS, even tho' there is only one to choose from. I installed LILO to the MBR and that is also listed there as a possibility.

Is there a way to set Linux so it will simply load automatically? Thanks for your help.
 
Old 07-26-2010, 06:56 PM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
There sure is! You'll need to edit the file located at /etc/lilo.conf and change one or two parameters.

Before doing do, open a terminal window, and type:
Code:
man lilo.conf
And you can there read the manual page (documentation) for the lilo.conf file.

There are several parameters affecting what you speak of: prompt and timeout= and delay=.

Read the man page carefully, as these parameters affect each other to some degree. If I remember right, you want the delay= option; set it to a number of tenths of a second (a very small timeout). If this doesn't work as expected (like, it doesn't auto-boot), boot up and try setting the timeout= option. I can't remember which option is which -- delay or timeout -- but someone here surely does remember and will verify this sooner or later.

It's relatively safe to experiment with these items; but remember:

1) You need to be root to edit the config file.
1b) Refer to the example(s) in the man page while you're editing.
2) Save the file after editing.
3) In your console (terminal window) AFTER having edited & saved the file & exited the editor, type:
Code:
lilo
and press return. If all's well, LILO will show a brief message about which image(s) are set up for booting. If you see an error message, something's wrong with the file.

What editor to use? Up to you.. Kwrite if you like.. Or nano, or some other one.... All can be started from the console:

Code:
root$ nano /etc/lilo.conf

or

root$ kwrite /etc/lilo.conf
 
Old 07-27-2010, 01:22 PM   #3
porphyry5
Member
 
Registered: Jul 2010
Location: oregon usa
Distribution: Slackware 14.1, Arch
Posts: 437

Original Poster
Rep: Reputation: 19
Re: GrapefruiTgirl's response

Thank you very much. Worked like a charm.

 
Old 07-27-2010, 01:27 PM   #4
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Hey, that's great

Please, tell us which option(s) you used? I still cannot remember which ones!

And, if you're happy with this thread's outcome, you can mark it [solved] if you like, using "Thread Tools" near the top.
 
Old 07-29-2010, 02:45 PM   #5
porphyry5
Member
 
Registered: Jul 2010
Location: oregon usa
Distribution: Slackware 14.1, Arch
Posts: 437

Original Poster
Rep: Reputation: 19
Solved: To have Linux load automatically

In lilo.conf I commented out the "prompt" statement and set the "timeout" statement value to 1. There is no "delay" statement in my lilo.conf. Thanks again.

I couldn't see any reference to "Thread Tools" anywhere on the page, so included Solved as part of the title.
 
Old 07-29-2010, 02:48 PM   #6
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by porphyry5 View Post
I couldn't see any reference to "Thread Tools" anywhere on the page, so included Solved as part of the title.
Right in the top-center header of your 1st post.

Thanks for the update!
 
Old 07-29-2010, 02:48 PM   #7
porphyry5
Member
 
Registered: Jul 2010
Location: oregon usa
Distribution: Slackware 14.1, Arch
Posts: 437

Original Poster
Rep: Reputation: 19
Re: Solved

Aah, but there, after I made the post, it appeared.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Minime won't load on automatic boot catminister Linux - Newbie 3 01-23-2009 10:31 PM
how to load a scsi kernel in the boot prompt on slackware 12 instalation splyt Slackware - Installation 9 07-19-2007 08:56 AM
Automatic load of snd modules guldo Debian 2 12-22-2006 02:27 PM
automatic driver load & device permissions xtravar Linux - Hardware 0 06-17-2005 01:30 PM
How to load modules on demand (automatic loading)? Cyb3rPr0 Linux - Software 4 07-08-2004 12:07 AM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration