LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-24-2008, 04:21 PM   #1
bloodangel
LQ Newbie
 
Registered: Dec 2008
Posts: 4

Rep: Reputation: 0
Slackware 12.2 Wifi problem with Atheros


I just got Slackware 12.2 that apparently has ath5k built into it. I'm having trouble with my wireless network settings. I have an Atheros wireless card. I don't remember which model but it's a commonly supported one. I've gotten it to work just fine in the past. What I am having trouble with is KDE. It won't save my network settings. I enter all the info in and it seems to just forget everything I typed in. I've gotten it to connect and give me internet access twice after playing with it a hundred times but it never stays. As soon as I reboot it just goes away. I've had this issue with multiple Linux distros. I'm convinced that it's a problem with KDE. The information just won't stick. I commonly get it to connect to my wireless router (which is plugged into my modem) but it usually won't give me internet. I've thought about using MadWifi but I don't know how to disable ath5k. Any insight would be appreciated.
 
Old 12-24-2008, 05:38 PM   #2
zetabill
Member
 
Registered: Oct 2005
Location: Rhode Island, USA
Distribution: Slackware, Xubuntu
Posts: 348

Rep: Reputation: 31
Can you get it to work without help of KDE? (i.e. with ifconfig/iwconfig)
Code:
lspci | grep -i wireless
Use the output of that command to determine if your card is supported by ath5k using their compatibility website. Mine is an AR242x and neither madwifi or ath5k handle it. I need to get a snapshot of madwifi as the "production" version does not support my card.

If you need to switch to madwifi, you can blacklist the ath5k module by adding the following to /etc/modprobe.d/blacklist:
Code:
blacklist ath5k
I compile my own kernel and just leave it out so you could do that if you're going down that route (blacklisting is just fine if not). Then you can go to www.SlackBuilds.org, search for madwifi (currently there isn't anything labeled 12.2 but you can modify the 12.1 scripts to match up), and get the tools and the driver. If there's a new version of madwifi, you need to use a snapshot as I do, or have any questions about using the Slackbuild process we can help you get up and running.

As far as using KDE to manage your wireless, I would recommend installing the wicd package from extra and following the directions on getting that working instead of using KDE.
 
Old 12-25-2008, 12:42 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,390
Blog Entries: 3

Rep: Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479
Hi,
Quote:
Originally Posted by bloodangel View Post
I just got Slackware 12.2 that apparently has ath5k built into it. I'm having trouble with my wireless network settings. I have an Atheros wireless card. <snip>
Your card should be recognized, do a 'ifconfig -a' from the 'cli' to show all recognized devices.

You should be using 'netconfig' from the 'cli' as root to setup your network. If need be you can edit the /etc/rc.d/rc.inet1.conf' as root to setup the network. You would then restart the inet with a '/etc/rc.d/rc.inet1 restart'.
 
Old 12-26-2008, 07:14 PM   #4
bloodangel
LQ Newbie
 
Registered: Dec 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,


Your card should be recognized, do a 'ifconfig -a' from the 'cli' to show all recognized devices.

You should be using 'netconfig' from the 'cli' as root to setup your network. If need be you can edit the /etc/rc.d/rc.inet1.conf' as root to setup the network. You would then restart the inet with a '/etc/rc.d/rc.inet1 restart'.
Thanks for the info. I did end up manually editing the /etc/rc.d/rc.inet1.conf file and it worked and would load on boot. My only problem now is that it's dramatically slow in Konqueror and Firefox basically won't load. Could just be the ath5k driver. I tried Ubuntu, which still uses the madwifi driver by default, and it was like a speed demon.
 
Old 12-26-2008, 08:05 PM   #5
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Rep: Reputation: 38
Do you use any sort of encryption? Because that is where the Ath5k driver dies on me.
 
Old 12-26-2008, 08:10 PM   #6
bloodangel
LQ Newbie
 
Registered: Dec 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mjjzf View Post
Do you use any sort of encryption? Because that is where the Ath5k driver dies on me.
I use a short hex WEP key
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu studio and Atheros wifi problem sidneylopsides Linux - Newbie 3 10-08-2008 07:18 PM
Slackware Atheros AR5007 configuration(?) problem and Wifi issues ZeroDaHero Linux - Wireless Networking 2 08-24-2008 07:09 PM
Atheros WiFi jamaliskandar Suse/Novell 2 08-11-2008 11:04 AM
Wifi installation problem for a Atheros chipset jacobdm Linux - Newbie 13 11-14-2007 01:28 AM
Atheros cardbus wifi card problem Nostur Linux - Hardware 1 05-23-2006 11:13 PM


All times are GMT -5. The time now is 03:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration