LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2008, 10:53 PM   #1
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Rep: Reputation: 15
Screen Resolution too small + no option to change it


I've installed Slackware on an old laptop and the screen resolution is 640x480 and I wish to make it 1024x768. I tried doing xrandr but the only option that comes up is 640x480.

Last edited by gNguyen; 10-15-2008 at 04:59 PM.
 
Old 08-01-2008, 11:09 PM   #2
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
You can change the /etc/X11/xorg.conf file to be 1024x768

You will have to restart x for the settings to work though
 
Old 08-02-2008, 01:18 AM   #3
MafiaTux
LQ Newbie
 
Registered: Aug 2008
Location: Portland, Oregon United States
Distribution: Mandriva, Ubuntu, Goblinx, and linux xp
Posts: 20

Rep: Reputation: 0
Try reconfiguring x
 
Old 08-02-2008, 08:18 AM   #4
jestinjoy
Member
 
Registered: May 2004
Location: India
Distribution: Ubuntu 9.04, Debian Lenny
Posts: 121

Rep: Reputation: 22
configure your monitor.in system settings to 1024*768
 
Old 08-02-2008, 10:41 AM   #5
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Original Poster
Rep: Reputation: 15
How exactly do you do that? What part of the xorg.conf file do i change?

Last edited by gNguyen; 08-02-2008 at 03:18 PM.
 
Old 08-02-2008, 11:12 AM   #6
wraithe
Member
 
Registered: Feb 2006
Location: Australia
Distribution: Linux... :-)
Posts: 216
Blog Entries: 1

Rep: Reputation: 31
Will it support the higher resolution...
What was the max resolution when it was running windows...
the first post stated the solution, but beware of the limits of the monitor...
 
Old 08-02-2008, 12:13 PM   #7
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Original Poster
Rep: Reputation: 15
On Windows it was at 1024x768. In the xorg.conf file it has "1024x768" "800x600" "640x480" in that order. But I can't choose 1024x768. What part of the xorg.conf file do I have to edit?

Last edited by gNguyen; 08-02-2008 at 03:19 PM.
 
Old 08-02-2008, 01:33 PM   #8
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
First make sure you can edit xorg.conf from a terminal if you bork x.
Then change the modeline: "1024x768" "800x600" "640x480"
to: "1024x768" # "800x600" "640x480"
to force the mode you want.
I take it you already are using the correct driver for you video card. If not sure post the output of "lspci |grep VGA" and your xorg.conf.
 
Old 08-02-2008, 03:03 PM   #9
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Original Poster
Rep: Reputation: 15
I changed the "1024x768" "800x600" "640x480" 's to "1024x768" # "800x600" "640x480" 's but it still doesn't work. I also did the command and it said:
Code:
00:02.0 VGA compatible controller: Intel Corporation 82815 Chipset Graphics Controller (CGC) (rev 11)

Last edited by gNguyen; 08-02-2008 at 03:20 PM.
 
Old 08-02-2008, 04:55 PM   #10
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Have you tried running xorgsetup, as root?
 
Old 08-02-2008, 05:30 PM   #11
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Original Poster
Rep: Reputation: 15
I tried the setup and the res. changed to 800x600. I still can't get the res. to 1024x768. The xorg.conf file has totally changed. Theres no more 1024x768, 800x600, or 640x480. Also there is a new problem... the mouse is off sync.

Last edited by gNguyen; 08-02-2008 at 05:37 PM.
 
Old 08-02-2008, 06:11 PM   #12
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Mmm, so my advice has made things worse. Sorry about that. When you run xorgsetup, it usually backs up your old xorg.conf, try reverting to that.
 
Old 08-02-2008, 07:46 PM   #13
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Original Poster
Rep: Reputation: 15
I reversed the changes... Now what do I do?
 
Old 08-03-2008, 03:22 AM   #14
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Post your xorg.conf and check with lsmod if the i810 driver is loaded.
 
Old 08-03-2008, 03:25 AM   #15
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Rep: Reputation: 32
Quote:
Originally Posted by gNguyen View Post
I tried the setup and the res. changed to 800x600. I still can't get the res. to 1024x768. The xorg.conf file has totally changed. Theres no more 1024x768, 800x600, or 640x480. Also there is a new problem... the mouse is off sync.
run then command if ur mouse is not working

"service gpm restart"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Looks Small in 1024x768 Screen Resolution jlconferido Linux - Newbie 26 04-11-2007 07:55 AM
change screen resolution of xdm login screen in suse linux pseudoxiah Linux - Desktop 2 04-02-2007 10:26 AM
Resolution screen to small on knoppix burnt1ce85 Linux - Newbie 1 12-11-2004 12:48 PM
Change Screen Resolution? Darrin Linux - Newbie 3 06-27-2003 10:50 AM
Screen resolution is too small! Josnap Slackware 1 03-31-2003 12:36 AM


All times are GMT -5. The time now is 01:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration