LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-05-2007, 11:01 AM   #1
jlconferido
Member
 
Registered: Apr 2007
Distribution: Ubuntu Feisty Fawn
Posts: 52

Rep: Reputation: 15
Screen Looks Small in 1024x768 Screen Resolution


Hi. I am a newbie and here are some imformation about my hardware and settings tha you can help out with in my inquiry.

OS: 6.10 Edgy Eft
VC: Palit 7600 GS
Monitor: LG T710SH CRT
Driver: 1.0-8776

My screen resolution settings are 1024x768 for the screen resolution and this is optimal for my CRT monitor, refresh rate is 85Hz.

I noticed that the screen looks small which means that there are spaces at the edges and I can not get the optimal view. Surely I can adjust the width and the height in my CRT ,but, is there a fix for this so that my desktop display will be bigger? Many thanks!
 
Old 04-05-2007, 11:16 AM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Sure sounds like the Horizontal scan rate and/or vertical refresh rate you are using is not correct, and so the driver is not displaying the screen properly.
I am guessing you use an nVidia card, based on the driver number you post. What type of card is it?
Check the monitor manual, or use google, and verify the HorizSync and VertRefresh ranges for your xorg.conf file, and make sure the driver is specified as 'nvidia', not 'nv'.

EDIT - Sorry, ok I see the card there.. Who makes it? Is it an nvidia?

Last edited by GrapefruiTgirl; 04-05-2007 at 11:17 AM.
 
Old 04-05-2007, 11:22 AM   #3
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Horizontal Frequency 30 ~ 71 kHz
Vertical Frequency 50 ~ 160 Hz

Here's what your HorizSync and VertRefresh rates should be.
 
Old 04-05-2007, 05:20 PM   #4
jlconferido
Member
 
Registered: Apr 2007
Distribution: Ubuntu Feisty Fawn
Posts: 52

Original Poster
Rep: Reputation: 15
@GrapefruiTgirl

Thanks! I changed the horizontal and vertical frequencies and nothing changed. Should I also adjust the refresh rates? How to adjust this?
In the manual, it says that the best resolution is 1024x768 and the refresh rate should be 75 hz.

Last edited by jlconferido; 04-05-2007 at 05:59 PM.
 
Old 04-05-2007, 07:19 PM   #5
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Yes, I looked at the specs online. Every monitor comes with a set of numbers they claim are the best, mine included. But these are at ideal conditions, on a praticular bunch of hardware, with a perfect driver, etc etc.. For mine, it says the native resulution is 1024*768 @ 85 hz , however its maximum resolution is 1600*1200, which is what I use. At this resolution, the refresh rate is 75.1H x 60.1V

So, the idea is to give the entire range your monitor is able to handle, and let it decide for itself what refresh & scan rates to use for a given resolution. In other words, do not have just one single number for the scan rates, but give it the whole range.

Why not post your xorg.conf file here so we can have a look
 
Old 04-06-2007, 04:12 AM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I'm quite sure that your monitor has controls to adjust the vertical and horizontal size.
 
Old 04-06-2007, 07:25 AM   #7
jlconferido
Member
 
Registered: Apr 2007
Distribution: Ubuntu Feisty Fawn
Posts: 52

Original Poster
Rep: Reputation: 15
Yup it has but can it adjust automatically based on settings?

Here is my xorg.conf(/etc/X11):

Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NVIDIA Default Card"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NVIDIA Default Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
I installed the new dirvers from Nvidia thru Envy. It gives me more options. However, when I adjust the settings to 1024x768, 75 Hz it comes back to the default refresh rate settings of 50Hz since I installed the new drivers. Any fix for this? Thanks.
 
Old 04-06-2007, 08:42 AM   #8
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Your max refresh is 60 Hz according to your xorg.conf. Change the two lines below to match your monitor's capabilities:
Code:
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
and restart the x-server
 
Old 04-06-2007, 09:35 AM   #9
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Yup, that should do wonders as Wim says, change those lines to the values I gave above. This will allow your monitor to pick the best scan rates for the resolution being sent to it.
 
Old 04-07-2007, 07:55 AM   #10
jlconferido
Member
 
Registered: Apr 2007
Distribution: Ubuntu Feisty Fawn
Posts: 52

Original Poster
Rep: Reputation: 15
I change the settings in xorg.conf but every restart goes back to 50hz. I must be doins something incorrectly. I saved the settings in nvidia-settings but still the same.
 
Old 04-07-2007, 09:14 AM   #11
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
OK, try removing or commenting-out the line in Module Section for 'Load DDC' and also add a line to the Screen Section like:
Option "UseEDID" "False"

And if this doesn't work, re-post your xorg.conf (as it is now) in your above post where you initially posted it.
 
Old 04-07-2007, 08:49 PM   #12
jlconferido
Member
 
Registered: Apr 2007
Distribution: Ubuntu Feisty Fawn
Posts: 52

Original Poster
Rep: Reputation: 15
@GrapefruiTgirl

Thanks a lot for the help and I am glad that there are a lot of people here in this community that help newbies like me. So here is the the conf file and I have not changed anything because I want to show you first:

Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30.0 - 71.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NVIDIA Default Card"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NVIDIA Default Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
I will follow your guide but don't know exactly what to type. Do you mind teaching a fool like me about it? Thanks for the wonderful help and more power to you!
 
Old 04-07-2007, 09:36 PM   #13
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
OK first, is there an onboard video device in your computer, as well as this card?
If there is, please post the output of 'lspci' entered into a root console.

Now... Technically there's nothing *wrong* with this file; it could however have a few things added to it, in case one of them is something that will help the situation. It is something of a trial and error process though.
Also, If you haven't already, get a copy of the README file or the tutorial from nvidia.com and browse through it. It is VERY detailed, and explains every possible option you might ever need for these drivers.

Once you post the 'lspci' results I will suggest some things to add to the file; some of all of them may or may not help fix it, but again, it's different for almost every machine, so it is trial and error.
 
Old 04-08-2007, 12:46 AM   #14
jlconferido
Member
 
Registered: Apr 2007
Distribution: Ubuntu Feisty Fawn
Posts: 52

Original Poster
Rep: Reputation: 15
If its not so much to ask what are the commands for lspci? Thanks.
 
Old 04-08-2007, 12:48 AM   #15
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551

The command 'lspci' *is* the command. Just enter a console, use 'su' and enter the root password, and type 'lspci'. Then post the output here.
 
  


Reply

Tags
resolution, screen


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't get screen resolution to 1024x768 marta Debian 18 03-26-2010 05:33 PM
Can't change screen resolution from 1280x1064 to 1024x768 dbayguy Ubuntu 4 03-27-2007 03:45 PM
Can't change screen resolution from 1280x1064 to 1024x768 dbayguy Ubuntu 1 03-18-2007 08:42 PM
larger screen resolution than 1024x768 Crayoneater Slackware - Installation 9 09-13-2005 06:17 PM
Make Screen Resolution 1024x768 gsoft Linux - General 4 03-09-2004 03:22 AM


All times are GMT -5. The time now is 04:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration