LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-01-2005, 12:56 PM   #1
darkervisions
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 34

Rep: Reputation: 15
Exclamation Screen Resolution


Hi, i'm new to linux. I tried to change my screen resolution from 800x600, but there is only one other option (640x480). I would like to use 1280x800. My computer is capible of it, but it's just not there for usage. Thanks for the help. ;D

Last edited by darkervisions; 12-01-2005 at 01:42 PM.
 
Old 12-01-2005, 01:02 PM   #2
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
You'd like to use 1200x800?

Which distro of Linux are you running?
 
Old 12-01-2005, 01:04 PM   #3
darkervisions
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
I'm using Ubuntu.
Sorry, I ment 1280x800. lol

Last edited by darkervisions; 12-01-2005 at 01:06 PM.
 
Old 12-01-2005, 03:09 PM   #4
anti.corp
Member
 
Registered: Nov 2005
Location: Copenhagen
Distribution: Debian E, Vectorlinux 5.1std, Arch, Gentoo 2006.0
Posts: 576

Rep: Reputation: 30
Hi,

You may need to manually edit your /etc/X11/xorg.conf. Make sure to create a backup first.

If can also post your xorg.conf here.

 
Old 12-01-2005, 05:35 PM   #5
darkervisions
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
I don't know how to do that. When I try to open it in Gedit or whatever, it says that it is read only. I don't know what to change and what not.
 
Old 12-01-2005, 05:43 PM   #6
Mateo1041
Member
 
Registered: Nov 2004
Location: New Prague, MN
Posts: 80

Rep: Reputation: 15
Do you need to be logged in as root? Then maybe try the "vi" editor from the Linux prompt.

Just some ideas...
 
Old 12-01-2005, 05:55 PM   #7
alperthereal
LQ Newbie
 
Registered: Oct 2005
Location: Ankara, Turkey
Distribution: Ubuntu 5.10 & Mandrake 10.1
Posts: 6

Rep: Reputation: 0
Lightbulb

Quote:
Originally posted by darkervisions
I don't know how to do that. When I try to open it in Gedit or whatever, it says that it is read only. I don't know what to change and what not.
hey darkervisions,

if you are sure your computer (graphics card + monitor) is capable of handling the resolutions you mention, then there is no reason why it wouldn't work.

ok, first, yes, it is gedit and, true, you may not be able to open the .conf file for writing. to be able to that, you need to know your root password -- which i am assuming you do. but i really dont recommend, editing that .conf file manually,

judging by your post (mentioning gedit), you are gnome user. so try changing the resolution from the preferences --> screen resolution tool.

btw, if you told us what distro you were using, we probably could be more helpful

good luck!
 
Old 12-01-2005, 05:55 PM   #8
darkervisions
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
What is the password for root? Ahh confusion.

Last edited by darkervisions; 12-01-2005 at 05:56 PM.
 
Old 12-01-2005, 05:58 PM   #9
alperthereal
LQ Newbie
 
Registered: Oct 2005
Location: Ankara, Turkey
Distribution: Ubuntu 5.10 & Mandrake 10.1
Posts: 6

Rep: Reputation: 0
Quote:
Originally posted by darkervisions
What is the password for root? Ahh confusion.
you don't know your root password? ok, darkervisions, you really need to tell what distro you are using now...
 
Old 12-01-2005, 05:59 PM   #10
darkervisions
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by alperthereal
hey darkervisions,

if you are sure your computer (graphics card + monitor) is capable of handling the resolutions you mention, then there is no reason why it wouldn't work.

ok, first, yes, it is gedit and, true, you may not be able to open the .conf file for writing. to be able to that, you need to know your root password -- which i am assuming you do. but i really dont recommend, editing that .conf file manually,

judging by your post (mentioning gedit), you are gnome user. so try changing the resolution from the preferences --> screen resolution tool.

btw, if you told us what distro you were using, we probably could be more helpful

good luck!
I'm using ubuntu. I had windows on this system previously, and it was capible of running in 1280x800. I tried changing the resolution but 1280x800 was not an option there.
 
Old 12-01-2005, 06:06 PM   #11
alperthereal
LQ Newbie
 
Registered: Oct 2005
Location: Ankara, Turkey
Distribution: Ubuntu 5.10 & Mandrake 10.1
Posts: 6

Rep: Reputation: 0
Quote:
Originally posted by darkervisions
I'm using ubuntu. I had windows on this system previously, and it was capible of running in 1280x800. I tried changing the resolution but 1280x800 was not an option there.
ok then, ubuntu it is. you probably never needed root password before. i am betting it has never been changed -- it is default. to set the password, use the toolbar on the top of the screen by default.

Applications | System Tools | Root Terminal

run that. then voila, you can run programs as root. but first, set a root password. type

Code:
passwd
and then enter your password. now you have a root password, my friend, don't you forget this after doing that.

using the same toolbar,

System | Preferences | Screen Resolution

you can change your resolution using that program.

good luck again
 
Old 12-01-2005, 07:17 PM   #12
darkervisions
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
Okay, thank you, that worked. Now how do I add that 1280x800 as option in the list? lol
 
Old 12-01-2005, 07:47 PM   #13
elrohir_telperi
LQ Newbie
 
Registered: May 2004
Location: Malaysia
Distribution: Mandrake 9.2, Mandrake 10.0, Ubuntu 5.10 Breezy Badger
Posts: 17

Rep: Reputation: 0
Hi,

firstly run gedit as root (sudo gedit /etc/X11/xorg.conf)

then search the file for line

Code:
Section "Screen"
Code:
	SubSection "Display" 		Depth		24 		Modes		 "1400x1050" "1280x1024" "1024x768" "800x600" "640x480" "720x350"  EndSubSection
add in "1280x800", save the file.

restart x (ctrl alt backspace)

now you should have 1280x800.

cheers.
 
Old 12-01-2005, 08:10 PM   #14
darkervisions
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
Okay, I tried that. Nothing happened. Here is a copy of my xorg.conf. (Wow am I learning linux quickly. )

Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/CID"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. 3D Rage Pro (AGP)"
	Driver		"ati"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"MX50"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. 3D Rage Pro (AGP)"
	Monitor		"MX50"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600" "720x400" "640x480" "1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection
 
Old 12-01-2005, 09:28 PM   #15
lord-fu
Member
 
Registered: Apr 2005
Location: Ohio
Distribution: Slackware && freeBSD
Posts: 676

Rep: Reputation: 30
Hello,

Change this
Code:
SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600" "720x400" "640x480" "1280x800"
	EndSubSection
to this

Code:
SubSection "Display"
		Depth		24
		Modes		"1200x800" "1024x768" "800x600" "720x400" "640x480" 
	EndSubSection
That should work.
Hope it helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 02:33 AM
Screen lock changes screen resolution ohzo Linux - Laptop and Netbook 0 06-23-2004 12:13 PM
Unable to configure screen resolution for 15.2" LCD screen in Fedore Core 1 schu Linux - Newbie 3 01-02-2004 06:39 PM
screen freezes after making changes to the screen resolution with Xconfigurator sharathkv Linux - Newbie 1 08-01-2003 06:56 AM


All times are GMT -5. The time now is 10:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration