LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-14-2015, 03:55 PM   #1
mhsahkir
LQ Newbie
 
Registered: Dec 2014
Location: U.S.A ,NEWYORK
Posts: 24

Rep: Reputation: Disabled
Root sign has been changed?


When i logged in as a root,generally it should be show me # sign, but somehow it has been changed and showing $ sign as a root privilege.
Attached Thumbnails
Click image for larger version

Name:	Snapshot_20140819.jpg
Views:	24
Size:	48.3 KB
ID:	18115  
 
Old 04-14-2015, 04:15 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
You have not posted the output as requested for this issue under the following thread: http://www.linuxquestions.org/questi...er-4175539330/
 
1 members found this post helpful.
Old 04-14-2015, 04:25 PM   #3
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Void, Debian
Posts: 812

Rep: Reputation: 216Reputation: 216Reputation: 216
The prompt is specified by the PS1 variable. This in turn is typically set in the .bashrc.

You presumably want something like this
Code:
PS1='[\u@\h:\w]# '
 
1 members found this post helpful.
Old 04-15-2015, 03:37 AM   #4
mhsahkir
LQ Newbie
 
Registered: Dec 2014
Location: U.S.A ,NEWYORK
Posts: 24

Original Poster
Rep: Reputation: Disabled
Thanks a lot guys, specially @joe.
 
Old 04-16-2015, 03:41 AM   #5
mhsahkir
LQ Newbie
 
Registered: Dec 2014
Location: U.S.A ,NEWYORK
Posts: 24

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by joe_2000 View Post
The prompt is specified by the PS1 variable. This in turn is typically set in the .bashrc.

You presumably want something like this
Code:
PS1='[\u@\h:\w]# '
Hi joe this code does worked but when i reboot the system,its came back($ sign) the way it was. Do you know where i can edit it and keep this sign permanent?
 
Old 04-16-2015, 05:45 AM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
You can put this code in /root/.bashrc file or /root/.bash_profile file to make it permanent.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] changed username in slackware12.1 now can't sign into acct NightSky Slackware 6 10-28-2009 05:15 PM
can't sign in as root cluelessme Linux From Scratch 3 03-10-2009 11:46 PM
can't sign on as root samuelmp Ubuntu 3 09-04-2005 10:36 AM
can't sign in as root howarddevore Debian 6 07-18-2005 02:16 PM
how do i sign into root with one command? provkitir Linux - Newbie 12 10-28-2004 08:08 PM


All times are GMT -5. The time now is 04:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration