LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-04-2003, 11:25 PM   #1
Subleak
LQ Newbie
 
Registered: May 2003
Distribution: Debian 3.0 & RedHat 9.0
Posts: 18

Rep: Reputation: 0
Removing Old Version of Glib


I'm currently trying to install GAim.
After Upgrading my versions of glib and pkg-config to meet the reqs of GAim, im receiving an error with i attempt to ./configure GAim folder.

*** 'pkg-config --modversion glib-2.0' returned 2.2.1, but GLIB (2.0.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old verions of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH environment variable, or by editing
*** /etc/ld.so.conf . Make sure you have run ldconfig if that is
*** required on your system.
...

how would i go about doing one of those 2 things?
1) remove the old version of GLib
2) modifying LD_LIBRARY_PATH

which would be easiest?

Thanks for any Help

Running Debian 3.0R1 Kernel 2.4.18-bf2.4
 
Old 08-10-2003, 04:31 AM   #2
gusto
LQ Newbie
 
Registered: Aug 2003
Distribution: Fedora
Posts: 4

Rep: Reputation: 0
I ran into the same problem.
I did just:

rm /usr/lib/libglib*

and then I run

/sbin/ldconfig

and everything works fine.

I don't know if this is the right solution. But it worked for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
Removing Glib midgcool Linux - Software 4 11-25-2004 11:18 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Removing old version of Glib authenticgeek Linux - Newbie 1 09-24-2003 03:05 AM
Removing an old version of glib authenticgeek Linux - Software 3 09-18-2003 04:32 PM


All times are GMT -5. The time now is 03:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration