LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2009, 05:58 AM   #1
learnlinux2day
LQ Newbie
 
Registered: May 2009
Posts: 4

Rep: Reputation: 0
Problem with RIP routing using Quagga


Hello All,
I am Newbie to Quagga. I need to test the RIP and OSPF dynamic routing protocol functionality using quagga. I have made a small setup like shown below.


.12(eth0) .11(eth1)and .10(eth0) .11(eth1) and .10(eth0) .11(eth0)
Host A<------------------------------------------>Router1<------------------------------------------>Router2<------------------------------------------------>Host B
192.168.2.0 192.168.1.0 192.168.3.0

The Details of the network are interface between
Host A and Router 1 is 192.168.2.0 network .
Router1 and Router2 is 192.168.1.0 network.
Router2 and Host B is 192.168.3.0 network.
I am running quagga on router 1 and router 2 pc's. The following configurations were made in Router 1 and Router 2,

Configure R1
------------------------------------------------------------------------------------------
1. configure zebra.conf
! -*- zebra -*-
!

! list Interfaces
interface eth0
ip address 192.168.1.10/24
link-detect

interface eth1
ip address 192.168.2.11/24
link-detect

interface lo

!
ip route 192.168.3.0/24 eth0

!
ip forwarding
!
!log file
log file /var/log/quagga/zebra.log

line vty

1. configure ripd.conf

!
! RIPd sample configuration file
!
!
debug rip events
debug rip packet

!
router rip
version 2
network eth0
network eth1
network 192.168.1.0/24
network 192.168.2.0/24
neighbor 192.168.1.11
neighbor 192.168.2.12

!
!log file ripd.log
log file /var/log/quagga/ripd.log

!
line vty
!
------------------------------------------------------------------------------------------------------------

Configure R2
1. configure zebra.conf
! -*- zebra -*-
!

! list Interfaces
interface eth0
ip address 192.168.3.10/24
link-detect

interface eth1
ip address 192.168.1.11/24
link-detect

interface lo
! Static default route sample
ip route 192.168.2.0/24 eth1

!
ip forwarding
!
!log file zebra.log
log file /var/log/zebra/zebra.log

!
line vty

1. configure ripd.conf
! -*- rip -*-
!
! RIPd sample configuration file
!

!
debug rip events
debug rip packet

!
router rip
version 2
network eth0
network eth1
network 192.168.1.0/24
network 192.168.2.0/24
network 192.168.3.0/24
neighbor 192.168.1.10
neighbor 192.168.3.11

!
!log file ripd.log
log file /var/log/ripd.log

!
line vty
-------------------------------------------------------------------------------------------------

When i see the routing table from Router 1 using "show ip route", i am able to view only the static routing table.
The Dynamic RIP routing is not shown,similarly in the show ip rip it shows only connected interfaces not the RIP interfaces in both the routers mentioned above.

Am i missing any other configurations for RIP ,kindly help me.
Thanks in Advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Quagga 0.98.6 rip authentication KoreanLinuxer Linux - Networking 1 07-31-2007 02:47 AM
Quagga for Linux Routing without SNAT or MASQUERADE. Zepiroth Linux - Networking 1 03-12-2007 12:01 PM
Quagga Routing Problems amitabhmca Linux - Networking 1 05-28-2006 11:59 AM
RIP(Routing Information protocol) cranium2004 Linux - Networking 2 05-01-2005 07:08 AM
routing in linux using rip r.balaji Linux - Networking 0 09-04-2001 08:43 AM


All times are GMT -5. The time now is 10:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration