LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-01-2012, 02:55 PM   #1
dzeos
LQ Newbie
 
Registered: Dec 2011
Posts: 5

Rep: Reputation: Disabled
Problem with GCC and G++ !!


hello every body and happy new year 2012 ....

i want to compile enigma plugin and the probleme is

Code:
gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 4.3.2-1.1' --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --enable-targets=all --enable-cld --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.3.2 (Debian 4.3.2-1.1)
i need to set the GCC and G++ to i686-linux-gnu..

like this

Code:
gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/lto-wrapper
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.5.2-8ubuntu4' --with-bugurl=file:///usr/share/doc/gcc-4.5/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.5 --enable-shared --enable-multiarch --with-multiarch-defaults=i386-linux-gnu --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib/i386-linux-gnu --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.5 --libdir=/usr/lib/i386-linux-gnu --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-plugin --enable-gold --enable-ld=default --with-plugin-ld=ld.gold --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
Thread model: posix
gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)

g++ -v
Using built-in specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/lto-wrapper
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.5.2-8ubuntu4' --with-bugurl=file:///usr/share/doc/gcc-4.5/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.5 --enable-shared --enable-multiarch --with-multiarch-defaults=i386-linux-gnu --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib/i386-linux-gnu --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.5 --libdir=/usr/lib/i386-linux-gnu --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-plugin --enable-gold --enable-ld=default --with-plugin-ld=ld.gold --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
Thread model: posix
gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)

thank for help

Last edited by dzeos; 01-04-2012 at 04:30 PM.
 
Old 01-01-2012, 03:34 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
On your Debian machine
Code:
--build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
and on your Ubuntu machine
Code:
--build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
You would need to build gcc for an i686 target on you Debian machine. But, why does it need to be i686 to build the enigma plugin?
 
Old 01-01-2012, 03:41 PM   #3
dzeos
LQ Newbie
 
Registered: Dec 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
yes i need build gcc for i686-linux-gnu because when i execute plugin the box restart
 
Old 01-01-2012, 04:55 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,830

Rep: Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409
Quote:
yes i need build gcc for i686-linux-gnu because when i execute plugin the box restart
WHAT???

when you run the program the computer reboots ????

did you by chance read the egnima install instructions
http://enigma-dev.org/docs/Wiki/Install#Linux

for the SVN build
the ubuntu dependencies
http://enigma-dev.org/docs/Wiki/Linux#Dependencies

Is EVERYTHING installed and working?
if your computer is rebooting from a gcc compiler plugin then something went VERY wrong in the build

what were the build errors ?
 
Old 01-01-2012, 05:42 PM   #5
dzeos
LQ Newbie
 
Registered: Dec 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
no computer reboot !!!! the dreambox reboot

because when i compile plugin in i686-linux-gnu mode every thing is ok but in i486-linux-gnu the plugin crach so i need to change my gcc and g++ in i686-linux-gnu mode
 
Old 01-01-2012, 08:11 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,830

Rep: Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409
Quote:
no computer reboot !!!! the dreambox reboot
the satellite, cable tv set top box "dreambox" crashes and restarts?
http://en.wikipedia.org/wiki/Dreambox

then the "computer" IS restarting if the set-top box is rebooting ( a set top is a computer)
-- edit - added later ---
or is "dreambox" a very bad language translation ? if so is it VirtualBox VB)

the 486 cpu is a bit old

what is it you are doing ?
building software for the very old 486 hardware ?

to build on the old 486 hardware use the
Code:
--build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
in the build file for gcc

Last edited by John VV; 01-01-2012 at 09:53 PM.
 
Old 01-03-2012, 04:18 PM   #7
dzeos
LQ Newbie
 
Registered: Dec 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
waiting help ........

i need to Switching gcc and g++ to i686-linux-gnu target
 
Old 01-03-2012, 09:23 PM   #8
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
Suggestions have been provided, clarifying questions have been asked. Are you going to participate in the solution?
 
Old 01-04-2012, 04:34 PM   #9
dzeos
LQ Newbie
 
Registered: Dec 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
Lightbulb

waiting help ........

i need to Switching gcc and g++ from i486-linux-gnu to i686-linux-gnu target
like this ...

Code:
gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/lto-wrapper
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.5.2-8ubuntu4' --with-bugurl=file:///usr/share/doc/gcc-4.5/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.5 --enable-shared --enable-multiarch --with-multiarch-defaults=i386-linux-gnu --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib/i386-linux-gnu --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.5 --libdir=/usr/lib/i386-linux-gnu --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-plugin --enable-gold --enable-ld=default --with-plugin-ld=ld.gold --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=[COLOR="rgb(255, 0, 255)"]i686-linux-gnu[/COLOR] --host=[COLOR="rgb(255, 0, 255)"]i686-linux-gnu[/COLOR] --target=[COLOR="rgb(255, 0, 255)"]i686-linux-gnu[/COLOR]
Thread model: posix
gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)

Last edited by dzeos; 01-04-2012 at 05:14 PM.
 
Old 01-05-2012, 08:06 AM   #10
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
OK, as was stated in my first post.....you need to rebuild gcc for the i686-linux-gnu target on your Debian machine.

Are you sure the problem is the target and not the gcc version?
 
Old 01-05-2012, 09:21 AM   #11
johnsfine
LQ Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,286

Rep: Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181
Quote:
Originally Posted by dzeos View Post
i need to Switching gcc and g++ from i486-linux-gnu to i686-linux-gnu target
Why do you think that would help?

I'm sure you are ignoring a lot of differences between the situation that worked and the situation that failed. It is most likely one of the differences you are ignoring is responsible for the failure.

You haven't given enough information for us to make reasonable estimates of the correct diagnosis for your problem.

Recompiling gcc would be needed to make the change you think you need. You could download gcc source code and follow the included instructions and do that. But I suspect the process would be too difficult for you and more importantly wouldn't do you any good, because I'm pretty sure you are wrong about the gcc target even mattering.

There is also an option -march=i686 that can be used to make gcc produce roughly the same compiled code that it would have produced if gcc itself had been built for a target of i686. The makefile you are using for enigma probably would take such options via the CFLAGS environment variable, so you could compile enigma for i686 even using a gcc whose target is i486. That would be much easier than recompiling gcc itself. If you were correct (which I still really doubt) that the gcc target is a significant factor in your problem, the likely using -march=i686 would be as good as changing the gcc target.

Quote:
Originally Posted by weibullguy View Post
Are you sure the problem is the target and not the gcc version?
I would guess the problem is something else entirely, neither the target nor the gcc version. We don't know exactly what the OP tried on each machine, so it is reasonable to expect there are a wide variety of differences between the two situations.

Last edited by johnsfine; 01-05-2012 at 09:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] SEGMENTATION FAULT using gcc 4.4.4 -O2 , works with gcc 4.1.0 -O2 or gcc 4.4.4 -O1 amir1981 Programming 36 07-26-2010 07:07 PM
Compilation problem when downgrading from 64-bit gcc to 32-bit gcc huyhoang3673 Linux - Software 7 08-26-2009 12:31 PM
Problem building the PSP Toolchain under Ubuntu (gcc problem) L-28C Linux - Software 2 09-23-2008 03:38 AM
Solved Problem Second GCC-Pass(or gettext sanity check problem) hoes Linux From Scratch 0 09-04-2005 11:20 AM


All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration