LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-11-2008, 04:45 AM   #16
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122

Note that I can't reply to your email because the reply to address is @localhost...
 
Old 03-11-2008, 04:49 AM   #17
djgc
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 15
hmm weird. coz ive been testing it with my companies email account too and I can never recieve emails from my server unless i REPLY to it.
 
Old 03-11-2008, 04:50 AM   #18
djgc
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 15
ok i tried it with my friends GMAIL account and he actually recieved the email!!!..

soo hmmm wut could be the reason for my office account and hotmail not recieving? coz id love to be able to send to hotmail users too since a lot of friends and ppl use hotmail.

ya i noticed that too the address is localhost.domain.
do u know where i change that?

Last edited by djgc; 03-11-2008 at 04:55 AM.
 
Old 03-11-2008, 04:55 AM   #19
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
As I said earlier (I think), myorigin, but it could be a squirrelmail setting too
 
Old 03-11-2008, 04:58 AM   #20
djgc
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 15
ah. coz ive never touched squirrel setting. all i did was yum install it and it did everything. hahaa. coz i was reading this website on how to setup mail server and it never said anything about configuring squirrel. it was mainly configuring dovecot and postfix.
 
Old 03-11-2008, 05:01 AM   #21
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Then change your myorigin setting in main.cf - you set it to hostname rather than mydomain
 
Old 03-11-2008, 05:36 AM   #22
djgc
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 15
i changed myorigin dont seem to change it either. I tried sending an email to another friends office account and she couldnt recieve my mail as well..
This is weirD~~~ argh.. its like selecting mailboxes to get through hahah..
 
Old 03-11-2008, 05:39 AM   #23
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
It is probably reverse DNS as I've said. Where is your domain hosted? You need to set up reverse DNS on your name server.

Basically, a nameserver resolves mail.example.com to IP 1.2.3.4. Reverse DNS checks that 1.2.3.4 resolves to mail.example.com. It's used to catch spam, since most bots will fail this test.
 
Old 03-11-2008, 05:47 AM   #24
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
To update your squirrelmail preferences, run

/usr/share/squirrelmail/config/conf.pl

from a terminal.

You can change the sender and reply address when you are logged into squirrelmail using Options - Personal Information. Note this is different from the 3 lines above
 
Old 03-11-2008, 05:56 AM   #25
djgc
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 15
yes i managed to change it ! and it works. but still some ppl cant recieve emails .. only selective email accounts can it seems.. weird tho. >.<
 
Old 03-11-2008, 05:57 AM   #26
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
What distro are you using - I suspect your hostname isn't set up properly

type hostname and hostname -d in a terminal
 
Old 03-11-2008, 06:04 AM   #27
djgc
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 15
ya its tripped out because if i use REPLY function in web mail the email would get through but COMPOSE doesnt. so that just bugs me out haha.

i tried those 2 commands u listed and this is what showed up.

[root@mail squirrelmail]# hostname
mail.siubeen.com
[root@mail squirrelmail]# hostname -d
siubeen.com
 
Old 03-11-2008, 06:08 AM   #28
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Well that looks OK

Sort out the DNS issue and hopefully you'll be fine.

The other way around it is to relay through your ISP with the relayhost option in main.cf (unless it's a dodgy ISP). What happened when you tried it earlier?
 
Old 03-11-2008, 06:10 AM   #29
djgc
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 15
what DNS issue do i have that you're talking about?

i actually tried relayhost = [myisp_hostname]

but it got denied hahaha =p
 
Old 03-11-2008, 06:22 AM   #30
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Actually, a more likely cause is your clock. The email you sent me are dated 9 hours ahead of me, which isn't a valid timezone. These are probably filtered out by spam filters and the like.

On revers DNS, I gave a short version earlier, but do a search for a longer version.

Your ISP's server is probably called something like mail.your.isp or smtp.your.isp. I'm pretty sure you don't want the square brackets around it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix + Mysql + Sasl SMTP Auth Problem Jukas Linux - Server 0 10-30-2007 11:10 PM
postfix smtp problem(Urgent!!!!) efang Linux - General 2 10-12-2005 09:08 PM
Postfix smtp chroot problem FlyingMoose Debian 1 02-08-2004 02:29 AM
Postfix change smtp problem kelper Linux - Software 0 08-02-2003 04:51 AM
Postfix + pop-before-smtp problem Kostko Linux - Software 3 02-19-2003 01:46 PM


All times are GMT -5. The time now is 07:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration