LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2013, 03:31 AM   #1
Robert84
LQ Newbie
 
Registered: Feb 2013
Posts: 21

Rep: Reputation: Disabled
PKG_CONFIG_PATH environment variable problem


I got this error in installing a numerical code figuring out mpich2 package:

checking pkg-config is at least version 0.9.0... yes
checking for MPICH2... configure: error: Package requirements (mpich2-ch3) were not met:

Variable 'exec_prefix' not defined in '/usr/local/lib/pkgconfig/mpich2-ch3.pc'

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MPICH2_CFLAGS
and MPICH2_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I have looked to the last posts on PKG_CONFIG_PATH:
I add the PKG_CONFIG_PATH with

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH
to find and check the path, I write

echo $PKG_CONFIG_PATH
/usr/local/lib/pkgconfig:/usr/local/lib/pkgconfig

I also type at the end of the .bashrc file the following line
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

when I rerun
./configure
I got the same error, What am I missing here??
 
Old 02-26-2013, 03:43 AM   #2
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 3,014

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
> Variable 'exec_prefix' not defined in '/usr/local/lib/pkgconfig/mpich2-ch3.pc'

Check this file, if it has 'exec_prefix' in it or not. Typical *.pc files look like this:
Code:
prefix=/usr/local
exec_prefix=${prefix}
libdir=${prefix}/lib
includedir=${prefix}/include

Name: slang.
Description: S-Lang programming library and interpreter
URL: http://www.jedsoft.org/slang/
Version: 2.2.2
Libs: -L${libdir} -lslang
Libs.private:  -ldl  -lm
Cflags: -I${includedir}
 
Old 02-26-2013, 07:46 AM   #3
Robert84
LQ Newbie
 
Registered: Feb 2013
Posts: 21

Original Poster
Rep: Reputation: Disabled
My mpich2-ch3.pc file looks like this:

# this gives access to the mpich2 header files

Name: mpich2
Description: MPICH2 is an implementation of the Message-Passing Interface (MPI). The goals of MPICH2 are to provide an MPI implementation for important platforms, including clusters, SMPs, and massively parallel processors. It also provides a vehicle for MPI implementation research and for developing new and better parallel programming environments.
Version: 1.2.1p1
Requires:
Libs: -L${exec_prefix}/lib -lmpich -lmpichcxx -lopa -lpthread
Cflags: -O2 -I${prefix}/include -DMPICH_IGNORE_CXX_SEEK

I am sorry what I have to do now, should I put the path next to {exec_prefix}/usr/local/lib/pkgconfig (like this??)

Please help me
 
Old 02-26-2013, 08:40 AM   #4
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 3,014

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
1. please use [code] and [/code] tags
2. is this file 'official', or you hacked it manually? Anyway, you can insert an exec_prefix line:

Code:
# this gives access to the mpich2 header files
prefix=/usr/local # where-ever it is
exec_prefix=${prefix}

Name: mpich2
Description: MPICH2 is an implementation of the Message-Passing Interface (MPI). The goals of MPICH2 are to provide an MPI implementation for important platforms, including clusters, SMPs, and massively parallel processors. It also provides a vehicle for MPI implementation research and for developing new and better parallel programming environments.
Version: 1.2.1p1
Requires:
Libs: -L${exec_prefix}/lib -lmpich -lmpichcxx -lopa -lpthread
Cflags: -O2 -I${prefix}/include -DMPICH_IGNORE_CXX_SEEK
 
Old 02-26-2013, 09:10 PM   #5
Robert84
LQ Newbie
 
Registered: Feb 2013
Posts: 21

Original Poster
Rep: Reputation: Disabled
thank you I solved this problem, but I got a new one,

giving the command $sh install-titan.sh
I got this as an error:


make all-recursive
make[1]: Entering directory `/home/bob/titan2d/titan-3.0.0'
Making all in src
make[2]: Entering directory `/home/bob/titan2d/titan-3.0.0/src'
Making all in header
make[3]: Entering directory `/home/bob/titan2d/titan-3.0.0/src/header'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/bob/titan2d/titan-3.0.0/src/header'
Making all in gisapi
make[3]: Entering directory `/home/bob/titan2d/titan-3.0.0/src/gisapi'
if /usr/local/bin/mpiCC -DHAVE_CONFIG_H -I. -I. -I../.. -O2 -DMPICH_IGNORE_CXX_SEEK -I/usr/local/lib/pkgconfig/include -I/usr/include -DH5_USE_16_API -DOMPI_IGNORE_CXX_SEEK -MT GdalApi.o -MD -MP -MF ".deps/GdalApi.Tpo" -c -o GdalApi.o GdalApi.cc; \
then mv -f ".deps/GdalApi.Tpo" ".deps/GdalApi.Po"; else rm -f ".deps/GdalApi.Tpo"; exit 1; fi
GdalApi.cc:5:23: fatal error: gdal_priv.h: No such file or directory
compilation terminated.
Makefile:273: recipe for target `GdalApi.o' failed
make[3]: *** [GdalApi.o] Error 1
make[3]: Leaving directory `/home/bob/titan2d/titan-3.0.0/src/gisapi'
Makefile:209: recipe for target `all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/bob/titan2d/titan-3.0.0/src'
Makefile:249: recipe for target `all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/bob/titan2d/titan-3.0.0'
Makefile:187: recipe for target `all' failed
make: *** [all] Error 2


Sorry for this, do you I to solve this problem?
 
Old 02-26-2013, 09:26 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
Quote:
gdal_priv.h: No such file or directory
install the gdal software that has that header

my install of gdal is in "FWTools-x86_64-3.1.0" so it might be different than yours

???/???/FWTools-x86_64-3.1.0/usr/include/gdal_priv.h

that include folder should be set by the gdal install scripts
( i use the fwtools script )
how did you install it ?

if you do have the header in the include folder
export it's location
 
Old 02-26-2013, 10:45 PM   #7
Robert84
LQ Newbie
 
Registered: Feb 2013
Posts: 21

Original Poster
Rep: Reputation: Disabled
I am sorry I am using cygwin in windiws 7, and making the cygcheck for all my packages installed, I have not found the gdal, in cygwin, the installation update is made through the setup. I find this web site for gdal mapping tools: http://lists.maptools.org/pipermail/...ay/002010.html,
What do you think? does it work on cigwin?
 
Old 09-07-2014, 12:43 PM   #8
GRF93
LQ Newbie
 
Registered: Sep 2014
Posts: 2

Rep: Reputation: Disabled
PKG_CONFIG_PATH environment variable problem

I got this error in installing a numerical code figuring out mpich2 package:

checking pkg-config is at least version 0.9.0... yes
checking for MPICH2... configure: error: Package requirements (mpich2-ch3) were not met:

No package 'mpich2-ch3' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.



when I rerun
./configure
I got the same error?
 
Old 09-08-2014, 03:37 AM   #9
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 3,014

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Oh, my mind-reading powers left me... Please give an URL to the software you are trying to compile.
 
Old 09-08-2014, 06:28 AM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Post #8, @GRF93.

No package 'mpich2-ch3' found : `package' means "package config file" :
Like » no file /usr/lib/mpich2-ch3.pc «

* Sorry, there is no ``mpich2-ch3.pc´´ available for any Ubuntu version.
( $ apt-file search mpich2-ch3.pc ).

May be "/usr/lib/<arch>-linux-gnu/pkgconfig/mpich.pc" can be used ?
I.e. install mpich : $ sudo apt-get install libmpich-dev
. http://packages.ubuntu.com/search?ke...searchon=names
. http://packages.ubuntu.com/trusty/i3...h-dev/filelist

-
 
Old 09-08-2014, 12:30 PM   #11
GRF93
LQ Newbie
 
Registered: Sep 2014
Posts: 2

Rep: Reputation: Disabled
ok I understand, but which version of ubuntu is compatible with this package?
The download link is:
http://www.mcs.anl.gov/research/proj...hp?s=downloads
MPICH2-1.5

Thanks in advance
 
Old 09-08-2014, 02:20 PM   #12
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Ref. # 11 .

The package mpich2-1.5.tar.gz from
http://www.mcs.anl.gov/research/proj...hp?s=downloads
.. is source code, and can be installed in any Ubuntu version with :
$ ./configure --prefix=/usr/ --enable-threads=default && make && sudo make install

*** You can watch all the "200" options with $ ./configure --help

?? Any particular reason that you want "1.5",
and not the default Ubuntu "libmpich-dev-<version>" ?

? Which application are you trying to build, with mpich ?

-

Last edited by knudfl; 09-08-2014 at 02:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set PKG_CONFIG_PATH environment variable rahul8705 Linux - Software 4 03-25-2012 10:43 AM
How do I add to the pkg_config_path environment variable? sonichedgehog Linux - Software 2 02-07-2008 05:52 PM
PKG_CONFIG_PATH environment variable mohapi Linux - Software 8 01-11-2004 09:05 PM
Where is the PKG_CONFIG_PATH environment variable? jdruin Linux - Software 4 12-05-2003 09:31 PM
PKG_CONFIG_PATH environment variable hyperriven Linux - Software 2 10-24-2003 09:29 PM


All times are GMT -5. The time now is 07:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration