LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-10-2009, 11:08 AM   #1
macubex
Member
 
Registered: Apr 2009
Posts: 43

Rep: Reputation: Disabled
Permission denied in live cd


when I try to open hard-disk partition of Debian in my system from a live CD, it says permission denied. What should I do to access it?
 
Old 04-10-2009, 11:13 AM   #2
Robhogg
Member
 
Registered: Sep 2004
Location: Old York, North Yorks.
Distribution: Debian 7 (mainly)
Posts: 653

Rep: Reputation: 88
Which live CD are you using, and what's your user id (type id in a console window - the numeric id will be the most useful)? What type is the Debian partition, and what are the permissions on it? Is the partition actually mounted (does it appear in the output from df)?
 
Old 04-10-2009, 12:07 PM   #3
macubex
Member
 
Registered: Apr 2009
Posts: 43

Original Poster
Rep: Reputation: Disabled
I'm using debian(kde,amd64) live cd. In the installed debian, permissions are : 'owner'-r&rw, 'others' and 'group' -read ony; it's ext3. In live cd, it's automatic login. User id for installed linux is 'rajan'. THe partition is shown as 'Unmounted hard-disk volume' in properties ; it doesn't apper in df either.

Last edited by macubex; 04-10-2009 at 12:09 PM.
 
Old 04-10-2009, 12:37 PM   #4
Robhogg
Member
 
Registered: Sep 2004
Location: Old York, North Yorks.
Distribution: Debian 7 (mainly)
Posts: 653

Rep: Reputation: 88
Right - I've not used the debian live disk before, but the disk will need to be mounted before you can access it. In Knoppix, you mount the disk just by clicking on its desktop icon, but if this doesn't work, you may need to open a terminal window to do it. Mounting usually has to be done by root, but most live disks will allow you to become root without a password:
Code:
su # or su - root
mount /dev/*** /mnt
/mnt is commonly provided as a temporary mount point (though you can use another directory). The *** has to be replaced by the identifier of your disk, which could be:

hda1 (first partition on the primary IDE drive, IDE socket 1)
hdd2 (second partition on the secondary drive, IDE socket 2)
sda4 (fourth partition on the first SCSI, SATA or USB drive)

... and so on. If you can't see the identifier displayed anywhere, after becoming root enter fdisk -l. This will show all the partitions on all your "fixed disks", with the identifier in the first column.

Last edited by Robhogg; 04-10-2009 at 01:18 PM.
 
Old 04-10-2009, 01:08 PM   #5
macubex
Member
 
Registered: Apr 2009
Posts: 43

Original Poster
Rep: Reputation: Disabled
Thank you very much for your help.
I got the identifier as hda(only one partition). But when I type the code in Konsole, it says 'you must specify the file system type'.

Last edited by macubex; 04-10-2009 at 01:10 PM.
 
Old 04-10-2009, 01:26 PM   #6
Robhogg
Member
 
Registered: Sep 2004
Location: Old York, North Yorks.
Distribution: Debian 7 (mainly)
Posts: 653

Rep: Reputation: 88
Sorry, I've just realised that I typed the mount command the wrong way around (how embarrassing). It should have been:
Code:
mount /dev/hda1 /mnt #I've corrected it in the post above
If you do need to specify the filesystem still, it is most likely to be ext2, ext3 or reiserfs if it's a Linux filesystem. You use a -t flag to pass it to mount, for example:
Code:
mount -t ext3 /dev/hda1 /mnt
... and you need the 1 after it, even if there's only one partition.

Rob

Edited to add: Just found this. You should be able to get the file system type by running the following as root:
Code:
file -sL /dev/hda1

Last edited by Robhogg; 04-10-2009 at 01:31 PM.
 
Old 04-10-2009, 01:45 PM   #7
macubex
Member
 
Registered: Apr 2009
Posts: 43

Original Poster
Rep: Reputation: Disabled
That worked. Thanks a lot.
 
  


Reply

Tags
hdd, permission


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 05:50 AM
Who are you?: Permission denied pankajsys.engg Linux - Server 1 12-07-2007 07:55 PM
'permission denied" inspite of right permission flags on network drive anirudhvij Linux - Enterprise 8 05-22-2007 06:57 AM
Permission Denied Deag^ Linux - Newbie 2 10-20-2004 03:14 PM
Permission Denied Viper Slackware 7 08-07-2002 09:22 PM


All times are GMT -5. The time now is 01:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration