LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-24-2005, 08:50 AM   #1
Spyker
LQ Newbie
 
Registered: Aug 2005
Location: Slovenia
Distribution: Gentoo
Posts: 4

Rep: Reputation: 0
Unhappy "permission denied"


Hi! I have a problem. When I want to access to /etc/X11/xorg.conf it tells me that I don't have a permission. I tryed to acces there as user and as root but it always tells me that I don't have a permission. What could it be wrong?


P.S.: it also shows me that error on many other paths...
 
Old 08-24-2005, 09:05 AM   #2
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Welcome to LQ!
use "ls -l" to check the permissions and make sure you didn't somehow remove all write access.
 
Old 08-24-2005, 09:09 AM   #3
Spyker
LQ Newbie
 
Registered: Aug 2005
Location: Slovenia
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
If i write "ls-l" in Terminal that's what it comes out: bash: ls-l: command not found

 
Old 08-24-2005, 09:11 AM   #4
geeman2.0
Member
 
Registered: Feb 2005
Location: Ontario, Canada
Distribution: Gentoo, Slackware
Posts: 345

Rep: Reputation: 30
Did you type "ls-l" or "ls -l" (notice the space in the latter)
You need the space there. ls is the command, and -l is an option which tells ls to list the file permissions.
 
Old 08-24-2005, 09:22 AM   #5
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
We're looking for the part that says "_rwxrwxrwx" or something similar at the beginning of the entry.
 
Old 08-24-2005, 09:30 AM   #6
Spyker
LQ Newbie
 
Registered: Aug 2005
Location: Slovenia
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
OK i typed it wrong, but now it shows me this:

total 33
-rwx-------- 1 spyker_ users 14658 Aug 21 22:27 aaa.xorg.conf
drwxr-xr--x 2 spyker_ users 552 Aug 24 15:14 mp3
drwx------- 2 spyker_ users 200 Aug 24 15:21 slike
-rwx------- 1 spyker_ users 14640 Aug 22 17:43 xorg


Is here anything wrong? I don't think that I've removed all write access.


P.S.: how can I copy text from Terminal so I won't have to retype it all?
 
Old 08-24-2005, 01:08 PM   #7
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,432

Rep: Reputation: 196Reputation: 196
How are you trying to access the file? If you are just typing: /etc/X11/xorg.conf - you will get a no permission warning.

You need to open this with a text editor. Try: emacs /etc/X11/xorg.conf
Or, if you just want to read it, try: more /etc/X11/xorg.conf.

Or use any editor from the command line that you are comfortable with.

You should be root though to change this file.
 
Old 08-25-2005, 04:14 AM   #8
Spyker
LQ Newbie
 
Registered: Aug 2005
Location: Slovenia
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
Ok I tryed to access this file now with Emacs but now I don't now how to save my changes

So how do I save changes in Emacs?
 
Old 08-25-2005, 04:38 AM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
To save, use Ctrl-X followed by Ctrl-S.
 
Old 08-25-2005, 11:16 PM   #10
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Well done!
Welcome to Linux!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 05:50 AM
Submount, "permission denied" when writing to floppy as normal user DaneM Linux - Software 5 02-22-2006 03:05 PM
"Permission Denied" for normal users on physical console brycebent Linux - Security 5 07-15-2005 12:42 AM
"permission denied" when I try to send raw data to the sound device. Travis86 Linux - Hardware 2 10-29-2003 10:08 AM
Can't access mounted NFS directory: "permission denied" SparceMatrix Linux - General 6 03-08-2003 02:36 PM


All times are GMT -5. The time now is 06:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration