LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-18-2005, 08:50 PM   #1
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 731

Rep: Reputation: 77
Submount, "permission denied" when writing to floppy as normal user


Hello, everybody.

I'm using Slackware 10.1 with kernel 2.6.12.4 and Submount 0.9. Whenever I try to write to /mnt/floppy (while mounted) I get this error:

Code:
<~/tmp/submount-0.9-33/submount-0.9/subfs-0.9>
[dane@Orchestrator subfs-0.9]$ touch /mnt/floppy/foo
touch: cannot touch `/mnt/floppy/foo': Permission denied
My fstab entry is as follows:

Code:
/dev/fd0 /mnt/floppy subfs fs=floppyfss,user,rw,iocharset=iso8859-1,sync,umask=0 0 0
Any ideas? Your help is well-appreciated.

--Dane
 
Old 08-19-2005, 03:07 AM   #2
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 731

Original Poster
Rep: Reputation: 77
FIXED!

Here's the solution:

Same fstab entry.

Do this:
Code:
cd /mnt
chmod 666 floppy
cd floppy
chmod 666 .
I don't entirely understand why this works, but somehow it does! (The first chmod alone didn't fix it for some reason...)

Hopefully this will help somebody with the same or similar problem.

--Dane
 
Old 08-21-2005, 01:34 PM   #3
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
Thanks for the courtesy of posting your results, so few do.

I think you could combine your solution into 1 line:
Code:
# chmod -R 666 /mnt/floppy
While this doesn't do exactly what your code did, it may be what you really need -- any sub-dirs on the floppy as well the root.

However, I think the correct & permanent fix lies in your fstab; possibly in the umask, or maybe in the UID / GID. Suggest you take a look at the fstab & mount man pages. I don't do floppies or Slack enough to offer you the specific advice you really need, sorry.
 
Old 08-21-2005, 09:01 PM   #4
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 731

Original Poster
Rep: Reputation: 77
Thanks for the input. Now that I think about it, I believe that that chmod command could be put into one line like you said. I tried the umask idea and for some reason "umask=0" didn't work like it should have. Oh well... :-)

Have a good one.

--Dane
 
Old 02-22-2006, 01:34 PM   #5
AlinFaur
LQ Newbie
 
Registered: Jun 2004
Location: Romania
Distribution: RH, SuSE, Slackware, Debian - would like to test many ;-)
Posts: 11

Rep: Reputation: 0
Hi.
I've met about the same problem and I found a way around it: by using a LiveCD (knoppix) i read the /etc/fstab it built and tried to copy that kind of lines.
From what I found, you should use "users" instead of "user" - that way you would allow any user to umount it (not only the user that mounted it).
Also, umask=000,rw and, as a suplementary option, I saw they use exec, so it would be like
/dev/fd0 /mnt/floppy auto noauto,users,exec,rw,umask=000 0 0
 
Old 02-22-2006, 02:05 PM   #6
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 731

Original Poster
Rep: Reputation: 77
Thanks for posting your solution! :-)

--Dane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 04:50 AM
"Permission Denied" for normal users on physical console brycebent Linux - Security 5 07-14-2005 11:42 PM
Permission denied writing to ext2 floppy s34n Linux - General 3 02-06-2005 12:20 PM
normal user want to perform "init 6" by using " sudo acbenny Linux - General 3 08-08-2004 07:41 AM
Permission denied on " ls "for root user itsjvivek Linux - General 12 12-11-2002 07:02 PM


All times are GMT -5. The time now is 10:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration